On 08/24/2017 03:27 PM, Oliver Hartkopp wrote: > > > On 08/02/2017 07:44 PM, Marc Kleine-Budde wrote: >> This patch gives the variables holding the CAN receiver and the receiver >> list a better name by renaming them from "r to "rcv" and "rl" to >> "recv_list". > > Comment not consistent to code. > >> >> Signed-off-by: Marc Kleine-Budde > > Indeed I would suggest 'rcv' and 'rcvlist' > >> - hlist_add_head_rcu(&r->list, rl); >> + hlist_add_head_rcu(&rcv->list, rcv_list); > > would lead to > > > + hlist_add_head_rcu(&rcv->list, rcvlist); > > which looks better to me. We have the spelling with an underscore already in the code: > diff --git a/include/net/netns/can.h b/include/net/netns/can.h > index b106e6ae2e5b..1fcd395ed506 100644 > --- a/include/net/netns/can.h > +++ b/include/net/netns/can.h > @@ -9,6 +9,6 @@ > > struct dev_rcv_lists; > -struct s_stats; > -struct s_pstats; > +struct can_pkg_stats; > +struct can_rcv_lists_stats; Marc -- Pengutronix e.K. | Marc Kleine-Budde | Industrial Linux Solutions | Phone: +49-231-2826-924 | Vertretung West/Dortmund | Fax: +49-5121-206917-5555 | Amtsgericht Hildesheim, HRA 2686 | http://www.pengutronix.de |