All of lore.kernel.org
 help / color / mirror / Atom feed
From: Max Reitz <mreitz@redhat.com>
To: Kevin Wolf <kwolf@redhat.com>, qemu-block@nongnu.org
Cc: eblake@redhat.com, jsnow@redhat.com, armbru@redhat.com,
	jcody@redhat.com, qemu-devel@nongnu.org
Subject: Re: [Qemu-devel] [PATCH 40/42] job: Add query-jobs QMP command
Date: Tue, 15 May 2018 01:09:52 +0200	[thread overview]
Message-ID: <13ad0be2-6966-db50-3a84-31f4e890a6a1@redhat.com> (raw)
In-Reply-To: <20180509162637.15575-41-kwolf@redhat.com>

[-- Attachment #1: Type: text/plain, Size: 7035 bytes --]

On 2018-05-09 18:26, Kevin Wolf wrote:
> This adds a minimal query-jobs implementation that shouldn't pose many
> design questions. It can later be extended to expose more information,
> and especially job-specific information.
> 
> Signed-off-by: Kevin Wolf <kwolf@redhat.com>
> ---
>  qapi/block-core.json | 18 ----------------
>  qapi/job.json        | 59 ++++++++++++++++++++++++++++++++++++++++++++++++++++
>  include/qemu/job.h   |  3 +++
>  job-qmp.c            | 54 +++++++++++++++++++++++++++++++++++++++++++++++
>  job.c                |  2 +-
>  5 files changed, 117 insertions(+), 19 deletions(-)
> 
> diff --git a/qapi/block-core.json b/qapi/block-core.json
> index f2da7d696d..d38dfa7836 100644
> --- a/qapi/block-core.json
> +++ b/qapi/block-core.json
> @@ -1051,24 +1051,6 @@
>    'data': ['top', 'full', 'none', 'incremental'] }
>  
>  ##
> -# @JobType:
> -#
> -# Type of a background job.
> -#
> -# @commit: block commit job type, see "block-commit"
> -#
> -# @stream: block stream job type, see "block-stream"
> -#
> -# @mirror: drive mirror job type, see "drive-mirror"
> -#
> -# @backup: drive backup job type, see "drive-backup"
> -#
> -# Since: 1.7
> -##
> -{ 'enum': 'JobType',
> -  'data': ['commit', 'stream', 'mirror', 'backup'] }
> -
> -##
>  # @JobVerb:
>  #
>  # Represents command verbs that can be applied to a job.
> diff --git a/qapi/job.json b/qapi/job.json
> index 7b84158292..742fa97768 100644
> --- a/qapi/job.json
> +++ b/qapi/job.json
> @@ -5,6 +5,24 @@
>  ##
>  
>  ##
> +# @JobType:
> +#
> +# Type of a background job.
> +#
> +# @commit: block commit job type, see "block-commit"
> +#
> +# @stream: block stream job type, see "block-stream"
> +#
> +# @mirror: drive mirror job type, see "drive-mirror"
> +#
> +# @backup: drive backup job type, see "drive-backup"
> +#
> +# Since: 1.7
> +##
> +{ 'enum': 'JobType',
> +  'data': ['commit', 'stream', 'mirror', 'backup'] }
> +
> +##

FWIW, I'd put this code movement into the hypothetical commit which
specifically adds job.json.

(Same as JobVerb, which is not moved in this series, but which very
likely should be.)

>  # @JobStatus:
>  #
>  # Indicates the present state of a given job in its lifetime.
> @@ -175,3 +193,44 @@
>  # Since: 2.13
>  ##
>  { 'command': 'job-finalize', 'data': { 'id': 'str' } }
> +
> +##
> +# @JobInfo:
> +#
> +# Information about a job.
> +#
> +# @id:                  The job identifier
> +#
> +# @type:                The job type

I'm not really happy with this description that effectively provides no
information that one cannot already get from the field name, but I
cannot come up with something better, so I'd rather stop typing now.

(OK, my issue here is that "job type" can be anything.  That could mean
e.g. "Is this a block job?".   Maybe an explicit reference to JobType
might help here, although that is already part of the documentation.  On
that note, maybe a quote from the documentation might help make my point
that this description is not very useful:

       "type: JobType"
           The job type

Maybe "The kind of job that is being performed"?)

> +# @status:              Current job state/status

Why the "state/status"?  Forgive me my incompetence, but I don't see a
real difference here.  But in any case, one ought to be enough, no?

(OK, full disclosure: My gut tells me "status" is what we now call the
"progress", and this field should be called "state".  But it's called
"status" now and it doesn't really make a difference, so it's fine to
describe it as either.)

> +#
> +# @current-progress:    The current progress value
> +#
> +# @total-progress:      The maximum progress value

Hm, not really.  This makes it sound like at any point, this will be the
maximum even in the future, but that's not true.

Maybe "estimated progress maximum"?  Or be even more verbose (no, that
doesn't hurt): "This is an estimation of the value @current-progress
needs to reach for the job to complete."

(Actually, I find it important to note that it is an estimation, maybe
we event want to be really explicit about the fact that this value may
change all the time, in any direction.)

> +#
> +# @error:               If this field is present, the job failed; if it is
> +#                       still missing in the CONCLUDED state, this indicates
> +#                       successful completion.
> +#
> +#                       The value is a human-readable error message to describe
> +#                       the reason for the job failure. It should not be parsed
> +#                       by applications.
> +#
> +# Since: 2.13
> +##
> +{ 'struct': 'JobInfo',
> +  'data': { 'id': 'str', 'type': 'JobType', 'status': 'JobStatus',
> +            'current-progress': 'int', 'total-progress': 'int',
> +            '*error': 'str' } }
> +
> +##
> +# @query-jobs:
> +#
> +# Return information about jobs.
> +#
> +# Returns: a list with a @JobInfo for each active job
> +#
> +# Since: 2.13
> +##
> +{ 'command': 'query-jobs', 'returns': ['JobInfo'] }

[...]

> diff --git a/job-qmp.c b/job-qmp.c
> index f32cb8b73e..7425a2a490 100644
> --- a/job-qmp.c
> +++ b/job-qmp.c
> @@ -138,3 +138,57 @@ void qmp_job_dismiss(const char *id, Error **errp)
>      job_dismiss(&job, errp);
>      aio_context_release(aio_context);
>  }
> +
> +static JobInfo *job_query_single(Job *job, Error **errp)
> +{
> +    JobInfo *info;
> +    const char *errmsg = NULL;
> +
> +    assert (!job_is_internal(job));

One stray space.

Max

> +
> +    if (job->ret < 0) {
> +        errmsg = strerror(-job->ret);
> +    }
> +
> +    info = g_new(JobInfo, 1);
> +    *info = (JobInfo) {
> +        .id                 = g_strdup(job->id),
> +        .type               = job_type(job),
> +        .status             = job->status,
> +        .current_progress   = job->progress_current,
> +        .total_progress     = job->progress_total,
> +        .has_error          = !!errmsg,
> +        .error              = g_strdup(errmsg),
> +    };
> +
> +    return info;
> +}
> +
> +JobInfoList *qmp_query_jobs(Error **errp)
> +{
> +    JobInfoList *head = NULL, **p_next = &head;
> +    Job *job;
> +
> +    for (job = job_next(NULL); job; job = job_next(job)) {
> +        JobInfoList *elem;
> +        AioContext *aio_context;
> +
> +        if (job_is_internal(job)) {
> +            continue;
> +        }
> +        elem = g_new0(JobInfoList, 1);
> +        aio_context = job->aio_context;
> +        aio_context_acquire(aio_context);
> +        elem->value = job_query_single(job, errp);
> +        aio_context_release(aio_context);
> +        if (!elem->value) {
> +            g_free(elem);
> +            qapi_free_JobInfoList(head);
> +            return NULL;
> +        }
> +        *p_next = elem;
> +        p_next = &elem->next;
> +    }
> +
> +    return head;
> +}


[-- Attachment #2: OpenPGP digital signature --]
[-- Type: application/pgp-signature, Size: 488 bytes --]

  reply	other threads:[~2018-05-14 23:10 UTC|newest]

Thread overview: 146+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-05-09 16:25 [Qemu-devel] [PATCH 00/42] Generic background jobs Kevin Wolf
2018-05-09 16:25 ` [Qemu-devel] [PATCH 01/42] blockjob: Fix assertion in block_job_finalize() Kevin Wolf
2018-05-09 17:28   ` Eric Blake
2018-05-11 21:55   ` Max Reitz
2018-05-11 22:29   ` John Snow
2018-05-09 16:25 ` [Qemu-devel] [PATCH 02/42] blockjob: Wrappers for progress counter access Kevin Wolf
2018-05-11 22:12   ` Max Reitz
2018-05-14 10:16     ` Kevin Wolf
2018-05-14 19:14   ` John Snow
2018-05-09 16:25 ` [Qemu-devel] [PATCH 03/42] blockjob: Move RateLimit to BlockJob Kevin Wolf
2018-05-11 22:14   ` Max Reitz
2018-05-14 19:19   ` John Snow
2018-05-09 16:25 ` [Qemu-devel] [PATCH 04/42] blockjob: Implement block_job_set_speed() centrally Kevin Wolf
2018-05-11 22:19   ` Max Reitz
2018-05-14 19:27   ` John Snow
2018-05-09 16:26 ` [Qemu-devel] [PATCH 05/42] blockjob: Introduce block_job_ratelimit_get_delay() Kevin Wolf
2018-05-11 22:25   ` Max Reitz
2018-05-14 19:36   ` John Snow
2018-05-09 16:26 ` [Qemu-devel] [PATCH 06/42] blockjob: Add block_job_driver() Kevin Wolf
2018-05-11 22:28   ` Max Reitz
2018-05-14 19:43   ` John Snow
2018-05-09 16:26 ` [Qemu-devel] [PATCH 07/42] blockjob: Remove block_job_pause/resume_all() Kevin Wolf
2018-05-09 17:30   ` Eric Blake
2018-05-11 22:30   ` Max Reitz
2018-05-14 19:44     ` John Snow
2018-05-14 19:45     ` Eric Blake
2018-05-09 16:26 ` [Qemu-devel] [PATCH 08/42] job: Create Job, JobDriver and job_create() Kevin Wolf
2018-05-11 22:46   ` Max Reitz
2018-05-14 12:58     ` Kevin Wolf
2018-05-14 19:57   ` John Snow
2018-05-09 16:26 ` [Qemu-devel] [PATCH 09/42] job: Rename BlockJobType into JobType Kevin Wolf
2018-05-11 22:48   ` Max Reitz
2018-05-14 20:05   ` John Snow
2018-05-09 16:26 ` [Qemu-devel] [PATCH 10/42] job: Add JobDriver.job_type Kevin Wolf
2018-05-11 22:53   ` Max Reitz
2018-05-14 11:31     ` Kevin Wolf
2018-05-14 20:12     ` John Snow
2018-05-09 16:26 ` [Qemu-devel] [PATCH 11/42] job: Add job_delete() Kevin Wolf
2018-05-11 22:56   ` Max Reitz
2018-05-14 20:15   ` John Snow
2018-05-16 17:54   ` Eric Blake
2018-05-09 16:26 ` [Qemu-devel] [PATCH 12/42] job: Maintain a list of all jobs Kevin Wolf
2018-05-14 13:59   ` Max Reitz
2018-05-14 20:42   ` John Snow
2018-05-16 18:03   ` Eric Blake
2018-05-09 16:26 ` [Qemu-devel] [PATCH 13/42] job: Move state transitions to Job Kevin Wolf
2018-05-14 14:20   ` Max Reitz
2018-05-14 20:58   ` John Snow
2018-05-16 18:11   ` Eric Blake
2018-05-09 16:26 ` [Qemu-devel] [PATCH 14/42] job: Add reference counting Kevin Wolf
2018-05-14 14:29   ` Max Reitz
2018-05-14 21:34   ` John Snow
2018-05-15  9:06     ` Kevin Wolf
2018-05-16 18:17   ` Eric Blake
2018-05-16 20:56     ` Kevin Wolf
2018-05-16 21:25       ` Eric Blake
2018-05-09 16:26 ` [Qemu-devel] [PATCH 15/42] job: Move cancelled to Job Kevin Wolf
2018-05-14 14:39   ` Max Reitz
2018-05-14 21:53   ` John Snow
2018-05-09 16:26 ` [Qemu-devel] [PATCH 16/42] job: Add Job.aio_context Kevin Wolf
2018-05-14 15:20   ` Max Reitz
2018-05-14 22:02   ` John Snow
2018-05-09 16:26 ` [Qemu-devel] [PATCH 17/42] job: Move defer_to_main_loop to Job Kevin Wolf
2018-05-14 15:52   ` Max Reitz
2018-05-15 12:17     ` Kevin Wolf
2018-05-16 10:51       ` Max Reitz
2018-05-16 18:32         ` Eric Blake
2018-05-14 22:33   ` John Snow
2018-05-15 12:22     ` Kevin Wolf
2018-05-16 18:37   ` Eric Blake
2018-05-09 16:26 ` [Qemu-devel] [PATCH 18/42] job: Move coroutine and related code " Kevin Wolf
2018-05-14 16:47   ` Max Reitz
2018-05-14 23:02   ` John Snow
2018-05-16 16:50     ` Kevin Wolf
2018-05-16 17:38       ` John Snow
2018-05-09 16:26 ` [Qemu-devel] [PATCH 19/42] job: Add job_sleep_ns() Kevin Wolf
2018-05-14 16:57   ` Max Reitz
2018-05-14 23:10   ` John Snow
2018-05-09 16:26 ` [Qemu-devel] [PATCH 20/42] job: Move pause/resume functions to Job Kevin Wolf
2018-05-14 17:13   ` Max Reitz
2018-05-14 23:23   ` John Snow
2018-05-09 16:26 ` [Qemu-devel] [PATCH 21/42] job: Replace BlockJob.completed with job_is_completed() Kevin Wolf
2018-05-14 17:33   ` Max Reitz
2018-05-14 23:43   ` John Snow
2018-05-09 16:26 ` [Qemu-devel] [PATCH 22/42] job: Move BlockJobCreateFlags to Job Kevin Wolf
2018-05-14 17:50   ` Max Reitz
2018-05-16 19:13   ` Eric Blake
2018-05-16 20:53     ` Kevin Wolf
2018-05-09 16:26 ` [Qemu-devel] [PATCH 23/42] blockjob: Split block_job_event_pending() Kevin Wolf
2018-05-14 17:56   ` Max Reitz
2018-05-16 19:15   ` Eric Blake
2018-05-09 16:26 ` [Qemu-devel] [PATCH 24/42] job: Add job_event_*() Kevin Wolf
2018-05-14 18:09   ` Max Reitz
2018-05-09 16:26 ` [Qemu-devel] [PATCH 25/42] job: Move single job finalisation to Job Kevin Wolf
2018-05-14 18:46   ` Max Reitz
2018-05-09 16:26 ` [Qemu-devel] [PATCH 26/42] job: Convert block_job_cancel_async() " Kevin Wolf
2018-05-14 19:00   ` Max Reitz
2018-05-09 16:26 ` [Qemu-devel] [PATCH 27/42] job: Add job_drain() Kevin Wolf
2018-05-14 19:26   ` Max Reitz
2018-05-09 16:26 ` [Qemu-devel] [PATCH 28/42] job: Move .complete callback to Job Kevin Wolf
2018-05-14 19:37   ` Max Reitz
2018-05-09 16:26 ` [Qemu-devel] [PATCH 29/42] job: Move job_finish_sync() " Kevin Wolf
2018-05-14 19:49   ` Max Reitz
2018-05-09 16:26 ` [Qemu-devel] [PATCH 30/42] job: Switch transactions to JobTxn Kevin Wolf
2018-05-14 20:00   ` Max Reitz
2018-05-09 16:26 ` [Qemu-devel] [PATCH 31/42] job: Move transactions to Job Kevin Wolf
2018-05-14 20:28   ` Max Reitz
2018-05-14 21:17   ` Max Reitz
2018-05-09 16:26 ` [Qemu-devel] [PATCH 32/42] job: Move completion and cancellation " Kevin Wolf
2018-05-14 20:53   ` Max Reitz
2018-05-15 12:59     ` Kevin Wolf
2018-05-16 10:52       ` Max Reitz
2018-05-09 16:26 ` [Qemu-devel] [PATCH 33/42] job: Add job_yield() Kevin Wolf
2018-05-14 20:59   ` Max Reitz
2018-05-09 16:26 ` [Qemu-devel] [PATCH 34/42] job: Add job_dismiss() Kevin Wolf
2018-05-14 21:06   ` Max Reitz
2018-05-14 22:26   ` Max Reitz
2018-05-09 16:26 ` [Qemu-devel] [PATCH 35/42] job: Add job_is_ready() Kevin Wolf
2018-05-14 21:11   ` Max Reitz
2018-05-09 16:26 ` [Qemu-devel] [PATCH 36/42] job: Add job_transition_to_ready() Kevin Wolf
2018-05-14 21:22   ` Max Reitz
2018-05-09 16:26 ` [Qemu-devel] [PATCH 37/42] job: Move progress fields to Job Kevin Wolf
2018-05-14 21:33   ` Max Reitz
2018-05-16 21:23   ` Eric Blake
2018-05-09 16:26 ` [Qemu-devel] [PATCH 38/42] job: Add JOB_STATUS_CHANGE QMP event Kevin Wolf
2018-05-14 22:11   ` Max Reitz
2018-05-16 16:15     ` Kevin Wolf
2018-05-16 19:26   ` Eric Blake
2018-05-16 20:46     ` Kevin Wolf
2018-05-16 20:53       ` Eric Blake
2018-05-09 16:26 ` [Qemu-devel] [PATCH 39/42] job: Add lifecycle QMP commands Kevin Wolf
2018-05-14 22:31   ` Max Reitz
2018-05-15 14:08     ` Kevin Wolf
2018-05-16 10:54       ` Max Reitz
2018-05-09 16:26 ` [Qemu-devel] [PATCH 40/42] job: Add query-jobs QMP command Kevin Wolf
2018-05-14 23:09   ` Max Reitz [this message]
2018-05-16 11:21     ` Kevin Wolf
2018-05-16 11:27       ` Max Reitz
2018-05-09 16:26 ` [Qemu-devel] [PATCH 41/42] iotests: Move qmp_to_opts() to VM Kevin Wolf
2018-05-14 23:11   ` Max Reitz
2018-05-09 16:26 ` [Qemu-devel] [PATCH 42/42] qemu-iotests: Test job-* with block jobs Kevin Wolf
2018-05-14 23:44   ` Max Reitz
2018-05-17 13:50     ` Kevin Wolf
2018-05-28 13:07       ` Max Reitz
2018-05-15 14:15 ` [Qemu-devel] [PATCH 00/42] Generic background jobs Kevin Wolf
2018-05-15 14:43   ` Eric Blake

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=13ad0be2-6966-db50-3a84-31f4e890a6a1@redhat.com \
    --to=mreitz@redhat.com \
    --cc=armbru@redhat.com \
    --cc=eblake@redhat.com \
    --cc=jcody@redhat.com \
    --cc=jsnow@redhat.com \
    --cc=kwolf@redhat.com \
    --cc=qemu-block@nongnu.org \
    --cc=qemu-devel@nongnu.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.