All of lore.kernel.org
 help / color / mirror / Atom feed
From: Leonard Crestez <leonard.crestez@nxp.com>
To: "Uwe Kleine-König" <u.kleine-koenig@pengutronix.de>,
	"Dong Aisheng" <aisheng.dong@nxp.com>,
	"Bai Ping" <ping.bai@nxp.com>
Cc: Shawn Guo <shawnguo@kernel.org>, Zhang Rui <rui.zhang@intel.com>,
	Eduardo Valentin <edubezval@gmail.com>,
	linux-pm@vger.kernel.org, kernel@pengutronix.de
Subject: Re: [PATCH 1/4] thermal: imx: Use better parameter names than "val"
Date: Mon, 27 Nov 2017 20:39:31 +0200	[thread overview]
Message-ID: <1511807971.20123.29.camel@nxp.com> (raw)
In-Reply-To: <20171121200225.23316-2-u.kleine-koenig@pengutronix.de>

On Tue, 2017-11-21 at 21:02 +0100, Uwe Kleine-König wrote:
> The values passed to imx_init_calib() and imx_init_temp_grade() are
> read from specific OCOTP values. Use their names (in lower case) as
> parameter name instead of "val" to make the code easier to understand.
> 
> Signed-off-by: Uwe Kleine-König <u.kleine-koenig@pengutronix.de>
> ---
>  drivers/thermal/imx_thermal.c | 10 +++++-----
>  1 file changed, 5 insertions(+), 5 deletions(-)
> 
> diff --git a/drivers/thermal/imx_thermal.c b/drivers/thermal/imx_thermal.c
> index e7d4ffc3de7f..21b8c4c4da3c 100644
> --- a/drivers/thermal/imx_thermal.c
> +++ b/drivers/thermal/imx_thermal.c
> @@ -347,13 +347,13 @@ static struct thermal_zone_device_ops imx_tz_ops = {
>  	.set_trip_temp = imx_set_trip_temp,
>  };
>  
> -static int imx_init_calib(struct platform_device *pdev, u32 val)
> +static int imx_init_calib(struct platform_device *pdev, u32 ocotp_ana1)
>  {
>  	struct imx_thermal_data *data = platform_get_drvdata(pdev);
>  	int t1, n1;
>  	u64 temp64;
>  
> -	if (val == 0 || val == ~0) {
> +	if (ocotp_ana1 == 0 || ocotp_ana1 == ~0) {
>  		dev_err(&pdev->dev, "invalid sensor calibration data\n");
>  		return -EINVAL;
>  	}
> @@ -364,7 +364,7 @@ static int imx_init_calib(struct platform_device *pdev, u32 val)
>  	 * Use universal formula now and only need sensor value @ 25C
>  	 * slope = 0.4297157 - (0.0015976 * 25C fuse)
>  	 */
> -	n1 = val >> 20;
> +	n1 = ocotp_ana1 >> 20;
>  	t1 = 25; /* t1 always 25C */
>  
>  	/*
> @@ -392,12 +392,12 @@ static int imx_init_calib(struct platform_device *pdev, u32 val)
>  	return 0;
>  }
>  
> -static void imx_init_temp_grade(struct platform_device *pdev, u32 val)
> +static void imx_init_temp_grade(struct platform_device *pdev, u32 ocotp_mem0)

On imx7 (thermal not currently supported in upstream) the temperature
grade is in OCOTP_TESTER3. So using a more generic parameter name here
would be preferable or this would have to be changed again later.

Unfortunately I can't find a good reference for the imx7 fusemap. But
the IMX7D Reference Manual mentions a speed grade in 0x440 and
something else for 0x480.

--
Regards,
Leonard

  reply	other threads:[~2017-11-27 18:39 UTC|newest]

Thread overview: 13+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-11-21 20:02 [PATCH 0/4] thermal: imx: cleanup and new formula Uwe Kleine-König
2017-11-21 20:02 ` [PATCH 1/4] thermal: imx: Use better parameter names than "val" Uwe Kleine-König
2017-11-27 18:39   ` Leonard Crestez [this message]
2017-11-27 19:50     ` Uwe Kleine-König
2017-11-28 13:20       ` Leonard Crestez
2017-11-21 20:02 ` [PATCH 2/4] thermal: imx: improve comments describing algorithm for temp calculation Uwe Kleine-König
2017-11-27 18:39   ` Leonard Crestez
2017-11-27 19:52     ` Uwe Kleine-König
2017-11-21 20:02 ` [PATCH 3/4] thermal: imx: use consistent style to write temperatures Uwe Kleine-König
2017-11-27 18:40   ` Leonard Crestez
2017-11-27 19:45     ` Uwe Kleine-König
2017-11-21 20:02 ` [PATCH 4/4] thermal: imx: update to new formula according to NXP AN5215 Uwe Kleine-König
2017-11-27 18:41   ` Leonard Crestez

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1511807971.20123.29.camel@nxp.com \
    --to=leonard.crestez@nxp.com \
    --cc=aisheng.dong@nxp.com \
    --cc=edubezval@gmail.com \
    --cc=kernel@pengutronix.de \
    --cc=linux-pm@vger.kernel.org \
    --cc=ping.bai@nxp.com \
    --cc=rui.zhang@intel.com \
    --cc=shawnguo@kernel.org \
    --cc=u.kleine-koenig@pengutronix.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.