All of lore.kernel.org
 help / color / mirror / Atom feed
From: Daniel Vetter <daniel@ffwll.ch>
To: ville.syrjala@linux.intel.com
Cc: dri-devel@lists.freedesktop.org
Subject: Re: [PATCH 2/7] drm: Rename MODE_UNVERIFIED to MODE_STALE
Date: Fri, 4 Dec 2015 09:18:16 +0100	[thread overview]
Message-ID: <20151204081816.GY10243@phenom.ffwll.local> (raw)
In-Reply-To: <1449177255-9515-3-git-send-email-ville.syrjala@linux.intel.com>

On Thu, Dec 03, 2015 at 11:14:10PM +0200, ville.syrjala@linux.intel.com wrote:
> From: Ville Syrjälä <ville.syrjala@linux.intel.com>
> 
> MODE_UNVERIFIED actually means that the mode came from a previous probe,
> and if the new probe doesn't produce a matching mode it will get pruned
> from the list. Rename the flag to MODE_STALE to better convey the
> meaning.
> 
> Cc: Adam Jackson <ajax@redhat.com>
> Signed-off-by: Ville Syrjälä <ville.syrjala@linux.intel.com>

Will conflict with my massive pile of kerneldoc, but makes sense.

Reviewed-by: Daniel Vetter <daniel.vetter@ffwll.ch>
> ---
>  drivers/gpu/drm/drm_modes.c        | 2 +-
>  drivers/gpu/drm/drm_probe_helper.c | 4 ++--
>  include/drm/drm_modes.h            | 2 +-
>  3 files changed, 4 insertions(+), 4 deletions(-)
> 
> diff --git a/drivers/gpu/drm/drm_modes.c b/drivers/gpu/drm/drm_modes.c
> index 5f79b9334a38..824125b3337f 100644
> --- a/drivers/gpu/drm/drm_modes.c
> +++ b/drivers/gpu/drm/drm_modes.c
> @@ -1073,7 +1073,7 @@ static const char * const drm_mode_status_names[] = {
>  	MODE_STATUS(ONE_SIZE),
>  	MODE_STATUS(NO_REDUCED),
>  	MODE_STATUS(NO_STEREO),
> -	MODE_STATUS(UNVERIFIED),
> +	MODE_STATUS(STALE),
>  	MODE_STATUS(BAD),
>  	MODE_STATUS(ERROR),
>  };
> diff --git a/drivers/gpu/drm/drm_probe_helper.c b/drivers/gpu/drm/drm_probe_helper.c
> index b9b3bd9349ff..2e0c8bfacd35 100644
> --- a/drivers/gpu/drm/drm_probe_helper.c
> +++ b/drivers/gpu/drm/drm_probe_helper.c
> @@ -143,9 +143,9 @@ static int drm_helper_probe_single_connector_modes_merge_bits(struct drm_connect
>  
>  	DRM_DEBUG_KMS("[CONNECTOR:%d:%s]\n", connector->base.id,
>  			connector->name);
> -	/* set all modes to the unverified state */
> +	/* set all old modes to the stale state */
>  	list_for_each_entry(mode, &connector->modes, head)
> -		mode->status = MODE_UNVERIFIED;
> +		mode->status = MODE_STALE;
>  
>  	old_status = connector->status;
>  
> diff --git a/include/drm/drm_modes.h b/include/drm/drm_modes.h
> index f9115aee43f4..71801229ce9d 100644
> --- a/include/drm/drm_modes.h
> +++ b/include/drm/drm_modes.h
> @@ -72,7 +72,7 @@ enum drm_mode_status {
>      MODE_ONE_SIZE,      /* only one resolution is supported */
>      MODE_NO_REDUCED,    /* monitor doesn't accept reduced blanking */
>      MODE_NO_STEREO,	/* stereo modes not supported */
> -    MODE_UNVERIFIED = -3, /* mode needs to reverified */
> +    MODE_STALE = -3,	/* mode has become stale */
>      MODE_BAD = -2,	/* unspecified reason */
>      MODE_ERROR	= -1	/* error condition */
>  };
> -- 
> 2.4.10
> 
> _______________________________________________
> dri-devel mailing list
> dri-devel@lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/dri-devel

-- 
Daniel Vetter
Software Engineer, Intel Corporation
http://blog.ffwll.ch
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/dri-devel

  reply	other threads:[~2015-12-04  8:18 UTC|newest]

Thread overview: 24+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-12-03 21:14 [PATCH 0/7] drm: Fix mode pruning ville.syrjala
2015-12-03 21:14 ` [PATCH 1/7] drm: Don't overwrite UNVERFIED mode status to OK ville.syrjala
2015-12-04  8:17   ` Daniel Vetter
2015-12-04  8:17     ` Daniel Vetter
2015-12-04 12:23     ` Ville Syrjälä
2015-12-04 12:23       ` Ville Syrjälä
2015-12-10 21:07     ` Ville Syrjälä
2015-12-10 21:07       ` Ville Syrjälä
2015-12-03 21:14 ` [PATCH 2/7] drm: Rename MODE_UNVERIFIED to MODE_STALE ville.syrjala
2015-12-04  8:18   ` Daniel Vetter [this message]
2015-12-10 20:39   ` [PATCH v2 " ville.syrjala
2015-12-03 21:14 ` [PATCH 3/7] drm: Reindent enum drm_mode_status ville.syrjala
2015-12-04  8:18   ` Daniel Vetter
2015-12-04  9:15     ` Ville Syrjälä
2015-12-03 21:14 ` [PATCH 4/7] drm: Flatten drm_mode_connector_list_update() a bit ville.syrjala
2015-12-04  8:19   ` Daniel Vetter
2015-12-03 21:14 ` [PATCH 5/7] drm: Only merge mode type bits between new probed modes ville.syrjala
2015-12-04  8:29   ` Daniel Vetter
2015-12-04 13:13   ` [PATCH v2 " ville.syrjala
2015-12-03 21:14 ` [PATCH 6/7] drm: Drop drm_helper_probe_single_connector_modes_nomerge() ville.syrjala
2015-12-04  8:30   ` Daniel Vetter
2015-12-03 21:14 ` [PATCH 7/7] drm/sti: Drop bogus drm_mode_sort() call ville.syrjala
2015-12-04  8:31   ` Daniel Vetter
2015-12-11  8:34 ` [PATCH 0/7] drm: Fix mode pruning Daniel Vetter

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20151204081816.GY10243@phenom.ffwll.local \
    --to=daniel@ffwll.ch \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=ville.syrjala@linux.intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.