All of lore.kernel.org
 help / color / mirror / Atom feed
From: Jiri Olsa <jolsa@redhat.com>
To: Ian Rogers <irogers@google.com>
Cc: Jiri Olsa <jolsa@kernel.org>,
	Arnaldo Carvalho de Melo <acme@kernel.org>,
	lkml <linux-kernel@vger.kernel.org>,
	Ingo Molnar <mingo@kernel.org>,
	Namhyung Kim <namhyung@kernel.org>,
	Alexander Shishkin <alexander.shishkin@linux.intel.com>,
	Peter Zijlstra <a.p.zijlstra@chello.nl>,
	Michael Petlan <mpetlan@redhat.com>,
	Andi Kleen <ak@linux.intel.com>, Kajol Jain <kjain@linux.ibm.com>,
	John Garry <john.garry@huawei.com>,
	"Paul A. Clarke" <pc@us.ibm.com>,
	Stephane Eranian <eranian@google.com>
Subject: Re: [PATCH 16/18] perf metric: Add recursion check when processing nested metrics
Date: Wed, 15 Jul 2020 23:29:23 +0200	[thread overview]
Message-ID: <20200715212923.GT183694@krava> (raw)
In-Reply-To: <CAP-5=fUdUKmsGMxsyxxZCzmwRAumLmj6LgGrXWe7APPZRRC=WA@mail.gmail.com>

On Wed, Jul 15, 2020 at 10:40:41AM -0700, Ian Rogers wrote:
> On Sun, Jul 12, 2020 at 6:27 AM Jiri Olsa <jolsa@kernel.org> wrote:
> >
> > Keeping the stack of nested metrics via 'struct expr_id' objecs
> 
> s/objecs/objects/
> 
> > and checking if we are in recursion via already processed metric.
> >
> > The stack is implemented as static array within the struct egroup
> > with 100 entries, which should be enough nesting depth for any
> > metric we have or plan to have at the moment.
> >
> > Adding test that simulates the recursion and checks we can
> > detect it.
> >
> > Signed-off-by: Jiri Olsa <jolsa@kernel.org>
> > ---
> >  tools/perf/tests/parse-metric.c |  27 ++++++++-
> >  tools/perf/util/expr.c          |   2 +
> >  tools/perf/util/expr.h          |   9 ++-
> >  tools/perf/util/metricgroup.c   | 101 +++++++++++++++++++++++++++++---
> >  4 files changed, 128 insertions(+), 11 deletions(-)
> >
> > diff --git a/tools/perf/tests/parse-metric.c b/tools/perf/tests/parse-metric.c
> > index b50e2a3f3b73..238a805edd55 100644
> > --- a/tools/perf/tests/parse-metric.c
> > +++ b/tools/perf/tests/parse-metric.c
> > @@ -57,6 +57,14 @@ static struct pmu_event pme_test[] = {
> >         .metric_expr    = "d_ratio(DCache_L2_All_Miss, DCache_L2_All)",
> >         .metric_name    = "DCache_L2_Misses",
> >  },
> > +{
> > +       .metric_expr    = "IPC + M2",
> > +       .metric_name    = "M1",
> > +},
> > +{
> > +       .metric_expr    = "IPC + M1",
> > +       .metric_name    = "M2",
> > +},
> >  };
> 
> Perhaps add a test on simple recursion too:
> {
>   .metric_expr = "1/M1",
>   .metric_name = "M1",
> }

ok, will add

SNIP

> > diff --git a/tools/perf/util/metricgroup.c b/tools/perf/util/metricgroup.c
> > index 66f25362702d..69ec20dd737b 100644
> > --- a/tools/perf/util/metricgroup.c
> > +++ b/tools/perf/util/metricgroup.c
> > @@ -24,6 +24,7 @@
> >  #include <subcmd/parse-options.h>
> >  #include <api/fs/fs.h>
> >  #include "util.h"
> > +#include <asm/bug.h>
> >
> >  struct metric_event *metricgroup__lookup(struct rblist *metric_events,
> >                                          struct evsel *evsel,
> > @@ -109,6 +110,8 @@ struct metric_ref_node {
> >         struct list_head list;
> >  };
> >
> > +#define RECURSION_ID_MAX 100
> > +
> >  struct egroup {
> >         struct list_head nd;
> >         struct expr_parse_ctx pctx;
> > @@ -119,6 +122,11 @@ struct egroup {
> >         int refs_cnt;
> >         int runtime;
> >         bool has_constraint;
> > +
> > +       struct {
> > +               struct expr_id  id[RECURSION_ID_MAX];
> > +               int             cnt;
> > +       } recursion;
> >  };
> 
> Rather than place this in the egroup why not pass a "visited" array to
> add metric. This would be more in keeping with Tarjan's algorithm
> (although the SCC isn't needed in this case):
> https://en.wikipedia.org/wiki/Tarjan%27s_strongly_connected_components_algorithm

it's true that it's just source of the 'struct expr_id' objects and
one global array could be used in multiple metrics not event directly
nested ... seems good, will check

thanks,
jirka


  reply	other threads:[~2020-07-15 21:29 UTC|newest]

Thread overview: 58+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-07-12 13:26 [PATCH 00/18] perf metric: Add support to reuse metric Jiri Olsa
2020-07-12 13:26 ` [PATCH 01/18] perf metric: Rename expr__add_id to expr__add_val Jiri Olsa
2020-07-14 21:05   ` Ian Rogers
2020-07-16 15:25     ` Arnaldo Carvalho de Melo
2020-07-12 13:26 ` [PATCH 02/18] perf metric: Add struct expr_id_data to keep expr value Jiri Olsa
2020-07-14 21:06   ` Ian Rogers
2020-07-16 15:26     ` Arnaldo Carvalho de Melo
2020-07-12 13:26 ` [PATCH 03/18] perf metric: Add expr__add_id function Jiri Olsa
2020-07-16 15:29   ` Arnaldo Carvalho de Melo
2020-07-16 18:51     ` Jiri Olsa
2020-07-12 13:26 ` [PATCH 04/18] perf metric: Change expr__get_id to return struct expr_id_data Jiri Olsa
2020-07-12 13:26 ` [PATCH 05/18] perf metric: Add expr__del_id function Jiri Olsa
2020-07-14 21:07   ` Ian Rogers
2020-07-12 13:26 ` [PATCH 06/18] perf metric: Add find_metric function Jiri Olsa
2020-07-14 21:09   ` Ian Rogers
2020-07-12 13:26 ` [PATCH 07/18] perf metric: Add add_metric function Jiri Olsa
2020-07-14 21:11   ` Ian Rogers
2020-07-15 21:01     ` Jiri Olsa
2020-07-12 13:26 ` [PATCH 08/18] perf metric: Rename __metricgroup__add_metric to __add_metric Jiri Olsa
2020-07-14 21:11   ` Ian Rogers
2020-07-12 13:26 ` [PATCH 09/18] perf metric: Collect referenced metrics in struct metric_ref_node Jiri Olsa
2020-07-15  0:07   ` Ian Rogers
2020-07-15 21:13     ` Jiri Olsa
2020-07-15 22:05       ` Ian Rogers
2020-07-12 13:26 ` [PATCH 10/18] perf metric: Collect referenced metrics in struct metric_expr Jiri Olsa
2020-07-15  0:09   ` Ian Rogers
2020-07-12 13:26 ` [PATCH 11/18] perf metric: Add referenced metrics to hash data Jiri Olsa
2020-07-13 16:27   ` John Garry
2020-07-13 16:56     ` Jiri Olsa
2020-07-15 18:25   ` Ian Rogers
2020-07-15 21:36     ` Jiri Olsa
2020-07-17 13:51       ` Jiri Olsa
2020-07-12 13:26 ` [PATCH 12/18] perf metric: Compute referenced metrics Jiri Olsa
2020-07-15  0:12   ` Ian Rogers
2020-07-12 13:26 ` [PATCH 13/18] perf metric: Add events for the current group Jiri Olsa
2020-07-15 17:00   ` Ian Rogers
2020-07-15 21:19     ` Jiri Olsa
2020-07-15 22:14       ` Ian Rogers
2020-07-16 10:44         ` Jiri Olsa
2020-07-12 13:26 ` [PATCH 14/18] perf metric: Add cache_miss_cycles to metric parse test Jiri Olsa
2020-07-15 17:04   ` Ian Rogers
2020-07-12 13:26 ` [PATCH 15/18] perf metric: Add DCache_L2 " Jiri Olsa
2020-07-15 17:01   ` Ian Rogers
2020-07-12 13:26 ` [PATCH 16/18] perf metric: Add recursion check when processing nested metrics Jiri Olsa
2020-07-15 17:40   ` Ian Rogers
2020-07-15 21:29     ` Jiri Olsa [this message]
2020-07-12 13:26 ` [PATCH 17/18] perf metric: Rename struct egroup to metric Jiri Olsa
2020-07-15 17:42   ` Ian Rogers
2020-07-12 13:26 ` [PATCH 18/18] perf metric: Rename group_list to list Jiri Olsa
2020-07-15 18:04   ` Ian Rogers
2020-07-15 21:32     ` Jiri Olsa
2020-07-15 18:33 ` [PATCH 00/18] perf metric: Add support to reuse metric Paul A. Clarke
2020-07-15 21:41   ` Jiri Olsa
2020-07-16  1:25     ` Paul A. Clarke
2020-07-16 11:31       ` Jiri Olsa
2020-07-16  7:50 ` John Garry
2020-07-16 11:32   ` Jiri Olsa
2020-07-17 20:03     ` Jiri Olsa

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200715212923.GT183694@krava \
    --to=jolsa@redhat.com \
    --cc=a.p.zijlstra@chello.nl \
    --cc=acme@kernel.org \
    --cc=ak@linux.intel.com \
    --cc=alexander.shishkin@linux.intel.com \
    --cc=eranian@google.com \
    --cc=irogers@google.com \
    --cc=john.garry@huawei.com \
    --cc=jolsa@kernel.org \
    --cc=kjain@linux.ibm.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@kernel.org \
    --cc=mpetlan@redhat.com \
    --cc=namhyung@kernel.org \
    --cc=pc@us.ibm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.