All of lore.kernel.org
 help / color / mirror / Atom feed
From: AKASHI Takahiro <takahiro.akashi@linaro.org>
To: u-boot@lists.denx.de
Subject: [PATCH v6 01/17] dfu: rename dfu_tftp_write() to dfu_write_by_name()
Date: Fri, 18 Sep 2020 10:28:57 +0900	[thread overview]
Message-ID: <20200918012857.GA29654@laputa> (raw)
In-Reply-To: <20200911024139.GP7259@bill-the-cat>

Tom, Lukasz,

On Thu, Sep 10, 2020 at 10:41:39PM -0400, Tom Rini wrote:
> On Fri, Sep 11, 2020 at 09:46:14AM +0900, AKASHI Takahiro wrote:
> > On Wed, Sep 09, 2020 at 10:26:34PM -0400, Tom Rini wrote:
> > > On Thu, Sep 10, 2020 at 10:54:18AM +0900, AKASHI Takahiro wrote:
> > > > On Wed, Sep 09, 2020 at 02:30:53PM +0200, Heinrich Schuchardt wrote:
> > > > > On 07.09.20 07:34, AKASHI Takahiro wrote:
> > > > > > This function is essentially independent from tftp, and will also be
> > > > > > utilised in implementing UEFI capsule update in a later commit.
> > > > > > So just give it a more generic name.
> > > > > > In addition, a new configuration option, CONFIG_DFU_ALT, was introduced
> > > > > > so that the file will be compiled with different options, particularly
> > > > > > one added in a later commit.
> > > > > >
> > > > > > Signed-off-by: AKASHI Takahiro <takahiro.akashi@linaro.org>
> > > > > > ---
> > > > > >  common/update.c                       |  5 +++--
> > > > > >  drivers/dfu/Kconfig                   |  5 +++++
> > > > > >  drivers/dfu/Makefile                  |  2 +-
> > > > > >  drivers/dfu/{dfu_tftp.c => dfu_alt.c} | 17 ++++++++++++--
> > > > > >  include/dfu.h                         | 32 +++++++++++++--------------
> > > > > >  5 files changed, 40 insertions(+), 21 deletions(-)
> > > > > >  rename drivers/dfu/{dfu_tftp.c => dfu_alt.c} (67%)
> > > > > >
> > > > > > diff --git a/common/update.c b/common/update.c
> > > > > > index 36b6b7523d50..39946776d74f 100644
> > > > > > --- a/common/update.c
> > > > > > +++ b/common/update.c
> > > > > > @@ -324,8 +324,9 @@ got_update_file:
> > > > > >  			}
> > > > > >  		} else if (fit_image_check_type(fit, noffset,
> > > > > >  						IH_TYPE_FIRMWARE)) {
> > > > > > -			ret = dfu_tftp_write(fit_image_name, update_addr,
> > > > > > -					     update_size, interface, devstring);
> > > > > > +			ret = dfu_write_by_name(fit_image_name, update_addr,
> > > > > > +						update_size, interface,
> > > > > > +						devstring);
> > > > > >  			if (ret)
> > > > > >  				return ret;
> > > > > >  		}
> > > > > > diff --git a/drivers/dfu/Kconfig b/drivers/dfu/Kconfig
> > > > > > index 0eec00ba734d..78f901ff348a 100644
> > > > > > --- a/drivers/dfu/Kconfig
> > > > > > +++ b/drivers/dfu/Kconfig
> > > > > > @@ -14,8 +14,13 @@ config DFU_OVER_TFTP
> > > > > >  	depends on NET
> > > > > >
> > > > > >  if DFU
> > > > > > +config DFU_ALT
> > > > > > +	bool
> > > > > 
> > > > > You cannot define CONFIG_DFU_ALT as bool. This symbol already exists as
> > > > > string in include/configs/odroid.h, include/configs/s5p_goni.h, et.al.
> > > > > It is used to initialize environment variable dfu_alt_info. Your patch
> > > > > leads to an error on Travis:
> > > > > 
> > > > >        arm:  +   odroid
> > > > 
> > > > Okay, will fix it.
> > > > DFU_WRITE_ALT? Or, as Heinrich suggested, move them
> > > > to dfu.c if Lukasz agrees.
> > > > 
> > > > # I haven't seen any comments from him yet though.
> > > 
> > > I think what you're introducing as "CONFIG_DFU_ALT" and renaming
> > > "drivers/dfu/dfu_tftp.c" to "drivers/dfu/dfu_alt.c" is what's confusing.
> > > That I think needs a different name than "alt" to convey that it's a
> > > generic "from DRAM to flash/etc" hook.
> > 
> > Whatever the name is, I need reviews on all of my DFU patches from Lukasz
> > in the first place.
> 
> The lower impact on the rest of the DFU subsytem and other automated
> testing that can be done, the easier it can be for someone else to
> review the DFU parts if Lukasz isn't able to find time to do it.

It sounds nice, but who will take that role?

Please name that person(s) if you're still busy on other stuffs.
        -> Lukasz

-Takahiro Akashi

> Thanks.
> 
> -- 
> Tom

  reply	other threads:[~2020-09-18  1:28 UTC|newest]

Thread overview: 35+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-09-07  5:34 [PATCH v6 00/17] efi_loader: add capsule update support AKASHI Takahiro
2020-09-07  5:34 ` [PATCH v6 01/17] dfu: rename dfu_tftp_write() to dfu_write_by_name() AKASHI Takahiro
2020-09-09 12:30   ` Heinrich Schuchardt
2020-09-10  1:54     ` AKASHI Takahiro
2020-09-10  2:26       ` Tom Rini
2020-09-11  0:46         ` AKASHI Takahiro
2020-09-11  2:41           ` Tom Rini
2020-09-18  1:28             ` AKASHI Takahiro [this message]
2020-09-18  1:32               ` Tom Rini
2020-09-18  8:08                 ` Lukasz Majewski
2020-09-07  5:34 ` [PATCH v6 02/17] dfu: modify an argument type for an address AKASHI Takahiro
2020-09-07  5:34 ` [PATCH v6 03/17] common: update: add a generic interface for FIT image AKASHI Takahiro
2020-09-07  5:34 ` [PATCH v6 04/17] dfu: export dfu_list AKASHI Takahiro
2020-09-07  5:34 ` [PATCH v6 05/17] efi_loader: add option to initialise EFI subsystem early AKASHI Takahiro
2020-09-07  5:34 ` [PATCH v6 06/17] efi_loader: add efi_create_indexed_name() AKASHI Takahiro
2020-09-07  5:34 ` [PATCH v6 07/17] efi_loader: define UpdateCapsule api AKASHI Takahiro
2020-09-07  5:34 ` [PATCH v6 08/17] efi_loader: capsule: add capsule_on_disk support AKASHI Takahiro
2020-09-07  5:34 ` [PATCH v6 09/17] efi_loader: capsule: add memory range capsule definitions AKASHI Takahiro
2020-09-07  5:34 ` [PATCH v6 10/17] efi_loader: capsule: support firmware update AKASHI Takahiro
2020-09-07  5:34 ` [PATCH v6 11/17] efi_loader: add firmware management protocol for FIT image AKASHI Takahiro
2020-09-07  5:34 ` [PATCH v6 12/17] dfu: add dfu_write_by_alt() AKASHI Takahiro
2020-09-07  5:34 ` [PATCH v6 13/17] efi_loader: add firmware management protocol for raw image AKASHI Takahiro
2020-09-07  5:34 ` [PATCH v6 14/17] cmd: add "efidebug capsule" command AKASHI Takahiro
2020-09-07  5:34 ` [PATCH v6 15/17] tools: add mkeficapsule command for UEFI capsule update AKASHI Takahiro
2020-09-07  5:34 ` [PATCH v6 16/17] test/py: efi_capsule: test for FIT image capsule AKASHI Takahiro
2020-09-07  5:34 ` [PATCH v6 17/17] test/py: efi_capsule: test for raw " AKASHI Takahiro
2020-09-09 14:48 ` [PATCH v6 00/17] efi_loader: add capsule update support Heinrich Schuchardt
2020-09-09 16:56   ` Tom Rini
2020-09-10  2:52     ` AKASHI Takahiro
2020-09-10  2:58       ` Tom Rini
2020-09-11  0:52         ` AKASHI Takahiro
2020-09-11  1:02           ` Tom Rini
2020-09-11  2:31             ` AKASHI Takahiro
2020-09-11  2:44               ` Tom Rini
2020-09-10  2:43   ` AKASHI Takahiro

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200918012857.GA29654@laputa \
    --to=takahiro.akashi@linaro.org \
    --cc=u-boot@lists.denx.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.