From mboxrd@z Thu Jan 1 00:00:00 1970 From: Bin Meng Date: Tue, 19 Nov 2019 16:02:36 +0800 Subject: [U-Boot] [PATCH v3 063/108] x86: Add an option to include a FIT In-Reply-To: <20191021033913.220758-63-sjg@chromium.org> References: <20191021033913.220758-22-sjg@chromium.org> <20191021033913.220758-63-sjg@chromium.org> Message-ID: List-Id: MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit To: u-boot@lists.denx.de On Mon, Oct 21, 2019 at 11:40 AM Simon Glass wrote: > > Many Intel SoCs require a FIT in order to boot properly. Add an option to > include this and enable it by default. > > Signed-off-by: Simon Glass > --- > > Changes in v3: > - Add help to CONFIG_FIT and don't make it 'default y' The changelog says "dont make it default y", but the commit message and the codes are still "default y". > > Changes in v2: None > > arch/x86/Kconfig | 9 +++++++++ > arch/x86/dts/u-boot.dtsi | 6 ++++++ > 2 files changed, 15 insertions(+) > > diff --git a/arch/x86/Kconfig b/arch/x86/Kconfig > index cbd3fc4f581..54f51e002b8 100644 > --- a/arch/x86/Kconfig > +++ b/arch/x86/Kconfig > @@ -217,6 +217,15 @@ config SYS_X86_START16 > depends on X86_RESET_VECTOR > default 0xfffff800 > > +config X86_HAS_FIT Can we rename this to HAVE_FIT? to be in consistent with other options like HAVE_INTEL_ME, HAVE_FSP? > + bool > + default y > + help > + Enable inclusion of an Intel Firmware Interface Table (FIT) into the > + image. This table is supposed to point to microcode and the like. So > + far it is just a fixed table with the minimum set of headers, so that > + it is actually present. > + > config X86_LOAD_FROM_32_BIT > bool "Boot from a 32-bit program" > help > diff --git a/arch/x86/dts/u-boot.dtsi b/arch/x86/dts/u-boot.dtsi > index 0e87b88e105..049f47c9ffd 100644 > --- a/arch/x86/dts/u-boot.dtsi > +++ b/arch/x86/dts/u-boot.dtsi > @@ -82,6 +82,12 @@ > u-boot-ucode { > align = <16>; > }; > +#ifdef CONFIG_X86_HAS_FIT > + intel-fit { > + }; > + intel-fit-ptr { > + }; > +#endif > #ifdef CONFIG_HAVE_MRC > intel-mrc { > offset = ; > -- Regards, Bin