From mboxrd@z Thu Jan 1 00:00:00 1970 From: Masahiro Yamada Date: Tue, 19 May 2015 10:41:34 +0900 Subject: [U-Boot] [PATCH v4 05/10] moveconfig: Cleanup headers in arch and board In-Reply-To: <1431726052-6519-5-git-send-email-joe.hershberger@ni.com> References: <1431556137-8426-1-git-send-email-joe.hershberger@ni.com> <1431726052-6519-1-git-send-email-joe.hershberger@ni.com> <1431726052-6519-5-git-send-email-joe.hershberger@ni.com> Message-ID: List-Id: MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit To: u-boot@lists.denx.de Hi Joe, 2015-05-16 6:40 GMT+09:00 Joe Hershberger : > Some config.h files live in arch and board directories. They will need > to be cleaned up as well, so run the same filters there. > > Signed-off-by: Joe Hershberger > > --- > > Changes in v4: > -New for version 4 > > Changes in v3: None > Changes in v2: None > > tools/moveconfig.py | 10 ++++++++++ > 1 file changed, 10 insertions(+) > > diff --git a/tools/moveconfig.py b/tools/moveconfig.py > index b6db058..25cee21 100755 > --- a/tools/moveconfig.py > +++ b/tools/moveconfig.py > @@ -352,6 +352,16 @@ def cleanup_headers(config_attrs, dry_run): > if not fnmatch.fnmatch(filename, '*~'): > cleanup_one_header(os.path.join(dirpath, filename), patterns, > dry_run) > + for (dirpath, dirnames, filenames) in os.walk('arch'): > + for filename in filenames: > + if not fnmatch.fnmatch(filename, '*~'): > + cleanup_one_header(os.path.join(dirpath, filename), patterns, > + dry_run) > + for (dirpath, dirnames, filenames) in os.walk('board'): > + for filename in filenames: > + if not fnmatch.fnmatch(filename, '*~'): > + cleanup_one_header(os.path.join(dirpath, filename), patterns, > + dry_run) To reduce code duplication, can we write like this or something? for dir in 'include', 'arch', 'board': for (dirpath, dirnames, filenames) in os.walk(dir): for filename in filenames: if not fnmatch.fnmatch(filename, '*~'): cleanup_one_header(os.path.join(dirpath, filename), patterns, dry_run) -- Best Regards Masahiro Yamada