On Mon, Apr 26, 2021 at 3:13 AM Peter Maydell wrote: > On Mon, 26 Apr 2021 at 10:01, Daniel P. Berrangé > wrote: > > > > On Fri, Apr 23, 2021 at 02:39:50PM -0600, imp@bsdimp.com wrote: > > > -#define TARGET_FREEBSD_MAP_RESERVED0080 0x0080 /* previously > misimplemented MAP_INHERIT */ > > > -#define TARGET_FREEBSD_MAP_RESERVED0100 0x0100 /* previously > unimplemented MAP_NOEXTEND */ > > > -#define TARGET_FREEBSD_MAP_STACK 0x0400 /* region grows down, > like a stack */ > > > -#define TARGET_FREEBSD_MAP_NOSYNC 0x0800 /* page to but do not > sync underlying file */ > > > +#define TARGET_FREEBSD_MAP_RESERVED0080 0x0080 > > > + /* previously misimplemented > MAP_INHERIT */ > > > +#define TARGET_FREEBSD_MAP_RESERVED0100 0x0100 > > > + /* previously unimplemented > MAP_NOEXTEND */ > > > +#define TARGET_FREEBSD_MAP_STACK 0x0400 > > > + /* region grows down, like a stack */ > > > +#define TARGET_FREEBSD_MAP_NOSYNC 0x0800 > > > + /* page to but do not sync > underlying file */ > > > > I find this indented following comment style more ambiguous as to > > what constant the comment applies to. IMHO would be clearer as > > > > /* previously misimplemented MAP_INHERIT */ > > #define TARGET_FREEBSD_MAP_RESERVED0080 0x0080 > > > > /* previously unimplemented MAP_NOEXTEND */ > > #define TARGET_FREEBSD_MAP_RESERVED0100 0x0100 > > > > /* region grows down, like a stack */ > > #define TARGET_FREEBSD_MAP_STACK 0x0400 > > > > /* page to but do not sync underlying file */ > > #define TARGET_FREEBSD_MAP_NOSYNC 0x0800 > > Or alternatively decide that this is one of those cases where the coding > style's "If wrapping the line at 80 columns is obviously less readable and > more awkward, prefer not to wrap it" advice applies. The lines as they > stand > are only 95 characters or so long. > I'm cool either way. Projects differ about how rigid or flexible style can be. I noticed this when cleaning up another thing. If we can apply that advice, I'd prefer that. Maybe it's better to just drop this entirely. In the final state, this file is here, but none of these flags are actually used. Not sure why they aren't, but there's commentary that's explicit about using the host constants in many places. Rather than take the time to sort this all out right now (it is a minor detail I think in the scheme of things compared to all the other changes coming), I'd propose dropping this hunk entirely, and revisiting when the merging is done... Warner