All of lore.kernel.org
 help / color / mirror / Atom feed
From: David Herrmann <dh.herrmann@gmail.com>
To: Benjamin Tissoires <benjamin.tissoires@redhat.com>
Cc: Benjamin Tissoires <benjamin.tissoires@gmail.com>,
	Jiri Kosina <jkosina@suse.cz>,
	"open list:HID CORE LAYER" <linux-input@vger.kernel.org>,
	linux-kernel <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH 12/14] HID: hidraw: replace hid_output_raw_report() calls by appropriates ones
Date: Wed, 12 Feb 2014 11:49:49 +0100	[thread overview]
Message-ID: <CANq1E4RvnReiak20x2HPeZ6evYzDuVnLtbT9-WNeZR9yQbeHXg@mail.gmail.com> (raw)
In-Reply-To: <1392055139-19631-13-git-send-email-benjamin.tissoires@redhat.com>

Hi

On Mon, Feb 10, 2014 at 6:58 PM, Benjamin Tissoires
<benjamin.tissoires@redhat.com> wrote:
> Remove hid_output_raw_report() call as it is not a ll_driver callbacj,
> and switch to the hid_hw_* implementation. USB-HID used to fallback
> into SET_REPORT when there were no output interrupt endpoint,
> so emulating this if hid_hw_output_report() returns -ENOSYS.
>
> Signed-off-by: Benjamin Tissoires <benjamin.tissoires@redhat.com>
> ---
>  drivers/hid/hidraw.c | 22 +++++++++++++++++-----
>  1 file changed, 17 insertions(+), 5 deletions(-)
>
> diff --git a/drivers/hid/hidraw.c b/drivers/hid/hidraw.c
> index f8708c9..704718b 100644
> --- a/drivers/hid/hidraw.c
> +++ b/drivers/hid/hidraw.c
> @@ -123,10 +123,8 @@ static ssize_t hidraw_send_report(struct file *file, const char __user *buffer,
>
>         dev = hidraw_table[minor]->hid;
>
> -       if (!dev->hid_output_raw_report) {
> -               ret = -ENODEV;
> -               goto out;
> -       }
> +       if (!dev->ll_driver->raw_request || !dev->ll_driver->output_report)
> +               return -ENODEV;

You still have a "goto out;" above (not visible in the patch). The
error paths look quite ugly now. I'd prefer consistency here, so
either keep the jump or fix the error-path above, too. Otherwise looks
good.

Reviewed-by: David Herrmann <dh.herrmann@gmail.com>

Thanks
David

>
>         if (count > HID_MAX_BUFFER_SIZE) {
>                 hid_warn(dev, "pid %d passed too large report\n",
> @@ -153,7 +151,21 @@ static ssize_t hidraw_send_report(struct file *file, const char __user *buffer,
>                 goto out_free;
>         }
>
> -       ret = hid_output_raw_report(dev, buf, count, report_type);
> +       if (report_type == HID_OUTPUT_REPORT) {
> +               ret = hid_hw_output_report(dev, buf, count);
> +               /*
> +                * compatibility with old implementation of USB-HID and I2C-HID:
> +                * if the device does not support receiving output reports,
> +                * on an interrupt endpoint, then fallback to the SET_REPORT
> +                * HID command.
> +                */
> +               if (ret != -ENOSYS)
> +                       goto out_free;
> +       }
> +
> +       ret = hid_hw_raw_request(dev, buf[0], buf, count, report_type,
> +                               HID_REQ_SET_REPORT);
> +
>  out_free:
>         kfree(buf);
>  out:
> --
> 1.8.3.1
>

  reply	other threads:[~2014-02-12 10:49 UTC|newest]

Thread overview: 35+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-02-10 17:58 [PATCH 00/14] HID: low-level transport cleanup, round 2 Benjamin Tissoires
2014-02-10 17:58 ` [PATCH 01/14] HID: uHID: remove duplicated code Benjamin Tissoires
2014-02-12 10:17   ` David Herrmann
2014-02-10 17:58 ` [PATCH 02/14] HID: uHID: implement .raw_request Benjamin Tissoires
2014-02-12 10:18   ` David Herrmann
2014-02-10 17:58 ` [PATCH 03/14] HID: core: implement generic .request() Benjamin Tissoires
2014-02-12 10:25   ` David Herrmann
2014-02-13 15:21     ` Benjamin Tissoires
2014-02-16 16:43       ` David Herrmann
2014-02-10 17:58 ` [PATCH 04/14] HID: i2c-hid: implement ll_driver transport-layer callbacks Benjamin Tissoires
2014-02-12 10:29   ` David Herrmann
2014-02-10 17:58 ` [PATCH 05/14] HID: i2c-hid: use generic .request() implementation Benjamin Tissoires
2014-02-12 10:30   ` David Herrmann
2014-02-13 15:14     ` Benjamin Tissoires
2014-02-10 17:58 ` [PATCH 06/14] HID: usbhid: change return error of usbhid_output_report Benjamin Tissoires
2014-02-12 10:31   ` David Herrmann
2014-02-10 17:58 ` [PATCH 07/14] HID: input: hid-input remove hid_output_raw_report call Benjamin Tissoires
2014-02-12 10:35   ` David Herrmann
2014-02-13 15:38     ` Benjamin Tissoires
2014-02-10 17:58 ` [PATCH 08/14] HID: logitech-dj: " Benjamin Tissoires
2014-02-12 10:36   ` David Herrmann
2014-02-10 17:58 ` [PATCH 09/14] HID: replace hid_output_raw_report with hid_hw_raw_request for feature requests Benjamin Tissoires
2014-02-10 17:58 ` [PATCH 10/14] HID: wiimote: replace hid_output_raw_report with hid_hw_output_report for output requests Benjamin Tissoires
2014-02-12 10:39   ` David Herrmann
2014-02-10 17:58 ` [PATCH 11/14] HID: sony: remove hid_output_raw_report calls Benjamin Tissoires
2014-02-12 10:47   ` David Herrmann
2014-02-13 15:46     ` Benjamin Tissoires
2014-02-10 17:58 ` [PATCH 12/14] HID: hidraw: replace hid_output_raw_report() calls by appropriates ones Benjamin Tissoires
2014-02-12 10:49   ` David Herrmann [this message]
2014-02-13 15:16     ` Benjamin Tissoires
2014-02-10 17:58 ` [PATCH 13/14] HID: remove hid_output_raw_report Benjamin Tissoires
2014-02-12 10:50   ` David Herrmann
2014-02-10 17:58 ` [PATCH 14/14] HID: core: check parameters when sending/receiving data from the device Benjamin Tissoires
2014-02-12 10:51   ` David Herrmann
2014-02-17 14:01 ` [PATCH 00/14] HID: low-level transport cleanup, round 2 Jiri Kosina

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=CANq1E4RvnReiak20x2HPeZ6evYzDuVnLtbT9-WNeZR9yQbeHXg@mail.gmail.com \
    --to=dh.herrmann@gmail.com \
    --cc=benjamin.tissoires@gmail.com \
    --cc=benjamin.tissoires@redhat.com \
    --cc=jkosina@suse.cz \
    --cc=linux-input@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.