All of lore.kernel.org
 help / color / mirror / Atom feed
From: Simon Glass <sjg@chromium.org>
To: u-boot@lists.denx.de
Subject: [U-Boot] [PATCH v16 0/4] efi_loader: Code refactoring and improvement
Date: Thu, 29 Nov 2018 14:26:59 -0700	[thread overview]
Message-ID: <CAPnjgZ0cdQtwv+30Eg28q3EC6RP_XhM6kRy9PVzSAf_AzYxiYQ@mail.gmail.com> (raw)
In-Reply-To: <20181126031439.202582-1-sjg@chromium.org>

Hi Alex,

On Sun, 25 Nov 2018 at 20:14, Simon Glass <sjg@chromium.org> wrote:
>
> This collects the patches previously sent to break up the very large
> functions in efi_loader into smaller pieces. Now that the other sandbox
> stuff is applied, perhaps it is time to apply these patches.
>
> This also adds a few new patches to fix more recent breakages.
> Unfortunately we still cannot enable the efi loader tests since one of
> the tests fails. Thus we should expect additional failures to appear
> until that is resolved.
>
> Changes in v16:
> - Add new patch to check for failure to create objects in selftest
> - Drop comments about efi_save_gd() being called in efi_init_obj_list()
>
> Changes in v15:
> - Add a comment about a leaked device path
> - Add check for return values to bootefi_test_prepare()
> - Drop call to efi_save_gd() in bootefi_test_prepare()
> - Drop patch already applied
> - Fix minor checkpatch nit with bracket
>
> Changes in v14:
> - Go back to the horrible long variable names
> - Hopefully correct error paths in do_bootefi_exec()
>
> Changes in v13:
> - Drop 'efi_loader: Drop setup_ok' as we have an existing patch for that
> - Drop patches previously applied
> - Rebase to efi/efi-next
>
> Changes in v12:
> - Rename image to image_prot
>
> Changes in v11:
> - Drop patches previously applied
>
> Changes in v9:
> - Add comments to bootefi_test_prepare() about the memset()s
>
> Changes in v7:
> - Drop patch "efi: Init the 'rows' and 'cols' variables"
> - Drop patches previous applied
>
> Changes in v5:
> - Drop call to efi_init_obj_list() which is now done in do_bootefi()
> - Introduce load_options_path to specifyc U-Boot env var for load_options_path
> - Rebase to master
>
> Changes in v4:
> - Rebase to master
>
> Changes in v3:
> - Add new patch to rename bootefi_test_finish() to bootefi_run_finish()
> - Add new patch to split out test init/uninit into functions
> - Add patch to create a function to set up for running EFI code
>
> Simon Glass (4):
>   efi: Check for failure to create objects in selftest
>   efi: Split out test init/uninit into functions
>   efi: Create a function to set up for running EFI code
>   efi: Rename bootefi_test_finish() to bootefi_run_finish()
>
>  cmd/bootefi.c | 118 +++++++++++++++++++++++++++++++++++++-------------
>  1 file changed, 89 insertions(+), 29 deletions(-)

Any thoughts on this latest version?

Regards,
Simon

  parent reply	other threads:[~2018-11-29 21:26 UTC|newest]

Thread overview: 11+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-11-26  3:14 [U-Boot] [PATCH v16 0/4] efi_loader: Code refactoring and improvement Simon Glass
2018-11-26  3:14 ` [U-Boot] [PATCH v16 1/4] efi: Check for failure to create objects in selftest Simon Glass
2018-11-30 23:21   ` [U-Boot] [U-Boot, v16, " Alexander Graf
2018-11-26  3:14 ` [U-Boot] [PATCH v16 2/4] efi: Split out test init/uninit into functions Simon Glass
2018-11-30 23:21   ` [U-Boot] [U-Boot, v16, " Alexander Graf
2018-11-26  3:14 ` [U-Boot] [PATCH v16 3/4] efi: Create a function to set up for running EFI code Simon Glass
2018-11-30 23:21   ` [U-Boot] [U-Boot, v16, " Alexander Graf
2018-11-26  3:14 ` [U-Boot] [PATCH v16 4/4] efi: Rename bootefi_test_finish() to bootefi_run_finish() Simon Glass
2018-11-30 23:21   ` [U-Boot] [U-Boot, v16, " Alexander Graf
2018-11-29 21:26 ` Simon Glass [this message]
2018-11-30 21:27   ` [U-Boot] [PATCH v16 0/4] efi_loader: Code refactoring and improvement Alexander Graf

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=CAPnjgZ0cdQtwv+30Eg28q3EC6RP_XhM6kRy9PVzSAf_AzYxiYQ@mail.gmail.com \
    --to=sjg@chromium.org \
    --cc=u-boot@lists.denx.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.