Hi, On Fri 08 Jan 21, 10:13, Ezequiel Garcia wrote: > On Fri, 2021-01-08 at 10:05 +0100, Paul Kocialkowski wrote: > > Hi Ezequiel, > > > > On Thu 07 Jan 21, 16:08, Ezequiel Garcia wrote: > > > Happy to see this patch. It was on my TODO list, > > > but I hadn't had time to bringup my rk3326 device. > > > > Same here, I just had an occasion to use it again these days so I jumped > > on it! > > > > > A few comments. > > > > > > On Thu, 2021-01-07 at 14:41 +0100, Paul Kocialkowski wrote: > > > > The PX30 SoC includes both the VDPU2 and VEPU2 blocks which are similar > > > > to the RK3399 (Hantro G1/H1 with shuffled registers). > > > > > > > > Besides taking an extra clock, it also shares an interrupt with the IOMMU > > > > so it's necessary to request the interrupt shared. > > > > > > > > [..] > > > > diff --git a/drivers/staging/media/hantro/hantro_hw.h b/drivers/staging/media/hantro/hantro_hw.h > > > > index 34c9e4649a25..07f516fd7a2e 100644 > > > > --- a/drivers/staging/media/hantro/hantro_hw.h > > > > +++ b/drivers/staging/media/hantro/hantro_hw.h > > > > @@ -148,6 +148,7 @@ enum hantro_enc_fmt { > > > >         RK3288_VPU_ENC_FMT_UYVY422 = 3, > > > >  }; > > > >   > > > > +extern const struct hantro_variant px30_vpu_variant; > > > >  extern const struct hantro_variant rk3399_vpu_variant; > > > >  extern const struct hantro_variant rk3328_vpu_variant; > > > >  extern const struct hantro_variant rk3288_vpu_variant; > > > > diff --git a/drivers/staging/media/hantro/rk3399_vpu_hw.c b/drivers/staging/media/hantro/rk3399_vpu_hw.c > > > > index 7a7962cf771e..4112f98baa60 100644 > > > > --- a/drivers/staging/media/hantro/rk3399_vpu_hw.c > > > > +++ b/drivers/staging/media/hantro/rk3399_vpu_hw.c > > > > > > Perhaps it's time to rename this to rockchip_vpu_hw.c, > > > and merge rk3288 and rk3399? It's a nitpick, though. > > > > Haha, I was thinking the exact same thing but wasn't sure it would be welcome! > > > > I was thinking of rockchip_vpu2_hw.c or rockchip_vdpu2_hw.c since that's > > apparently how it's called in Rockchip terminology: VDPU2 and VEPU2 for the > > Hantro G1 and H1 with the shuffled register layout. The rk3288 stuff is > > probably VDPU1/VEPU1 and we might want to rename it accordingly as well. > > > > I'd rather keep it simple as rockchip_vpu_hw.c and just throw in there > all the rockchip stuff. Do you also mean merging all the rk*_vpu_hw.c files into one or just covering the general helpers (and not the platform-specific structures)? Cheers, Paul -- Paul Kocialkowski, Bootlin Embedded Linux and kernel engineering https://bootlin.com