All of lore.kernel.org
 help / color / mirror / Atom feed
From: Stafford Horne <shorne@gmail.com>
To: Richard Henderson <richard.henderson@linaro.org>
Cc: qemu-devel@nongnu.org
Subject: Re: [PATCH v2 18/28] target/openrisc: Use translator_use_goto_tb
Date: Thu, 8 Jul 2021 05:59:32 +0900	[thread overview]
Message-ID: <YOYVtKsXCwiNvcXp@antec> (raw)
In-Reply-To: <20210630183226.3290849-19-richard.henderson@linaro.org>

On Wed, Jun 30, 2021 at 11:32:16AM -0700, Richard Henderson wrote:
> Reorder the cases in openrisc_tr_tb_stop to make this easier to read.

Hi Richard,

For me the description is a bit misleading.  I don't see it as a simple
reorder for making things easier to read, because we need to understand
what is inside of translator_use_goto_tb now.

From the patch basically translator_use_goto_tb indicates that a jump is in
the same page and we are not single stepping.

The old code was:

  If single step
   DEBUG
  else if not same page
   tcg_gen_lookup_and_goto_ptr()
  else *same page*
   jump same page

Now:

  If translator_use_goto_tb() (same page & not single step)
    jump same page

  If single step
    DEBUG
  else *not same page*
    tcg_gen_lookup_and_goto_ptr()

It would be a bit easier to understand if the description was something like,
Reorder the control statements to allow using the page boundary check from
translator_use_goto_tb().

That said it looks correct so:

Reviewed-by: Stafford Horne <shorne@gmail.com>


> Cc: Stafford Horne <shorne@gmail.com>
> Signed-off-by: Richard Henderson <richard.henderson@linaro.org>
> ---
>  target/openrisc/translate.c | 15 ++++++++-------
>  1 file changed, 8 insertions(+), 7 deletions(-)
> 
> diff --git a/target/openrisc/translate.c b/target/openrisc/translate.c
> index a9c81f8bd5..2d142d8577 100644
> --- a/target/openrisc/translate.c
> +++ b/target/openrisc/translate.c
> @@ -1720,16 +1720,17 @@ static void openrisc_tr_tb_stop(DisasContextBase *dcbase, CPUState *cs)
>          /* fallthru */
>  
>      case DISAS_TOO_MANY:
> -        if (unlikely(dc->base.singlestep_enabled)) {
> -            tcg_gen_movi_tl(cpu_pc, jmp_dest);
> -            gen_exception(dc, EXCP_DEBUG);
> -        } else if ((dc->base.pc_first ^ jmp_dest) & TARGET_PAGE_MASK) {
> -            tcg_gen_movi_tl(cpu_pc, jmp_dest);
> -            tcg_gen_lookup_and_goto_ptr();
> -        } else {
> +        if (translator_use_goto_tb(&dc->base, jmp_dest)) {
>              tcg_gen_goto_tb(0);
>              tcg_gen_movi_tl(cpu_pc, jmp_dest);
>              tcg_gen_exit_tb(dc->base.tb, 0);
> +            break;
> +        }
> +        tcg_gen_movi_tl(cpu_pc, jmp_dest);
> +        if (unlikely(dc->base.singlestep_enabled)) {
> +            gen_exception(dc, EXCP_DEBUG);
> +        } else {
> +            tcg_gen_lookup_and_goto_ptr();
>          }
>          break;
>  
> -- 
> 2.25.1
> 


  reply	other threads:[~2021-07-07 21:00 UTC|newest]

Thread overview: 53+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-06-30 18:31 [PATCH v2 00/28] accel/tcg: Introduce translator_use_goto_tb Richard Henderson
2021-06-30 18:31 ` [PATCH v2 01/28] " Richard Henderson
2021-06-30 18:32 ` [PATCH v2 02/28] target/alpha: Remove use_exit_tb Richard Henderson
2021-07-08 12:34   ` Peter Maydell
2021-06-30 18:32 ` [PATCH v2 03/28] target/alpha: Remove in_superpage Richard Henderson
2021-07-08 12:35   ` Peter Maydell
2021-06-30 18:32 ` [PATCH v2 04/28] target/alpha: Use translator_use_goto_tb Richard Henderson
2021-07-08 12:29   ` Peter Maydell
2021-06-30 18:32 ` [PATCH v2 05/28] target/arm: Use gen_jmp for ISB and SB Richard Henderson
2021-07-08 12:05   ` Peter Maydell
2021-07-08 16:04     ` Richard Henderson
2021-07-08 16:11       ` Peter Maydell
2021-07-08 16:17         ` Richard Henderson
2021-07-08 17:47           ` Peter Maydell
2021-06-30 18:32 ` [PATCH v2 06/28] target/arm: Use translator_use_goto_tb for aarch64 Richard Henderson
2021-07-08 12:08   ` Peter Maydell
2021-06-30 18:32 ` [PATCH v2 07/28] target/arm: Use translator_use_goto_tb for aarch32 Richard Henderson
2021-07-08 12:14   ` Peter Maydell
2021-06-30 18:32 ` [PATCH v2 08/28] target/avr: Use translator_use_goto_tb Richard Henderson
2021-07-08 12:28   ` Peter Maydell
2021-06-30 18:32 ` [PATCH v2 09/28] target/avr: Mark some helpers noreturn Richard Henderson
2021-06-30 18:32 ` [PATCH v2 10/28] target/cris: Use translator_use_goto_tb Richard Henderson
2021-07-08 12:27   ` Peter Maydell
2021-06-30 18:32 ` [PATCH v2 11/28] target/hppa: " Richard Henderson
2021-07-08 12:26   ` Peter Maydell
2021-06-30 18:32 ` [PATCH v2 12/28] target/i386: " Richard Henderson
2021-07-08 12:26   ` Peter Maydell
2021-06-30 18:32 ` [PATCH v2 13/28] target/m68k: " Richard Henderson
2021-07-08 12:22   ` Peter Maydell
2021-06-30 18:32 ` [PATCH v2 14/28] target/microblaze: " Richard Henderson
2021-07-08 12:21   ` Peter Maydell
2021-06-30 18:32 ` [PATCH v2 15/28] target/mips: " Richard Henderson
2021-07-08 12:18   ` Peter Maydell
2021-06-30 18:32 ` [PATCH v2 16/28] target/mips: Fix missing else in gen_goto_tb Richard Henderson
2021-06-30 18:32 ` [PATCH v2 17/28] target/nios2: Use translator_use_goto_tb Richard Henderson
2021-07-08 12:17   ` Peter Maydell
2021-06-30 18:32 ` [PATCH v2 18/28] target/openrisc: " Richard Henderson
2021-07-07 20:59   ` Stafford Horne [this message]
2021-06-30 18:32 ` [PATCH v2 19/28] target/ppc: " Richard Henderson
2021-06-30 18:32 ` [PATCH v2 20/28] target/riscv: " Richard Henderson
2021-06-30 18:32 ` [PATCH v2 21/28] target/rx: " Richard Henderson
2021-07-08 12:17   ` Peter Maydell
2021-06-30 18:32 ` [PATCH v2 22/28] target/s390x: " Richard Henderson
2021-07-01  7:42   ` David Hildenbrand
2021-06-30 18:32 ` [PATCH v2 23/28] target/s390x: Remove use_exit_tb Richard Henderson
2021-07-01  7:44   ` David Hildenbrand
2021-06-30 18:32 ` [PATCH v2 24/28] target/sh4: Use translator_use_goto_tb Richard Henderson
2021-07-08 12:16   ` Peter Maydell
2021-06-30 18:32 ` [PATCH v2 25/28] target/sparc: " Richard Henderson
2021-06-30 18:32 ` [PATCH v2 26/28] target/tricore: " Richard Henderson
2021-06-30 18:32 ` [PATCH v2 27/28] target/tricore: Use tcg_gen_lookup_and_goto_ptr Richard Henderson
2021-06-30 18:32 ` [PATCH v2 28/28] target/xtensa: Use translator_use_goto_tb Richard Henderson
2021-07-07 21:41 ` [PATCH v2 00/28] accel/tcg: Introduce translator_use_goto_tb Richard Henderson

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=YOYVtKsXCwiNvcXp@antec \
    --to=shorne@gmail.com \
    --cc=qemu-devel@nongnu.org \
    --cc=richard.henderson@linaro.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.