bpf.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Wenbo Zhang <ethercflow@gmail.com>
To: Yonghong Song <yhs@fb.com>
Cc: "bpf@vger.kernel.org" <bpf@vger.kernel.org>,
	"ast@kernel.org" <ast@kernel.org>,
	"daniel@iogearbox.net" <daniel@iogearbox.net>,
	"andrii.nakryiko@gmail.com" <andrii.nakryiko@gmail.com>,
	"netdev@vger.kernel.org" <netdev@vger.kernel.org>
Subject: Re: [PATCH bpf-next v12 2/2] selftests/bpf: test for bpf_get_file_path() from tracepoint
Date: Tue, 17 Dec 2019 17:44:09 +0800	[thread overview]
Message-ID: <CABtjQmYOQy05W8PfK1d--cdWu7hkTGbkm_4gEZp8HBKNPfPddQ@mail.gmail.com> (raw)
In-Reply-To: <71c53be6-add4-2557-bc8f-8acb8e4a2f39@fb.com>

> The kernel will actually have 8 bytes of memory to store fd
> based on trace_event_raw_sys_enter.

> For little endian machine, the lower 4 bytes are read based on
> your sys_enter_newfstat_args, which is "accidentally" the lower
> 4 bytes in u64, so you get the correct answer.

> For big endian machine, the lower 4 bytes read based on
> your sys_enter_newfstat_args will be high 4 bytes in u64, which
> is incorrect.

Oh, get it. Thank you, I'll fix this in the next version.

Yonghong Song <yhs@fb.com> 于2019年12月17日周二 下午12:14写道:
>
>
>
> On 12/16/19 8:01 PM, Wenbo Zhang wrote:
> >> In non-bpf .c file, typically we do not add 'inline' attribute.
> >> It is up to compiler to decide whether it should be inlined.
> >
> > Thank you, I'll fix this.
> >
> >>> +struct sys_enter_newfstat_args {
> >>> +     unsigned long long pad1;
> >>> +     unsigned long long pad2;
> >>> +     unsigned int fd;
> >>> +};
> >
> >> The BTF generated vmlinux.h has the following structure,
> >> struct trace_entry {
> >>           short unsigned int type;
> >>           unsigned char flags;
> >>           unsigned char preempt_count;
> >>           int pid;
> >> };
> >> struct trace_event_raw_sys_enter {
> >>           struct trace_entry ent;
> >>           long int id;
> >>           long unsigned int args[6];
> >>           char __data[0];
> >> };
> >
> >> The third parameter type should be long, otherwise,
> >> it may have issue on big endian machines?
> >
> > Sorry, I don't understand why there is a problem on big-endian machines.
> > Would you please explain that in more detail? Thank you.
>
> The kernel will actually have 8 bytes of memory to store fd
> based on trace_event_raw_sys_enter.
>
> For little endian machine, the lower 4 bytes are read based on
> your sys_enter_newfstat_args, which is "accidentally" the lower
> 4 bytes in u64, so you get the correct answer.
>
> For big endian machine, the lower 4 bytes read based on
> your sys_enter_newfstat_args will be high 4 bytes in u64, which
> is incorrect.
>
> >
> > Yonghong Song <yhs@fb.com> 于2019年12月16日周一 上午12:25写道:
> >>
> >>
> >>
> >> On 12/14/19 8:01 PM, Wenbo Zhang wrote:
> >>> trace fstat events by tracepoint syscalls/sys_enter_newfstat, and handle
> >>> events only produced by test_file_get_path, which call fstat on several
> >>> different types of files to test bpf_get_file_path's feature.
> >>>
> >>> v4->v5: addressed Andrii's feedback
> >>> - pass NULL for opts as bpf_object__open_file's PARAM2, as not really
> >>> using any
> >>> - modify patch subject to keep up with test code
> >>> - as this test is single-threaded, so use getpid instead of SYS_gettid
> >>> - remove unnecessary parens around check which after if (i < 3)
> >>> - in kern use bpf_get_current_pid_tgid() >> 32 to fit getpid() in
> >>> userspace part
> >>> - with the patch adding helper as one patch series
> >>>
> >>> v3->v4: addressed Andrii's feedback
> >>> - use a set of fd instead of fds array
> >>> - use global variables instead of maps (in v3, I mistakenly thought that
> >>> the bpf maps are global variables.)
> >>> - remove uncessary global variable path_info_index
> >>> - remove fd compare as the fstat's order is fixed
> >>>
> >>> v2->v3: addressed Andrii's feedback
> >>> - use global data instead of perf_buffer to simplified code
> >>>
> >>> v1->v2: addressed Daniel's feedback
> >>> - rename bpf_fd2path to bpf_get_file_path to be consistent with other
> >>> helper's names
> >>>
> >>> Signed-off-by: Wenbo Zhang <ethercflow@gmail.com>
> >>> ---
> >>>    .../selftests/bpf/prog_tests/get_file_path.c  | 171 ++++++++++++++++++
> >>>    .../selftests/bpf/progs/test_get_file_path.c  |  43 +++++
> >>>    2 files changed, 214 insertions(+)
> >>>    create mode 100644 tools/testing/selftests/bpf/prog_tests/get_file_path.c
> >>>    create mode 100644 tools/testing/selftests/bpf/progs/test_get_file_path.c
> >>>
> >>> diff --git a/tools/testing/selftests/bpf/prog_tests/get_file_path.c b/tools/testing/selftests/bpf/prog_tests/get_file_path.c
> >>> new file mode 100644
> >>> index 000000000000..7ec11e43e0fc
> >>> --- /dev/null
> >>> +++ b/tools/testing/selftests/bpf/prog_tests/get_file_path.c
> >>> @@ -0,0 +1,171 @@
> >>> +// SPDX-License-Identifier: GPL-2.0
> >>> +#define _GNU_SOURCE
> >>> +#include <test_progs.h>
> >>> +#include <sys/stat.h>
> >>> +#include <linux/sched.h>
> >>> +#include <sys/syscall.h>
> >>> +
> >>> +#define MAX_PATH_LEN         128
> >>> +#define MAX_FDS                      7
> >>> +#define MAX_EVENT_NUM                16
> >>> +
> >>> +static struct file_path_test_data {
> >>> +     pid_t pid;
> >>> +     __u32 cnt;
> >>> +     __u32 fds[MAX_EVENT_NUM];
> >>> +     char paths[MAX_EVENT_NUM][MAX_PATH_LEN];
> >>> +} src, dst;
> >>> +
> >>> +static inline int set_pathname(int fd)
> >>
> >> In non-bpf .c file, typically we do not add 'inline' attribute.
> >> It is up to compiler to decide whether it should be inlined.
> >>
> >>> +{
> >>> +     char buf[MAX_PATH_LEN];
> >>> +
> >>> +     snprintf(buf, MAX_PATH_LEN, "/proc/%d/fd/%d", src.pid, fd);
> >>> +     src.fds[src.cnt] = fd;
> >>> +     return readlink(buf, src.paths[src.cnt++], MAX_PATH_LEN);
> >>> +}
> >>> +
> >> [...]
> >>> diff --git a/tools/testing/selftests/bpf/progs/test_get_file_path.c b/tools/testing/selftests/bpf/progs/test_get_file_path.c
> >>> new file mode 100644
> >>> index 000000000000..eae663c1262a
> >>> --- /dev/null
> >>> +++ b/tools/testing/selftests/bpf/progs/test_get_file_path.c
> >>> @@ -0,0 +1,43 @@
> >>> +// SPDX-License-Identifier: GPL-2.0
> >>> +
> >>> +#include <linux/bpf.h>
> >>> +#include <linux/ptrace.h>
> >>> +#include <string.h>
> >>> +#include <unistd.h>
> >>> +#include "bpf_helpers.h"
> >>> +#include "bpf_tracing.h"
> >>> +
> >>> +#define MAX_PATH_LEN         128
> >>> +#define MAX_EVENT_NUM                16
> >>> +
> >>> +static struct file_path_test_data {
> >>> +     pid_t pid;
> >>> +     __u32 cnt;
> >>> +     __u32 fds[MAX_EVENT_NUM];
> >>> +     char paths[MAX_EVENT_NUM][MAX_PATH_LEN];
> >>> +} data;
> >>> +
> >>> +struct sys_enter_newfstat_args {
> >>> +     unsigned long long pad1;
> >>> +     unsigned long long pad2;
> >>> +     unsigned int fd;
> >>> +};
> >>
> >> The BTF generated vmlinux.h has the following structure,
> >> struct trace_entry {
> >>           short unsigned int type;
> >>           unsigned char flags;
> >>           unsigned char preempt_count;
> >>           int pid;
> >> };
> >> struct trace_event_raw_sys_enter {
> >>           struct trace_entry ent;
> >>           long int id;
> >>           long unsigned int args[6];
> >>           char __data[0];
> >> };
> >>
> >> The third parameter type should be long, otherwise,
> >> it may have issue on big endian machines?

  reply	other threads:[~2019-12-17  9:44 UTC|newest]

Thread overview: 52+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-11-19 13:27 [PATCH bpf-next v10 0/2] bpf: adding get_file_path helper Wenbo Zhang
2019-11-19 13:27 ` [PATCH bpf-next v10 1/2] bpf: add new helper get_file_path for mapping a file descriptor to a pathname Wenbo Zhang
2019-11-23  3:18   ` Alexei Starovoitov
2019-11-23  4:43     ` Al Viro
2019-11-23  4:51     ` Al Viro
2019-11-23  5:19       ` Alexei Starovoitov
2019-11-23  5:35         ` Al Viro
2019-11-23  6:04           ` Alexei Starovoitov
2019-12-13 19:51             ` Brendan Gregg
2019-12-05  4:20   ` [PATCH bpf-next v11 0/2] bpf: adding get_file_path helper Wenbo Zhang
2019-12-05  4:20     ` [PATCH bpf-next v11 1/2] bpf: add new helper get_file_path for mapping a file descriptor to a pathname Wenbo Zhang
2019-12-05  7:19       ` Alexei Starovoitov
2019-12-05  9:47         ` Wenbo Zhang
2019-12-15  4:01       ` [PATCH bpf-next v12 0/2] bpf: adding get_file_path helper Wenbo Zhang
2019-12-15  4:01         ` [PATCH bpf-next v12 1/2] bpf: add new helper get_file_path for mapping a file descriptor to a pathname Wenbo Zhang
2019-12-15 16:05           ` Yonghong Song
2019-12-17  6:26             ` Wenbo Zhang
2019-12-17  6:33               ` Yonghong Song
2019-12-15 16:10           ` Yonghong Song
2019-12-17  6:27             ` Wenbo Zhang
2019-12-16 22:09           ` Brendan Gregg
2019-12-17  4:05             ` Wenbo Zhang
2019-12-17  9:47           ` [PATCH bpf-next v13 0/2] bpf: adding get_fd_path helper Wenbo Zhang
2019-12-17  9:47             ` [PATCH bpf-next v13 1/2] bpf: add new helper get_fd_path for mapping a file descriptor to a pathname Wenbo Zhang
2019-12-17 16:29               ` Yonghong Song
2019-12-17 19:39                 ` Daniel Borkmann
2019-12-18  0:11                   ` Wenbo Zhang
2019-12-18  0:06                 ` Wenbo Zhang
2019-12-18  0:56               ` [PATCH bpf-next v14 0/2] bpf: adding get_fd_path helper Wenbo Zhang
2019-12-18  0:56                 ` [PATCH bpf-next v14 1/2] bpf: add new helper get_fd_path for mapping a file descriptor to a pathname Wenbo Zhang
2019-12-18  3:27                   ` Yonghong Song
2019-12-19 16:14                   ` Daniel Borkmann
2019-12-20  3:35                     ` Wenbo Zhang
2020-01-16  8:59                       ` Jiri Olsa
2020-02-10  4:43                         ` Brendan Gregg
2020-02-11  0:01                           ` Daniel Borkmann
2020-02-12 15:21                             ` Jiri Olsa
2020-06-01 14:17                               ` Wenbo Zhang
2020-06-01 16:38                                 ` Alexei Starovoitov
2020-06-02  3:04                                   ` Wenbo Zhang
2020-06-02  8:14                                     ` Jiri Olsa
2019-12-18  0:56                 ` [PATCH bpf-next v14 2/2] selftests/bpf: test for bpf_get_fd_path() from tracepoint Wenbo Zhang
2019-12-18  3:27                   ` Yonghong Song
2019-12-17  9:47             ` [PATCH bpf-next v13 " Wenbo Zhang
2019-12-17 16:32               ` Yonghong Song
2019-12-15  4:01         ` [PATCH bpf-next v12 2/2] selftests/bpf: test for bpf_get_file_path() " Wenbo Zhang
2019-12-15 16:24           ` Yonghong Song
2019-12-17  4:01             ` Wenbo Zhang
2019-12-17  4:13               ` Yonghong Song
2019-12-17  9:44                 ` Wenbo Zhang [this message]
2019-12-05  4:20     ` [PATCH bpf-next v11 " Wenbo Zhang
2019-11-19 13:27 ` [PATCH bpf-next v10 " Wenbo Zhang

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=CABtjQmYOQy05W8PfK1d--cdWu7hkTGbkm_4gEZp8HBKNPfPddQ@mail.gmail.com \
    --to=ethercflow@gmail.com \
    --cc=andrii.nakryiko@gmail.com \
    --cc=ast@kernel.org \
    --cc=bpf@vger.kernel.org \
    --cc=daniel@iogearbox.net \
    --cc=netdev@vger.kernel.org \
    --cc=yhs@fb.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).