driverdev-devel.linuxdriverproject.org archive mirror
 help / color / mirror / Atom feed
From: Coiby Xu <coiby.xu@gmail.com>
To: Benjamin Poirier <benjamin.poirier@gmail.com>
Cc: devel@driverdev.osuosl.org,
	Willem de Bruijn <willemdebruijn.kernel@gmail.com>,
	"supporter:QLOGIC QLGE 10Gb ETHERNET DRIVER"
	<GR-Linux-NIC-Dev@marvell.com>,
	Manish Chopra <manishc@marvell.com>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	Shung-Hsi Yu <shung-hsi.yu@suse.com>,
	open list <linux-kernel@vger.kernel.org>,
	"open list:QLOGIC QLGE 10Gb ETHERNET DRIVER"
	<netdev@vger.kernel.org>,
	Dan Carpenter <dan.carpenter@oracle.com>
Subject: Re: [PATCH v2 1/7] staging: qlge: replace ql_* with qlge_* to avoid namespace clashes with other qlogic drivers
Date: Thu, 15 Oct 2020 12:32:29 +0800	[thread overview]
Message-ID: <20201015043229.yngmk7h32plk5kkn@Rk> (raw)
In-Reply-To: <20201015042628.42evgens2z47x3d6@Rk>

On Thu, Oct 15, 2020 at 12:26:28PM +0800, Coiby Xu wrote:
>On Thu, Oct 15, 2020 at 10:01:36AM +0900, Benjamin Poirier wrote:
>>On 2020-10-14 18:43 +0800, Coiby Xu wrote:
>>>To avoid namespace clashes with other qlogic drivers and also for the
>>>sake of naming consistency, use the "qlge_" prefix as suggested in
>>>drivers/staging/qlge/TODO.
>>>
>>>Suggested-by: Benjamin Poirier <benjamin.poirier@gmail.com>
>>>Signed-off-by: Coiby Xu <coiby.xu@gmail.com>
>>>---
>>> drivers/staging/qlge/TODO           |    4 -
>>> drivers/staging/qlge/qlge.h         |  190 ++--
>>> drivers/staging/qlge/qlge_dbg.c     | 1073 ++++++++++++-----------
>>> drivers/staging/qlge/qlge_ethtool.c |  231 ++---
>>> drivers/staging/qlge/qlge_main.c    | 1257 +++++++++++++--------------
>>> drivers/staging/qlge/qlge_mpi.c     |  352 ++++----
>>> 6 files changed, 1551 insertions(+), 1556 deletions(-)
>>>
>>>diff --git a/drivers/staging/qlge/TODO b/drivers/staging/qlge/TODO
>>>index f93f7428f5d5..5ac55664c3e2 100644
>>>--- a/drivers/staging/qlge/TODO
>>>+++ b/drivers/staging/qlge/TODO
>>>@@ -28,10 +28,6 @@
>>> * the driver has a habit of using runtime checks where compile time checks are
>>>   possible (ex. ql_free_rx_buffers(), ql_alloc_rx_buffers())
>>> * reorder struct members to avoid holes if it doesn't impact performance
>>>-* in terms of namespace, the driver uses either qlge_, ql_ (used by
>>>-  other qlogic drivers, with clashes, ex: ql_sem_spinlock) or nothing (with
>>>-  clashes, ex: struct ob_mac_iocb_req). Rename everything to use the "qlge_"
>>>-  prefix.
>>
>>You only renamed ql -> qlge. The prefix needs to be added where there is
>>currently none like the second example of that text.
>>
>Thank you for reminding me of the second example!
>
>>Besides, the next patch reintroduces the name struct ql_adapter.
>
>Oh, there is still a left-over ql_adapter in qlge.h (I renamed ql->qlge
>after initializing the devlink framework earlier but did a git rebase
>to make the order of the changes more reasonable). Thank you for the
>reminding!

Btw, is there a way to configure kernel building to let the compiler
discover this kind of issue automatically?

>--
>Best regards,
>Coiby

--
Best regards,
Coiby
_______________________________________________
devel mailing list
devel@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

  reply	other threads:[~2020-10-15  4:32 UTC|newest]

Thread overview: 18+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-10-14 10:42 [PATCH v2 0/7] staging: qlge: Re-writing the debugging features Coiby Xu
2020-10-14 10:43 ` [PATCH v2 1/7] staging: qlge: replace ql_* with qlge_* to avoid namespace clashes with other qlogic drivers Coiby Xu
2020-10-15  1:01   ` Benjamin Poirier
2020-10-15  4:26     ` Coiby Xu
2020-10-15  4:32       ` Coiby Xu [this message]
2020-10-16 23:16     ` Coiby Xu
2020-10-18 11:02       ` Benjamin Poirier
2020-10-19  2:12         ` Coiby Xu
2020-10-14 10:43 ` [PATCH v2 2/7] staging: qlge: Initialize devlink health dump framework Coiby Xu
2020-10-14 13:08   ` Dan Carpenter
2020-10-15  4:22     ` Coiby Xu
2020-10-20  8:36   ` Shung-Hsi Yu
2020-10-20  8:55     ` Shung-Hsi Yu
2020-10-14 10:43 ` [PATCH v2 3/7] staging: qlge: coredump via devlink health reporter Coiby Xu
2020-10-14 10:43 ` [PATCH v2 4/7] staging: qlge: support force_coredump option for devlink health dump Coiby Xu
2020-10-14 10:43 ` [PATCH v2 5/7] staging: qlge: remove mpi_core_to_log which sends coredump to the kernel ring buffer Coiby Xu
2020-10-14 10:43 ` [PATCH v2 6/7] staging: qlge: clean up debugging code in the QL_ALL_DUMP ifdef land Coiby Xu
2020-10-14 10:43 ` [PATCH v2 7/7] staging: qlge: add documentation for debugging qlge Coiby Xu

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20201015043229.yngmk7h32plk5kkn@Rk \
    --to=coiby.xu@gmail.com \
    --cc=GR-Linux-NIC-Dev@marvell.com \
    --cc=benjamin.poirier@gmail.com \
    --cc=dan.carpenter@oracle.com \
    --cc=devel@driverdev.osuosl.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=manishc@marvell.com \
    --cc=netdev@vger.kernel.org \
    --cc=shung-hsi.yu@suse.com \
    --cc=willemdebruijn.kernel@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).