kernel-janitors.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Joe Perches <joe@perches.com>
To: maowenan <maowenan@huawei.com>,
	airlied@linux.ie, daniel@ffwll.ch, alexander.deucher@amd.com,
	christian.koenig@amd.com, David1.Zhou@amd.com,
	dan.carpenter@oracle.com, julia.lawall@lip6.fr
Cc: kernel-janitors@vger.kernel.org, amd-gfx@lists.freedesktop.org,
	linux-kernel@vger.kernel.org, Jonathan Kim <jonathan.kim@amd.com>
Subject: Re: [PATCH -next v2] drm/amdgpu: return 'ret' in amdgpu_pmu_init
Date: Mon, 24 Jun 2019 03:46:55 +0000	[thread overview]
Message-ID: <f7af76e8237f490f75d9f2624127e01c55476d2f.camel@perches.com> (raw)
In-Reply-To: <b468d765-bef7-70a8-9a14-bad0e6ed14df@huawei.com>

On Mon, 2019-06-24 at 11:41 +0800, maowenan wrote:
> 
> On 2019/6/23 2:13, Joe Perches wrote:
> > On Sat, 2019-06-22 at 21:05 +0800, Mao Wenan wrote:
> > > There is one warning:
> > > drivers/gpu/drm/amd/amdgpu/amdgpu_pmu.c: In function ‘amdgpu_pmu_init’:
> > > drivers/gpu/drm/amd/amdgpu/amdgpu_pmu.c:249:6: warning: variable ‘ret’ set but not used [-Wunused-but-set-variable]
> > >   int ret = 0;
> > []
> > >  v1->v2: change the subject for this patch; change the indenting when it calls init_pmu_by_type; use the value 'ret' in
> > >  amdgpu_pmu_init().
> > []
> > > diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_pmu.c b/drivers/gpu/drm/amd/amdgpu/amdgpu_pmu.c
> > []
> > > @@ -252,8 +252,8 @@ int amdgpu_pmu_init(struct amdgpu_device *adev)
> > >  	case CHIP_VEGA20:
> > >  		/* init df */
> > >  		ret = init_pmu_by_type(adev, df_v3_6_attr_groups,
> > > -				       "DF", "amdgpu_df", PERF_TYPE_AMDGPU_DF,
> > > -				       DF_V3_6_MAX_COUNTERS);
> > > +							   "DF", "amdgpu_df", PERF_TYPE_AMDGPU_DF,
> > > +							   DF_V3_6_MAX_COUNTERS);
> > 
> > trivia:
> > 
> > The indentation change seems superfluous and
> > appears to make the code harder to read.
> > 
> > You could also cc Jonathan Kim who wrote all of this.
> I think this is just display issue in mail format. It is correct that in vi/vim.
> The arguments are line up with '(' after my change.

Use 8 character tabs and try again please.

> @@ -252,8 +252,8 @@ int amdgpu_pmu_init(struct amdgpu_device *adev)$
>  ^Icase CHIP_VEGA20:$
>  ^I^I/* init df */$
>  ^I^Iret = init_pmu_by_type(adev, df_v3_6_attr_groups,$
> -^I^I^I^I       "DF", "amdgpu_df", PERF_TYPE_AMDGPU_DF,$
> -^I^I^I^I       DF_V3_6_MAX_COUNTERS);$
> +^I^I^I^I^I^I^I   "DF", "amdgpu_df", PERF_TYPE_AMDGPU_DF,$
> +^I^I^I^I^I^I^I   DF_V3_6_MAX_COUNTERS);$

  reply	other threads:[~2019-06-24  3:46 UTC|newest]

Thread overview: 29+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-11-15 10:52 [PATCH -next] drm/amdgpu: remove set but not used variable 'ring' YueHaibing
2018-11-15 11:49 ` Huang, Ray
2018-11-15 11:56   ` YueHaibing
2019-02-20  3:31 ` [PATCH -next] drm/amdgpu: remove set but not used variables 'vm, bo' YueHaibing
2019-02-28  2:43   ` Alex Deucher
2019-06-22  2:56 ` [PATCH -next] drm/amdgpu: remove set but not used variables 'ret' Mao Wenan
2019-06-22  6:02   ` Julia Lawall
2019-06-22  7:20     ` maowenan
2019-06-22 10:43   ` Dan Carpenter
2019-06-22 12:58     ` [PATCH -next v2] drm/amdgpu: return 'ret' in amdgpu_pmu_init Mao Wenan
2019-06-22 13:06       ` Julia Lawall
2019-06-22 13:56         ` maowenan
2019-06-22 14:00           ` Julia Lawall
2019-06-24  3:16             ` maowenan
2019-06-22 18:13       ` Joe Perches
2019-06-24  3:41         ` maowenan
2019-06-24  3:46           ` Joe Perches [this message]
2019-06-23  6:00     ` [PATCH -next] drm/amdgpu: remove set but not used variables 'ret' Dan Carpenter
2019-06-23  6:10       ` Julia Lawall
2019-06-24  3:45         ` [PATCH -next v3] drm/amdgpu: return 'ret' immediately if failed in amdgpu_pmu_init Mao Wenan
     [not found]           ` <20190624034532.135201-1-maowenan-hv44wF8Li93QT0dZR+AlfA@public.gmane.org>
2019-06-24  8:39             ` Dan Carpenter
2019-06-24  9:29               ` maowenan
     [not found]                 ` <4795ba5c-8e41-e1e0-c96a-47fdda3995e3-hv44wF8Li93QT0dZR+AlfA@public.gmane.org>
2019-06-24  9:48                   ` Dan Carpenter
2019-06-24 11:23                     ` [PATCH -next v4] " Mao Wenan
     [not found]                       ` <20190624112318.149299-1-maowenan-hv44wF8Li93QT0dZR+AlfA@public.gmane.org>
2019-06-24 17:42                         ` Kim, Jonathan
2019-06-26 11:35                           ` maowenan
2019-07-10  7:31                             ` maowenan
2020-07-02  1:55 ` [PATCH -next] drm/amdgpu: remove set but not used variable 'adev' YueHaibing
2020-07-06 16:06   ` Alex Deucher

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=f7af76e8237f490f75d9f2624127e01c55476d2f.camel@perches.com \
    --to=joe@perches.com \
    --cc=David1.Zhou@amd.com \
    --cc=airlied@linux.ie \
    --cc=alexander.deucher@amd.com \
    --cc=amd-gfx@lists.freedesktop.org \
    --cc=christian.koenig@amd.com \
    --cc=dan.carpenter@oracle.com \
    --cc=daniel@ffwll.ch \
    --cc=jonathan.kim@amd.com \
    --cc=julia.lawall@lip6.fr \
    --cc=kernel-janitors@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=maowenan@huawei.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).