linux-acpi.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Roman Kisel <romank@linux.microsoft.com>
To: Easwar Hariharan <eahariha@linux.microsoft.com>,
	kys@microsoft.com, haiyangz@microsoft.com, wei.liu@kernel.org,
	decui@microsoft.com, linux-hyperv@vger.kernel.org,
	rafael@kernel.org, lenb@kernel.org, linux-acpi@vger.kernel.org
Cc: ssengar@microsoft.com, sunilmut@microsoft.com
Subject: Re: [PATCH 1/6] arm64/hyperv: Support DeviceTree
Date: Tue, 14 May 2024 16:17:26 -0700	[thread overview]
Message-ID: <976901c1-1f16-464d-8e65-5b2425c8b05c@linux.microsoft.com> (raw)
In-Reply-To: <f52893ae-8dd1-421f-9943-cab3ef6974f0@linux.microsoft.com>



On 5/14/2024 3:46 PM, Easwar Hariharan wrote:
> On 5/10/2024 10:42 AM, Roman Kisel wrote:
>>
>>
>> On 5/10/2024 10:04 AM, Easwar Hariharan wrote:
>>> On 5/10/2024 9:05 AM, romank@linux.microsoft.com wrote:
>>>> From: Roman Kisel <romank@linux.microsoft.com>
>>>>
>>>> Update the driver to support DeviceTree boot as well along with ACPI.
>>>> This enables the Virtual Trust Level platforms boot up on ARM64.
>>>>
>>>> Signed-off-by: Roman Kisel <romank@linux.microsoft.com>
>>>> ---
>>>>    arch/arm64/hyperv/mshyperv.c | 34 +++++++++++++++++++++++++++++-----
>>>>    1 file changed, 29 insertions(+), 5 deletions(-)
>>>>
>>>> diff --git a/arch/arm64/hyperv/mshyperv.c b/arch/arm64/hyperv/mshyperv.c
>>>> index b1a4de4eee29..208a3bcb9686 100644
>>>> --- a/arch/arm64/hyperv/mshyperv.c
>>>> +++ b/arch/arm64/hyperv/mshyperv.c
>>>> @@ -15,6 +15,9 @@
>>>>    #include <linux/errno.h>
>>>>    #include <linux/version.h>
>>>>    #include <linux/cpuhotplug.h>
>>>> +#include <linux/libfdt.h>
>>>> +#include <linux/of.h>
>>>> +#include <linux/of_fdt.h>
>>>>    #include <asm/mshyperv.h>
>>>>      static bool hyperv_initialized;
>>>> @@ -27,6 +30,29 @@ int hv_get_hypervisor_version(union hv_hypervisor_version_info *info)
>>>>        return 0;
>>>>    }
>>>>    +static bool hyperv_detect_fdt(void)
>>>> +{
>>>> +#ifdef CONFIG_OF
>>>> +    const unsigned long hyp_node = of_get_flat_dt_subnode_by_name(
>>>> +            of_get_flat_dt_root(), "hypervisor");
>>>> +
>>>> +    return (hyp_node != -FDT_ERR_NOTFOUND) &&
>>>> +            of_flat_dt_is_compatible(hyp_node, "microsoft,hyperv");
>>>> +#else
>>>> +    return false;
>>>> +#endif
>>>> +}
>>>> +
>>>> +static bool hyperv_detect_acpi(void)
>>>> +{
>>>> +#ifdef CONFIG_ACPI
>>>> +    return !acpi_disabled &&
>>>> +            !strncmp((char *)&acpi_gbl_FADT.hypervisor_id, "MsHyperV", 8);
>>>> +#else
>>>> +    return false;
>>>> +#endif
>>>> +}
>>>> +
>>>
>>> Could using IS_ENABLED() allow collapsing these two functions into one hyperv_detect_fw()?
>>> I am wondering if #ifdef was explicitly chosen to allow for the code to be compiled in if CONFIG* is defined
>>> v/s IS_ENABLED() only being true if the CONFIG value is true.
>>>
>> In the hyperv_detect_fdt function, the #ifdef has been chosen due to the functions being declared only when the macro is defined, hence I could not rely on `if IS_ENABLED()` and the run-time detection. For the compile-time option, `#if IS_ENABLED()` would convey the intent better, could update with that.
> 
> In patch 2/6, just under the diff you have, we already `select OF_EARLY_FLATTREE if OF`, so the declarations (and definitions)
> of the functions being present is already handled, AFAIK. Are we thinking there may be some weird config where neither OF nor
> ACPI is selected? If so, we should set a `depends on ACPI || OF` for config HYPERV to prevent that.
> 
> I don't know if I'm missing something obvious here, so please correct me if I'm wrong.
> 
I just sent out the v2 of the patch set, and (un?)fortunately missed the 
change I had for the #ifdef's in this chunk (to use #if IS_ENABLED() and 
remove pre-processor directives from the ACPI-related function).

I am making the point that the change you are suggesting (as I 
understand) is this conditional statement

if IS_ENABLED(CONFIG_OF) {
     const unsigned long hyp_node = of_get_flat_dt_subnode_by_name(
				of_get_flat_dt_root(), "hypervisor");

     return (hyp_node != -FDT_ERR_NOTFOUND) &&
				of_flat_dt_is_compatible(hyp_node, "microsoft,hyperv");
}

and for it to link successfully, one needs 
of_get_flat_dt_subnode_by_name defined. From the source code, that needs 
CONFIG_OF_EARLY_FLATTREE as there is no stub available when 
CONFIG_OF_EARLY_FLATTREE is not defined. I'll check on successful 
linking with the config without CONFIG_OF and the above snippet. Do feel 
free to provide the code you have in mind.

>>
>> In the hyperv_detect_acpi function, using of the #ifdef appears to be not needed, will remove that in the next version of the patch set. Appreciate your help!
>>
>> As for combining the functions into one, the result looks less readable due to more if statements and is mixing the concerns to an extent. That said, unless you feel strongly about having just one function here, perhaps could keep the both functions.
> 
> Agreed on the readability, let's keep both functions.
> 
> Thanks,
> Easwar

-- 
Thank you,
Roman

  reply	other threads:[~2024-05-14 23:17 UTC|newest]

Thread overview: 16+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-05-10 16:04 [PATCH 0/6] arm64/hyperv: Support Virtual Trust Level boot romank
2024-05-10 16:05 ` [PATCH 1/6] arm64/hyperv: Support DeviceTree romank
2024-05-10 17:04   ` Easwar Hariharan
2024-05-10 17:42     ` Roman Kisel
2024-05-14 22:46       ` Easwar Hariharan
2024-05-14 23:17         ` Roman Kisel [this message]
2024-05-15  0:00           ` Easwar Hariharan
2024-05-20 17:08             ` Roman Kisel
2024-05-10 16:05 ` [PATCH 2/6] drivers/hv: Enable VTL mode for arm64 romank
2024-05-12  2:54   ` kernel test robot
2024-05-15  7:43   ` Wei Liu
2024-05-20 17:00     ` Roman Kisel
2024-05-10 16:05 ` [PATCH 3/6] arm64/hyperv: Boot in a Virtual Trust Level romank
2024-05-10 16:05 ` [PATCH 4/6] drivers/hv: arch-neutral implementation of get_vtl() romank
2024-05-10 16:05 ` [PATCH 5/6] drivers/hv/vmbus: Get the irq number from DeviceTree romank
2024-05-10 16:05 ` [PATCH 6/6] drivers/pci/hyperv/arm64: vPCI MSI IRQ domain from DT romank

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=976901c1-1f16-464d-8e65-5b2425c8b05c@linux.microsoft.com \
    --to=romank@linux.microsoft.com \
    --cc=decui@microsoft.com \
    --cc=eahariha@linux.microsoft.com \
    --cc=haiyangz@microsoft.com \
    --cc=kys@microsoft.com \
    --cc=lenb@kernel.org \
    --cc=linux-acpi@vger.kernel.org \
    --cc=linux-hyperv@vger.kernel.org \
    --cc=rafael@kernel.org \
    --cc=ssengar@microsoft.com \
    --cc=sunilmut@microsoft.com \
    --cc=wei.liu@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).