linux-arm-kernel.lists.infradead.org archive mirror
 help / color / mirror / Atom feed
From: Luc Van Oostenryck <luc.vanoostenryck@gmail.com>
To: Andrey Konovalov <andreyknvl@google.com>
Cc: Mark Rutland <mark.rutland@arm.com>,
	Kate Stewart <kstewart@linuxfoundation.org>,
	linux-doc@vger.kernel.org,
	Catalin Marinas <catalin.marinas@arm.com>,
	Will Deacon <will.deacon@arm.com>,
	Paul Lawrence <paullawrence@google.com>,
	linux-mm@kvack.org, Alexander Potapenko <glider@google.com>,
	Chintan Pandya <cpandya@codeaurora.org>,
	Christoph Lameter <cl@linux.com>, Ingo Molnar <mingo@kernel.org>,
	Jacob Bramley <Jacob.Bramley@arm.com>,
	Ruben Ayrapetyan <Ruben.Ayrapetyan@arm.com>,
	Mark Brand <markbrand@google.com>,
	kasan-dev@googlegroups.com, linux-sparse@vger.kernel.org,
	Geert Uytterhoeven <geert@linux-m68k.org>,
	linux-arm-kernel@lists.infradead.org,
	Andrey Ryabinin <aryabinin@virtuozzo.com>,
	Dave Martin <dave.martin@arm.com>,
	Evgeniy Stepanov <eugenis@google.com>,
	Vishwath Mohan <vishwath@google.com>,
	Arnd Bergmann <arnd@arndb.de>,
	linux-kbuild@vger.kernel.org, Marc Zyngier <marc.zyngier@arm.com>,
	Ramana Radhakrishnan <Ramana.Radhakrishnan@arm.com>,
	Mike Rapoport <rppt@linux.vnet.ibm.com>,
	Dmitry Vyukov <dvyukov@google.com>,
	Kostya Serebryany <kcc@google.com>, Jann Horn <jannh@google.com>,
	Ard Biesheuvel <ard.biesheuvel@linaro.org>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	Nick Desaulniers <ndesaulniers@google.com>,
	linux-kernel@vger.kernel.org,
	"Eric W . Biederman" <ebiederm@xmission.com>,
	Lee Smith <Lee.Smith@arm.com>,
	Andrew Morton <akpm@linux-foundation.org>,
	"Kirill A . Shutemov" <kirill.shutemov@linux.intel.com>
Subject: Re: [PATCH v13 05/25] kasan: add CONFIG_KASAN_GENERIC and CONFIG_KASAN_SW_TAGS
Date: Tue, 11 Dec 2018 16:28:41 +0100	[thread overview]
Message-ID: <20181211152840.ezjujzpyz5z6fd2d@ltop.local> (raw)
In-Reply-To: <b2550106eb8a68b10fefbabce820910b115aa853.1544099024.git.andreyknvl@google.com>

On Thu, Dec 06, 2018 at 01:24:23PM +0100, Andrey Konovalov wrote:
> diff --git a/include/linux/compiler-clang.h b/include/linux/compiler-clang.h
> index 3e7dafb3ea80..39f668d5066b 100644
> --- a/include/linux/compiler-clang.h
> +++ b/include/linux/compiler-clang.h
> @@ -16,9 +16,13 @@
>  /* all clang versions usable with the kernel support KASAN ABI version 5 */
>  #define KASAN_ABI_VERSION 5
>  
> +#if __has_feature(address_sanitizer) || __has_feature(hwaddress_sanitizer)
>  /* emulate gcc's __SANITIZE_ADDRESS__ flag */
> -#if __has_feature(address_sanitizer)
>  #define __SANITIZE_ADDRESS__
> +#define __no_sanitize_address \
> +		__attribute__((no_sanitize("address", "hwaddress")))
> +#else
> +#define __no_sanitize_address
>  #endif
>  
>  /*
> diff --git a/include/linux/compiler-gcc.h b/include/linux/compiler-gcc.h
> index 2010493e1040..5776da43da97 100644
> --- a/include/linux/compiler-gcc.h
> +++ b/include/linux/compiler-gcc.h
> @@ -143,6 +143,12 @@
>  #define KASAN_ABI_VERSION 3
>  #endif
>  
> +#if __has_attribute(__no_sanitize_address__)
> +#define __no_sanitize_address __attribute__((no_sanitize_address))
> +#else
> +#define __no_sanitize_address
> +#endif

Not really important but it's the name with leading and trailing
underscores that is tested with __has_attribute() but then it's
the naked 'no_sanitize_address' that is used in the attribute.

-- Luc

_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

  reply	other threads:[~2018-12-11 15:29 UTC|newest]

Thread overview: 39+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-12-06 12:24 [PATCH v13 00/25] kasan: add software tag-based mode for arm64 Andrey Konovalov
2018-12-06 12:24 ` [PATCH v13 01/25] kasan, mm: change hooks signatures Andrey Konovalov
2018-12-06 12:24 ` [PATCH v13 02/25] kasan, slub: handle pointer tags in early_kmem_cache_node_alloc Andrey Konovalov
2018-12-06 12:24 ` [PATCH v13 03/25] kasan: move common generic and tag-based code to common.c Andrey Konovalov
2018-12-06 12:24 ` [PATCH v13 04/25] kasan: rename source files to reflect the new naming scheme Andrey Konovalov
2018-12-06 12:24 ` [PATCH v13 05/25] kasan: add CONFIG_KASAN_GENERIC and CONFIG_KASAN_SW_TAGS Andrey Konovalov
2018-12-11 15:28   ` Luc Van Oostenryck [this message]
2018-12-11 16:02     ` Andrey Konovalov
2018-12-06 12:24 ` [PATCH v13 06/25] kasan, arm64: adjust shadow size for tag-based mode Andrey Konovalov
2018-12-06 12:24 ` [PATCH v13 07/25] kasan: rename kasan_zero_page to kasan_early_shadow_page Andrey Konovalov
2018-12-06 12:24 ` [PATCH v13 08/25] kasan: initialize shadow to 0xff for tag-based mode Andrey Konovalov
     [not found]   ` <CAP=VYLo-o8vpGrpM_+0jdvxLC9uxw+F7_OtsSfRyq24HR1dDwA@mail.gmail.com>
2018-12-10 12:12     ` Andrey Konovalov
2018-12-06 12:24 ` [PATCH v13 09/25] arm64: move untagged_addr macro from uaccess.h to memory.h Andrey Konovalov
2018-12-06 12:24 ` [PATCH v13 10/25] kasan: add tag related helper functions Andrey Konovalov
2018-12-06 12:24 ` [PATCH v13 11/25] kasan, arm64: untag address in _virt_addr_is_linear Andrey Konovalov
2018-12-06 12:24 ` [PATCH v13 12/25] kasan: preassign tags to objects with ctors or SLAB_TYPESAFE_BY_RCU Andrey Konovalov
2018-12-06 12:24 ` [PATCH v13 13/25] kasan, arm64: fix up fault handling logic Andrey Konovalov
2018-12-06 12:24 ` [PATCH v13 14/25] kasan, arm64: enable top byte ignore for the kernel Andrey Konovalov
2018-12-06 12:24 ` [PATCH v13 15/25] kasan, mm: perform untagged pointers comparison in krealloc Andrey Konovalov
2018-12-06 12:24 ` [PATCH v13 16/25] kasan: split out generic_report.c from report.c Andrey Konovalov
2018-12-06 12:24 ` [PATCH v13 17/25] kasan: add bug reporting routines for tag-based mode Andrey Konovalov
2018-12-06 12:24 ` [PATCH v13 18/25] mm: move obj_to_index to include/linux/slab_def.h Andrey Konovalov
2018-12-06 12:24 ` [PATCH v13 19/25] kasan: add hooks implementation for tag-based mode Andrey Konovalov
2018-12-11 16:22   ` Vincenzo Frascino
2018-12-12 15:04     ` Andrey Konovalov
2018-12-14 12:35       ` Vincenzo Frascino
2018-12-17 19:33         ` Andrey Konovalov
2018-12-17 20:38           ` Andrew Morton
2018-12-18 13:31             ` Andrey Konovalov
2018-12-06 12:24 ` [PATCH v13 20/25] kasan, arm64: add brk handler for inline instrumentation Andrey Konovalov
2018-12-06 12:24 ` [PATCH v13 21/25] kasan, mm, arm64: tag non slab memory allocated via pagealloc Andrey Konovalov
2018-12-06 12:24 ` [PATCH v13 22/25] kasan: add __must_check annotations to kasan hooks Andrey Konovalov
2018-12-06 12:24 ` [PATCH v13 23/25] kasan, arm64: select HAVE_ARCH_KASAN_SW_TAGS Andrey Konovalov
2018-12-06 12:24 ` [PATCH v13 24/25] kasan: update documentation Andrey Konovalov
2018-12-06 12:24 ` [PATCH v13 25/25] kasan: add SPDX-License-Identifier mark to source files Andrey Konovalov
2018-12-11 15:18 ` [PATCH v13 00/25] kasan: add software tag-based mode for arm64 Will Deacon
2018-12-11 15:57   ` Andrey Konovalov
2018-12-11 16:00     ` Will Deacon
2018-12-11 21:44       ` Andrew Morton

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20181211152840.ezjujzpyz5z6fd2d@ltop.local \
    --to=luc.vanoostenryck@gmail.com \
    --cc=Jacob.Bramley@arm.com \
    --cc=Lee.Smith@arm.com \
    --cc=Ramana.Radhakrishnan@arm.com \
    --cc=Ruben.Ayrapetyan@arm.com \
    --cc=akpm@linux-foundation.org \
    --cc=andreyknvl@google.com \
    --cc=ard.biesheuvel@linaro.org \
    --cc=arnd@arndb.de \
    --cc=aryabinin@virtuozzo.com \
    --cc=catalin.marinas@arm.com \
    --cc=cl@linux.com \
    --cc=cpandya@codeaurora.org \
    --cc=dave.martin@arm.com \
    --cc=dvyukov@google.com \
    --cc=ebiederm@xmission.com \
    --cc=eugenis@google.com \
    --cc=geert@linux-m68k.org \
    --cc=glider@google.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=jannh@google.com \
    --cc=kasan-dev@googlegroups.com \
    --cc=kcc@google.com \
    --cc=kirill.shutemov@linux.intel.com \
    --cc=kstewart@linuxfoundation.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-doc@vger.kernel.org \
    --cc=linux-kbuild@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=linux-sparse@vger.kernel.org \
    --cc=marc.zyngier@arm.com \
    --cc=mark.rutland@arm.com \
    --cc=markbrand@google.com \
    --cc=mingo@kernel.org \
    --cc=ndesaulniers@google.com \
    --cc=paullawrence@google.com \
    --cc=rppt@linux.vnet.ibm.com \
    --cc=vishwath@google.com \
    --cc=will.deacon@arm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).