linux-clk.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Stephen Boyd <sboyd@kernel.org>
To: Michael Turquette <mturquette@baylibre.com>,
	Taniya Das <tdas@codeaurora.org>
Cc: David Brown <david.brown@linaro.org>,
	Rajendra Nayak <rnayak@codeaurora.org>,
	linux-arm-msm@vger.kernel.org, linux-soc@vger.kernel.org,
	linux-clk@vger.kernel.org, linux-kernel@vger.kernel.org,
	Andy Gross <agross@kernel.org>,
	devicetree@vger.kernel.org, robh@kernel.org, robh+dt@kernel.org,
	Taniya Das <tdas@codeaurora.org>
Subject: Re: [PATCH v5 4/4] clk: qcom: lpass: Add support for LPASS clock controller for SC7180
Date: Wed, 05 Aug 2020 13:24:52 -0700	[thread overview]
Message-ID: <159665909245.1360974.10366839079633595523@swboyd.mtv.corp.google.com> (raw)
In-Reply-To: <1595606878-2664-5-git-send-email-tdas@codeaurora.org>

Quoting Taniya Das (2020-07-24 09:07:58)
> +
> +static struct clk_rcg2 core_clk_src = {
> +       .cmd_rcgr = 0x1d000,
> +       .mnd_width = 8,
> +       .hid_width = 5,
> +       .parent_map = lpass_core_cc_parent_map_2,
> +       .clkr.hw.init = &(struct clk_init_data){
> +               .name = "core_clk_src",

Any chance this can get a better name? Something with LPASS prefix?

> +               .parent_data = &(const struct clk_parent_data){
> +                       .fw_name = "bi_tcxo",
> +               },
> +               .num_parents = 1,
> +               .ops = &clk_rcg2_ops,
> +       },
> +};
> +
[...]
> +
> +static struct clk_branch lpass_audio_core_sysnoc_mport_core_clk = {
> +       .halt_reg = 0x23000,
> +       .halt_check = BRANCH_HALT,
> +       .hwcg_reg = 0x23000,
> +       .hwcg_bit = 1,
> +       .clkr = {
> +               .enable_reg = 0x23000,
> +               .enable_mask = BIT(0),
> +               .hw.init = &(struct clk_init_data){
> +                       .name = "lpass_audio_core_sysnoc_mport_core_clk",
> +                       .parent_data = &(const struct clk_parent_data){
> +                               .hw = &core_clk_src.clkr.hw,
> +                       },
> +                       .num_parents = 1,
> +                       .flags = CLK_SET_RATE_PARENT,
> +                       .ops = &clk_branch2_ops,
> +               },
> +       },
> +};
> +
> +static struct clk_regmap *lpass_core_cc_sc7180_clocks[] = {
> +       [EXT_MCLK0_CLK_SRC] = &ext_mclk0_clk_src.clkr,
> +       [LPAIF_PRI_CLK_SRC] = &lpaif_pri_clk_src.clkr,
> +       [LPAIF_SEC_CLK_SRC] = &lpaif_sec_clk_src.clkr,
> +       [CORE_CLK_SRC] = &core_clk_src.clkr,

And all of these, can they have LPASS_ prefix on the defines? Seems
like we're missing a namespace otherwise.

> +       [LPASS_AUDIO_CORE_EXT_MCLK0_CLK] = &lpass_audio_core_ext_mclk0_clk.clkr,
> +       [LPASS_AUDIO_CORE_LPAIF_PRI_IBIT_CLK] =
> +               &lpass_audio_core_lpaif_pri_ibit_clk.clkr,
> +       [LPASS_AUDIO_CORE_LPAIF_SEC_IBIT_CLK] =
> +               &lpass_audio_core_lpaif_sec_ibit_clk.clkr,
> +       [LPASS_AUDIO_CORE_SYSNOC_MPORT_CORE_CLK] =
> +               &lpass_audio_core_sysnoc_mport_core_clk.clkr,
> +       [LPASS_LPAAUDIO_DIG_PLL] = &lpass_lpaaudio_dig_pll.clkr,
> +       [LPASS_LPAAUDIO_DIG_PLL_OUT_ODD] = &lpass_lpaaudio_dig_pll_out_odd.clkr,
> +};
> +

  parent reply	other threads:[~2020-08-05 20:24 UTC|newest]

Thread overview: 13+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-07-24 16:07 [PATCH v5 0/4] clk: qcom: Support for Low Power Audio Clocks on SC7180 Taniya Das
2020-07-24 16:07 ` [PATCH v5 1/4] clk: qcom: gdsc: Add support to enable retention of GSDCR Taniya Das
2020-07-24 20:13   ` Stephen Boyd
2020-07-24 16:07 ` [PATCH v5 2/4] dt-bindings: clock: Add YAML schemas for LPASS clocks on SC7180 Taniya Das
2020-07-24 20:05   ` Stephen Boyd
2020-07-24 20:13   ` Stephen Boyd
2020-07-24 16:07 ` [PATCH v5 3/4] clk: qcom: gcc: Add support for GCC LPASS clock for SC7180 Taniya Das
2020-07-24 20:13   ` Stephen Boyd
2020-07-24 16:07 ` [PATCH v5 4/4] clk: qcom: lpass: Add support for LPASS clock controller " Taniya Das
2020-07-24 20:13   ` Stephen Boyd
2020-08-05 20:24   ` Stephen Boyd [this message]
2020-08-06  5:23     ` Taniya Das
2020-08-07 21:42       ` Stephen Boyd

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=159665909245.1360974.10366839079633595523@swboyd.mtv.corp.google.com \
    --to=sboyd@kernel.org \
    --cc=agross@kernel.org \
    --cc=david.brown@linaro.org \
    --cc=devicetree@vger.kernel.org \
    --cc=linux-arm-msm@vger.kernel.org \
    --cc=linux-clk@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-soc@vger.kernel.org \
    --cc=mturquette@baylibre.com \
    --cc=rnayak@codeaurora.org \
    --cc=robh+dt@kernel.org \
    --cc=robh@kernel.org \
    --cc=tdas@codeaurora.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).