linux-crypto.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2011-11-23 20:10:50 to 2012-01-06 04:12:59 UTC [more...]

Crypto Update for 2.6.34
 2012-01-06  4:12 UTC  (10+ messages)
` Crypto Update for 2.6.35
    ` Crypto Update for 2.6.36
        ` Crypto Update for 2.6.38
          ` Crypto Update for 2.6.39
            ` Crypto Update for 2.6.40
              ` Crypto Update for 3.1
                ` Crypto Update for 3.2
                  ` Crypto Update for 3.3

cryptodev tree on github
 2012-01-06  4:01 UTC  (5+ messages)

[PATCH 1/1] Added CRYPTO_ALG_KERN_DRIVER_ONLY flag (2nd attempt)
 2012-01-06  1:37 UTC  (4+ messages)
  ` [PATCH 1/1] Added CRYPTO_ALG_KERN_DRIVER_ONLY flag (3rd attempt)

I have a Question about linux asynchronous crypto
 2012-01-06  1:35 UTC  (4+ messages)

HMAC and stuff
 2012-01-06  1:34 UTC  (2+ messages)

I have a Question about linux asynchronous crypto
 2011-12-31 10:11 UTC 

End of year bonus!!
 2011-12-25 21:55 UTC 

[PATCH] crypto - serpent-sse2: change transpose_4x4 to only use integer instructions
 2011-12-20 10:58 UTC 

[PATCH 3.2] crypto: twofish-x86_64-3way - blacklist pentium4 and atom
 2011-12-20 10:20 UTC  (4+ messages)
  ` [PATCH 1/2] "
  ` [PATCH 2/2] crypto: blowfish-x86_64 - blacklist Pentium 4

[PATCH 1/7] crypto - lrw: remove dependency on EXPERIMENTAL
 2011-12-20  7:25 UTC  (8+ messages)
` [PATCH 2/7] crypto - xts: "
` [PATCH 3/7] crypto - twofish-x86_64-3way: select LRW and XTS
` [PATCH 4/7] crypto - twofish-x86_64-3way: remove unneeded LRW/XTS #ifdefs
` [PATCH 5/7] crypto - serpent-sse2: select LRW and XTS
` [PATCH 6/7] crypto - serpent-sse2: remove unneeded LRW/XTS #ifdefs
` [PATCH 7/7] crypto - gf128mul: remove leftover "(EXPERIMENTAL)" in Kconfig

[PATCH] crypto: picoxcell: fix boolean and / or confusion
 2011-12-20  7:25 UTC  (2+ messages)

[PATCH 0/7] crypto: talitos/caam: SEC h/w v2.0 fix and cleanups
 2011-12-20  7:24 UTC  (8+ messages)
` [PATCH 1/7] crypto: talitos - fix bad kfree
` [PATCH 2/7] crypto: talitos - remove NO_IRQ references
` [PATCH 3/7] crypto: talitos - convert talitos_error to struct device
` [PATCH 5/7] crypto: caam - more desc.h cleanups
` [PATCH 6/7] crypto: caam - fix polarity of "propagate error" logic
` [PATCH 7/7] crypto: caam - remove DECO access initialization code

[PATCH 1/2] crypto: Remove global #define PFX and use, use pr_<level>
 2011-12-18 22:23 UTC  (2+ messages)
` [PATCH 2/2] crypto: Convert printks to pr_<level>

[PATCH v8 0/2] crypto: driver for Tegra AES hardware
 2011-12-16 19:58 UTC  (4+ messages)
` [PATCH v8 1/2] arm: tegra: export tegra_chip_uid
` [PATCH v8 2/2] crypto: driver for Tegra AES hardware

[RFC][PATCH 00/21] Crypto keys and module signing [ver #3]
 2011-12-16  0:41 UTC  (35+ messages)
` [PATCH 01/21] MPILIB: Export some more symbols "
` [PATCH 02/21] MPILIB: Add a missing ENOMEM check "
` [PATCH 03/21] KEYS: Permit key_serial() to be called with a const key pointer "
` [PATCH 04/21] KEYS: Move the key config into security/keys/Kconfig "
` [PATCH 05/21] KEYS: Announce key type (un)registration "
` [PATCH 06/21] KEYS: Reorganise keys Makefile "
` [PATCH 07/21] KEYS: Create a key type that can be used for general cryptographic operations "
` [PATCH 08/21] KEYS: Add signature verification facility "
` [PATCH 09/21] KEYS: Asymmetric public-key algorithm crypto key subtype "
` [PATCH 10/21] KEYS: DSA signature verification algorithm "
` [PATCH 11/21] KEYS: RSA "
` [PATCH 12/21] PGPLIB: PGP definitions (RFC 4880) "
` [PATCH 13/21] PGPLIB: Basic packet parser "
` [PATCH 14/21] PGPLIB: Signature "
` [PATCH 15/21] KEYS: PGP data "
` [PATCH 16/21] KEYS: PGP-based public key signature verification "
` [PATCH 17/21] KEYS: PGP format signature parser "
` [PATCH 18/21] KEYS: Provide a function to load keys from a PGP keyring blob "
` [PATCH 19/21] MODSIGN: Add indications of module ELF types "
` [PATCH 20/21] MODSIGN: Module ELF verifier "
` [PATCH 21/21] MODSIGN: Apply signature checking to modules on module load "

[PATCH v5.2 00/14] crc32c: Add faster algorithm and self-test code
 2011-12-13 18:36 UTC  (27+ messages)
` [PATCH 01/14] crc32: removed two instances of trailing whitespaces
` [PATCH 02/14] crc32: Move long comment about crc32 fundamentals to Documentation/
` [PATCH 03/14] crc32: Simplify unit test code
` [PATCH 04/14] crc32: Speed up memory table access on powerpc
` [PATCH 05/14] crc32: Miscellaneous cleanups
` [PATCH 06/14] crc32: Fix mixing of endian-specific types
` [PATCH 07/14] crc32: Make CRC_*_BITS definition correspond to actual bit counts
` [PATCH 08/14] crc32: Add slice-by-8 algorithm to existing code
` [PATCH 09/14] crc32: Optimize loop counter for x86
` [PATCH 10/14] crc32: Add note about this patchset to crc32.c
` [PATCH 11/14] crc32: Bolt on crc32c
` [PATCH 12/14] crypto: crc32c should use library implementation
` [PATCH 13/14] crc32: Add self-test code for crc32c
` [PATCH 14/14] crc32: Select an algorithm via kconfig

drivers/crypto/picoxcell_crypto.c: boolean and / or confusion
 2011-12-13 14:26 UTC  (4+ messages)
  ` drivers/media/video/s5p-fimc/fimc-capture.c: "

From Libyan embassy
 2011-12-13 13:17 UTC 

[PATCH 1/1] Added CRYPTO_ALG_KERN_DRIVER_ONLY flag
 2011-12-13  8:54 UTC  (3+ messages)

Xmas Lening Aanbieding
 2011-12-12 13:11 UTC 

RFC: redesigning random(4)
 2011-12-12  5:46 UTC  (2+ messages)

Product Order
 2011-12-09 12:46 UTC 

A fiddle for /dev/random
 2011-12-09  2:48 UTC 

[PATCH 0/3] crypto: Add per-cpu transform helpers
 2011-12-07 18:59 UTC  (4+ messages)
` [PATCH 1/3] crypto: Add per-cpu transform alloc() and free()
` [PATCH 2/3] crypto: Add inline per-cpu wrappers for compression
` [PATCH 3/3] xfrm: Modify xfrm_ipcomp code to use new per-cpu helpers

[RFC][PATCH 00/16] Crypto keys and module signing [ver #2]
 2011-12-07 14:29 UTC  (26+ messages)
` [PATCH 01/16] MPILIB: Export some more symbols "
` [PATCH 02/16] MPILIB: Add a missing ENOMEM check "
` [PATCH 03/16] KEYS: Permit key_serial() to be called with a const key pointer "
` [PATCH 04/16] PGP: Add definitions (RFC 4880) and packet parser "
` [PATCH 05/16] KEYS: Create a key type that can be used for general cryptographic operations "
` [PATCH 06/16] KEYS: Add a DSA crypto key subtype "
` [PATCH 07/16] KEYS: Add a RSA "
` [PATCH 08/16] PGP: Add signature parser "
` [PATCH 09/16] KEYS: Add signature verification facility "
` [PATCH 10/16] KEYS: DSA key signature verification "
` [PATCH 11/16] KEYS: RSA "
` [PATCH 12/16] KEYS: Add a crypto key request function "
` [PATCH 13/16] KEYS: Provide a function to load keys from a PGP keyring blob "
` [PATCH 14/16] MODSIGN: Add indications of module ELF types "
` [PATCH 15/16] MODSIGN: Module ELF verifier "
` [PATCH 16/16] MODSIGN: Apply signature checking to modules on module load "
  ` [Keyrings] [RFC][PATCH 00/16] Crypto keys and module signing "

Christmas Award
 2011-12-07  9:07 UTC 

[PATCH 0/3] crypto: Add per-cpu transform helpers
 2011-12-06 22:45 UTC 

MESSAGE FROM FBI OFFICE, CAREFULLY READ THE ATTACHMENT AND COMPLY IMMEDIATELY
 2011-12-05  9:21 UTC 

[PATCH 3.2] crypto: blowfish-x86_64 - blacklist Pentium 4
 2011-12-04 10:33 UTC 

[PATCH v5.1 00/14] crc32c: Add faster algorithm and self-test code
 2011-12-01 20:12 UTC  (17+ messages)
` [PATCH 01/14] removed two instances of trailing whitespaces
` [PATCH 02/14] Moved a long comment from lib/crc32.c to Documentation/crc32.txt
` [PATCH 03/14] Replaced the unit test provided in crc32.c, which doesn't have a
` [PATCH 04/14] Replace 2D array references by pointer references in loops
` [PATCH 05/14] Misc cleanup of lib/crc32.c and related files
` [PATCH 06/14] crc32.c in its original version freely mixed u32, __le32 and __be32 types
` [PATCH 07/14] crc32.c provides a choice of one of several algorithms for
` [PATCH 08/14] add slicing-by-8 algorithm to the existing
` [PATCH 09/14] Add two changes that improve the performance of x86 systems
` [PATCH 10/14] Some final changes
` [PATCH 11/14] crc32: Bolt on crc32c
` [PATCH 12/14] crypto: crc32c should use library implementation
` [PATCH 13/14] crc32: Add self-test code for crc32c
` [PATCH 14/14] crc32: Select an algorithm via kconfig

Per-cpu tfm allocation/free functions
 2011-12-01 17:01 UTC 

DM-Steg: New steganographic encryption module
 2011-11-30 16:27 UTC 

linux-next: Tree for Nov 23 (crypto)
 2011-11-30  8:18 UTC  (4+ messages)
  ` [PATCH] crypto: serpent-sse2 - should select CRYPTO_CRYPTD

[PATCH 1/2] crypto: serpent - cleanup checkpatch errors and warnings
 2011-11-30  8:18 UTC  (3+ messages)
` [PATCH 2/2] crypto: serpent - rename serpent.c to serpent_generic.c

Announce loop-AES-v3.6e file/swap crypto package
 2011-11-29 15:01 UTC 

[PATCH 01/14] MPILIB: Export some more symbols
 2011-11-28 16:27 UTC  (15+ messages)
` [PATCH 02/14] KEYS: Permit key_serial() to be called with a const key pointer
` [PATCH 03/14] PGP: Add definitions (RFC 4880) and packet parser
` [PATCH 04/14] KEYS: Create a key type that can be used for general cryptographic operations
` [PATCH 05/14] KEYS: Add a DSA crypto key subtype
` [PATCH 06/14] KEYS: Add a RSA "
` [PATCH 07/14] PGP: Add signature parser
` [PATCH 08/14] KEYS: Add signature verification facility
` [PATCH 09/14] KEYS: DSA key signature verification
` [PATCH 10/14] KEYS: Add a crypto key request function
` [PATCH 11/14] KEYS: Provide a function to load keys from a PGP keyring blob
` [PATCH 12/14] MODSIGN: Add indications of module ELF types
` [PATCH 13/14] MODSIGN: Module ELF verifier
` [PATCH 14/14] MODSIGN: Apply signature checking to modules on module load
` [PATCH 00/14][RFC] Crypto keys and module signing

[PATCH 08/62] x86: remove the second argument of k[un]map_atomic()
 2011-11-28 12:47 UTC  (5+ messages)
` [PATCH 09/62] crypto: "
` [PATCH 12/62] "

[PATCH] crypto: convert drivers/crypto/* to use module_platform_driver()
 2011-11-26 14:55 UTC  (3+ messages)

Crypto Fixes for 2.6.35
 2011-11-26  2:34 UTC  (10+ messages)
    ` Crypto Fixes for 2.6.36
      ` Crypto Fixes for 2.6.37
          ` Crypto Fixes for 2.6.39
            ` Crypto Fixes for 3.0
              ` Crypto Fixes for 3.1
                ` Crypto Fixes for 3.2


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).