linux-fpga.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Xu Yilun <yilun.xu@intel.com>
To: Russ Weight <russell.h.weight@intel.com>
Cc: mdf@kernel.org, linux-fpga@vger.kernel.org, trix@redhat.com,
	lgoncalv@redhat.com, hao.wu@intel.com, matthew.gerlach@intel.com,
	richard.gong@intel.com
Subject: Re: [PATCH v2 5/8] fpga: region: Rename dev to parent for parent device
Date: Thu, 10 Jun 2021 16:25:02 +0800	[thread overview]
Message-ID: <20210610082502.GG2007225@yilunxu-OptiPlex-7050> (raw)
In-Reply-To: <20210609221135.261837-6-russell.h.weight@intel.com>

Sorry, one more minor comment inline.

On Wed, Jun 09, 2021 at 03:11:32PM -0700, Russ Weight wrote:
> Rename variable "dev" to "parent" in cases where it represents the parent
> device.
> 
> Signed-off-by: Russ Weight <russell.h.weight@intel.com>
> ---
> v2:
>   - This patch contains the renaming of "dev" to "parent" that was previously
>     part of the patch: "fpga: region: Use standard dev_release for class driver"
> ---
>  drivers/fpga/fpga-region.c | 14 +++++++-------
>  1 file changed, 7 insertions(+), 7 deletions(-)
> 
> diff --git a/drivers/fpga/fpga-region.c b/drivers/fpga/fpga-region.c
> index c3134b89c3fe..563626d66e56 100644
> --- a/drivers/fpga/fpga-region.c
> +++ b/drivers/fpga/fpga-region.c
> @@ -181,7 +181,7 @@ ATTRIBUTE_GROUPS(fpga_region);
>  
>  /**
>   * fpga_region_create - alloc and init a struct fpga_region
> - * @dev: device parent
> + * @parent: device parent
>   * @mgr: manager that programs this region
>   * @get_bridges: optional function to get bridges to a list
>   *
> @@ -192,7 +192,7 @@ ATTRIBUTE_GROUPS(fpga_region);
>   * Return: struct fpga_region or NULL
>   */
>  struct fpga_region
> -*fpga_region_create(struct device *dev,
> +*fpga_region_create(struct device *parent,
>  		    struct fpga_manager *mgr,
>  		    int (*get_bridges)(struct fpga_region *))
>  {
> @@ -214,8 +214,8 @@ struct fpga_region
>  
>  	device_initialize(&region->dev);
>  	region->dev.class = fpga_region_class;
> -	region->dev.parent = dev;
> -	region->dev.of_node = dev->of_node;
> +	region->dev.parent = parent;
> +	region->dev.of_node = parent->of_node;
>  	region->dev.id = id;
>  
>  	ret = dev_set_name(&region->dev, "region%d", id);
> @@ -268,7 +268,7 @@ static void devm_fpga_region_release(struct device *dev, void *res)
>   * Return: struct fpga_region or NULL
>   */
>  struct fpga_region
> -*devm_fpga_region_create(struct device *dev,
> +*devm_fpga_region_create(struct device *parent,

You missed the function description doc change in Patch #8

Thanks,
Yilun

>  			 struct fpga_manager *mgr,
>  			 int (*get_bridges)(struct fpga_region *))



>  {
> @@ -278,12 +278,12 @@ struct fpga_region
>  	if (!ptr)
>  		return NULL;
>  
> -	region = fpga_region_create(dev, mgr, get_bridges);
> +	region = fpga_region_create(parent, mgr, get_bridges);
>  	if (!region) {
>  		devres_free(ptr);
>  	} else {
>  		*ptr = region;
> -		devres_add(dev, ptr);
> +		devres_add(parent, ptr);
>  	}
>  
>  	return region;
> -- 
> 2.25.1

  parent reply	other threads:[~2021-06-10  8:31 UTC|newest]

Thread overview: 19+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-06-09 22:11 [PATCH v2 0/8] fpga: Populate dev_release functions Russ Weight
2021-06-09 22:11 ` [PATCH v2 1/8] fpga: altera-pr-ip: Remove function alt_pr_unregister Russ Weight
2021-06-10  7:37   ` Xu Yilun
2021-06-09 22:11 ` [PATCH v2 2/8] fpga: stratix10-soc: Add missing fpga_mgr_free() call Russ Weight
2021-06-09 22:11 ` [PATCH v2 3/8] fpga: mgr: Rename dev to parent for parent device Russ Weight
2021-06-10  8:02   ` Xu Yilun
2021-06-09 22:11 ` [PATCH v2 4/8] fpga: bridge: " Russ Weight
2021-06-10  8:04   ` Xu Yilun
2021-06-09 22:11 ` [PATCH v2 5/8] fpga: region: " Russ Weight
2021-06-10  8:07   ` Xu Yilun
2021-06-10  8:25   ` Xu Yilun [this message]
2021-06-10 18:45     ` Russ Weight
2021-06-09 22:11 ` [PATCH v2 6/8] fpga: mgr: Use standard dev_release for class driver Russ Weight
2021-06-10  8:13   ` Xu Yilun
2021-06-09 22:11 ` [PATCH v2 7/8] fpga: bridge: " Russ Weight
2021-06-10  8:17   ` Xu Yilun
2021-06-09 22:11 ` [PATCH v2 8/8] fpga: region: " Russ Weight
2021-06-10  8:29   ` Xu Yilun
2021-06-10 18:53     ` Russ Weight

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20210610082502.GG2007225@yilunxu-OptiPlex-7050 \
    --to=yilun.xu@intel.com \
    --cc=hao.wu@intel.com \
    --cc=lgoncalv@redhat.com \
    --cc=linux-fpga@vger.kernel.org \
    --cc=matthew.gerlach@intel.com \
    --cc=mdf@kernel.org \
    --cc=richard.gong@intel.com \
    --cc=russell.h.weight@intel.com \
    --cc=trix@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).