From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Date: Sun, 20 May 2018 22:42:36 -0600 From: Ross Zwisler To: Matthew Wilcox Cc: linux-mm@kvack.org, linux-fsdevel@vger.kernel.org, Matthew Wilcox , Jan Kara , Jeff Layton , Lukas Czerner , Ross Zwisler , Christoph Hellwig , Goldwyn Rodrigues , Nicholas Piggin , Ryusuke Konishi , linux-nilfs@vger.kernel.org, Jaegeuk Kim , Chao Yu , linux-f2fs-devel@lists.sourceforge.net, Oleg Drokin , Andreas Dilger , James Simmons , Mike Kravetz Subject: Re: [PATCH v11 53/63] dax: Rename some functions Message-ID: <20180521044236.GC27043@linux.intel.com> References: <20180414141316.7167-1-willy@infradead.org> <20180414141316.7167-54-willy@infradead.org> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20180414141316.7167-54-willy@infradead.org> Sender: owner-linux-mm@kvack.org List-ID: On Sat, Apr 14, 2018 at 07:13:06AM -0700, Matthew Wilcox wrote: > From: Matthew Wilcox > > Remove mentions of 'radix' and 'radix tree'. Simplify some names by > dropping the word 'mapping'. > > Signed-off-by: Matthew Wilcox > @@ -74,18 +74,18 @@ fs_initcall(init_dax_wait_table); > #define DAX_ZERO_PAGE (1UL << 2) > #define DAX_EMPTY (1UL << 3) > > -static unsigned long dax_radix_pfn(void *entry) > +static unsigned long dax_to_pfn(void *entry) > { > return xa_to_value(entry) >> DAX_SHIFT; > } > > -static void *dax_radix_locked_entry(unsigned long pfn, unsigned long flags) > +static void *dax_mk_locked(unsigned long pfn, unsigned long flags) Let's continue to use whole words in function names instead of abbreviations for readability. Can you please s/dax_mk_locked/dax_make_locked/ ? I do realize that the xarray function is xa_mk_value() (which I also think is perhaps too brief for readability), but in the rest of DAX we use full words everywhere. > @@ -1519,15 +1517,14 @@ int dax_iomap_fault(struct vm_fault *vmf, enum page_entry_size pe_size, > } > EXPORT_SYMBOL_GPL(dax_iomap_fault); > > -/** > +/* Let's leave the double ** so that the function is picked up properly by the documentation system, and so it's consistent with the rest of the functions.