linux-fsdevel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Christoph Hellwig <hch@lst.de>
To: Al Viro <viro@zeniv.linux.org.uk>
Cc: Christoph Hellwig <hch@lst.de>,
	Linus Torvalds <torvalds@linux-foundation.org>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	"Rafael J. Wysocki" <rafael@kernel.org>,
	Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
	linux-raid@vger.kernel.org,
	linux-fsdevel <linux-fsdevel@vger.kernel.org>,
	Linux API <linux-api@vger.kernel.org>
Subject: Re: add file system helpers that take kernel pointers for the init code v3
Date: Sun, 26 Jul 2020 18:24:26 +0200	[thread overview]
Message-ID: <20200726162426.GA24479@lst.de> (raw)
In-Reply-To: <20200726162113.GR2786714@ZenIV.linux.org.uk>

On Sun, Jul 26, 2020 at 05:21:13PM +0100, Al Viro wrote:
> On Sun, Jul 26, 2020 at 05:52:04PM +0200, Christoph Hellwig wrote:
> > On Sun, Jul 26, 2020 at 08:49:28AM -0700, Linus Torvalds wrote:
> > > On Sun, Jul 26, 2020 at 12:14 AM Christoph Hellwig <hch@lst.de> wrote:
> > > >
> > > > Hi Al and Linus,
> > > >
> > > > currently a lot of the file system calls in the early in code (and the
> > > > devtmpfs kthread) rely on the implicit set_fs(KERNEL_DS) during boot.
> > > > This is one of the few last remaining places we need to deal with to kill
> > > > off set_fs entirely, so this series adds new helpers that take kernel
> > > > pointers.  These helpers are in init/ and marked __init and thus will
> > > > be discarded after bootup.  A few also need to be duplicated in devtmpfs,
> > > > though unfortunately.
> > > 
> > > I see nothing objectionable here.
> > > 
> > > The only bikeshed comment I have is that I think the "for_init.c" name
> > > is ugly and pointless - I think you could just call it "fs/init.c" and
> > > it's both simpler and more straightforward. It _is_ init code, it's
> > > not "for" init.
> > 
> > That was Al's suggestion.  I personally don't care, so if between the
> > two of you, you can come up with a preferred choice I'll switch to it.
> 
> I can live with either variant; the only problem with fs/init.c is that
> such name would imply the init code _of_ VFS, rather than VFS helpers for
> init.
> 
> Anyway, the series looks generally sane; if no other objections are raised,
> I'm adding it to vfs.git#for-next

Thanks!

Note that this is based on top of my init-user-pointers branch, so you'll
need to pull that in as.

Btw, care to take a look at 

http://git.infradead.org/users/hch/misc.git/shortlog/refs/heads/kernel_readwrite

it has been in linux-next for 2 1/2 weeks, and the only interesting
thing found was that btrfs didn't wire up iter_splice_write, which has
already been fixed in mainline.

  reply	other threads:[~2020-07-26 16:24 UTC|newest]

Thread overview: 30+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-07-26  7:13 add file system helpers that take kernel pointers for the init code v3 Christoph Hellwig
2020-07-26  7:13 ` [PATCH 01/21] fs: refactor do_mount Christoph Hellwig
2020-07-26  7:13 ` [PATCH 02/21] fs: refactor ksys_umount Christoph Hellwig
2020-07-26  7:13 ` [PATCH 03/21] fs: push the getname from do_rmdir into the callers Christoph Hellwig
2020-07-26  7:13 ` [PATCH 04/21] devtmpfs: refactor devtmpfsd() Christoph Hellwig
2020-07-26  7:43   ` Greg Kroah-Hartman
2020-07-26  8:21     ` Christoph Hellwig
2020-07-26  7:13 ` [PATCH 05/21] init: initialize ramdisk_execute_command at compile time Christoph Hellwig
2020-07-26  7:13 ` [PATCH 06/21] init: mark create_dev as __init Christoph Hellwig
2020-07-26  7:13 ` [PATCH 07/21] init: add an init_mount helper Christoph Hellwig
2020-07-26  7:13 ` [PATCH 08/21] init: add an init_umount helper Christoph Hellwig
2020-07-26  7:13 ` [PATCH 09/21] init: add an init_unlink helper Christoph Hellwig
2020-07-26  7:13 ` [PATCH 10/21] init: add an init_rmdir helper Christoph Hellwig
2020-07-26  7:13 ` [PATCH 11/21] init: add an init_chdir helper Christoph Hellwig
2020-07-26  7:13 ` [PATCH 12/21] init: add an init_chroot helper Christoph Hellwig
2020-07-26  7:13 ` [PATCH 13/21] init: add an init_chown helper Christoph Hellwig
2020-07-26  7:13 ` [PATCH 14/21] init: add an init_chmod helper Christoph Hellwig
2020-07-26  7:13 ` [PATCH 15/21] init: add an init_eaccess helper Christoph Hellwig
2020-07-26  7:13 ` [PATCH 16/21] init: add an init_link helper Christoph Hellwig
2020-07-26  7:13 ` [PATCH 17/21] init: add an init_symlink helper Christoph Hellwig
2020-07-26  7:13 ` [PATCH 18/21] init: add an init_mkdir helper Christoph Hellwig
2020-07-26  7:13 ` [PATCH 19/21] init: add an init_mknod helper Christoph Hellwig
2020-07-26  7:13 ` [PATCH 20/21] init: add an init_stat helper Christoph Hellwig
2020-07-26  7:13 ` [PATCH 21/21] init: add an init_utimes helper Christoph Hellwig
2020-07-26 15:49 ` add file system helpers that take kernel pointers for the init code v3 Linus Torvalds
2020-07-26 15:52   ` Christoph Hellwig
2020-07-26 16:21     ` Al Viro
2020-07-26 16:24       ` Christoph Hellwig [this message]
2020-07-26 16:26         ` Christoph Hellwig
2020-07-26 16:33           ` Al Viro

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200726162426.GA24479@lst.de \
    --to=hch@lst.de \
    --cc=gregkh@linuxfoundation.org \
    --cc=linux-api@vger.kernel.org \
    --cc=linux-fsdevel@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-raid@vger.kernel.org \
    --cc=rafael@kernel.org \
    --cc=torvalds@linux-foundation.org \
    --cc=viro@zeniv.linux.org.uk \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).