linux-fsdevel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2009-05-28 20:10:39 to 2009-06-03 14:57:40 UTC [more...]

[RFC][PATCH 0/9] File descriptor hot-unplug support
 2009-06-03 14:57 UTC  (42+ messages)
` [PATCH 0/23] File descriptor hot-unplug support v2
  ` [PATCH 01/23] mm: Introduce revoke_file_mappings
  ` [PATCH 02/23] vfs: Implement unpoll_file
  ` [PATCH 03/23] vfs: Generalize the file_list
  ` [PATCH 04/23] vfs: Introduce infrastructure for revoking a file
  ` [PATCH 05/23] vfs: Teach lseek to use file_hotplug_lock
  ` [PATCH 06/23] vfs: Teach read/write to use file_hotplug_read_lock
  ` [PATCH 07/23] vfs: Teach sendfile,splice,tee,and vmsplice to use file_hotplug_lock
  ` [PATCH 08/23] vfs: Teach readdir "
  ` [PATCH 09/23] vfs: Teach poll and select "
  ` [PATCH 10/23] vfs: Teach do_path_lookup "
  ` [PATCH 11/23] mm: Teach mmap "
  ` [PATCH 12/23] vfs: Teach fcntl "
  ` [PATCH 13/23] vfs: Teach ioctl "
  ` [PATCH 14/23] vfs: Teach flock "
  ` [PATCH 15/23] vfs: Teach fallocate, and filp_close "
  ` [PATCH 16/23] vfs: Teach fstatfs, fstatfs64, ftruncate, fchdir, fchmod, fchown "
  ` [PATCH 17/23] proc: Teach /proc/<pid>/fd "
  ` [PATCH 18/23] vfs: Teach epoll "
  ` [PATCH 19/23] eventpoll: Fix comment
  ` [PATCH 20/23] vfs: Teach aio to use file_hotplug_lock
  ` [PATCH 21/23] vfs: Teach fsync "
  ` [PATCH 22/23] vfs: Teach fadvice to file_hotplug_lock
  ` [PATCH 23/23] vfs: Teach readahead to use the file_hotplug_lock

[PATCH][BUG] Lack of mutex_lock in drop_pagecache_sb()
 2009-06-03 14:47 UTC  (17+ messages)
        ` [PATCH] skip I_CLEAR state inodes

ANNOUNCE: mdadm 3.0 - A tool for managing Soft RAID under Linux
 2009-06-03 14:42 UTC  (5+ messages)
    `  "

RFC: kill msdos and vfat modules?
 2009-06-03 14:32 UTC 

[PATCH] fuse: cache invalidation calls
 2009-06-03 12:51 UTC 

[PATCH 0/11] Per-bdi writeback flusher threads v9
 2009-06-03 11:42 UTC  (28+ messages)
` [PATCH 04/11] writeback: switch to per-bdi threads for flushing data

[PATCH 0/5] FAT errors, user space notifications
 2009-06-03 11:36 UTC  (10+ messages)
` [PATCH 1/5] FAT: add 'errors' mount option
  ` [PATCH 2/5] FS: filesystem corruption notification
    ` [PATCH 3/5] FAT: generalize errors and warning printing
      ` [PATCH 4/5] FAT: add 'notify' mount option
        ` [PATCH 5/5] EXT2: "

[PATCH 00/19] periodic write-back timer optimization
 2009-06-03 11:13 UTC  (9+ messages)

Why do fs outside regular namespace clear DCACHE_UNHASHED?
 2009-06-03  8:06 UTC  (4+ messages)

[PATCH] fuse: cache invalidation calls
 2009-06-03  8:01 UTC 

[PATCH] Return a negative error code when seq_path_root() fails
 2009-06-03  1:35 UTC 

MD and DM (was: Re: ANNOUNCE: mdadm 3.0 - A tool for managing Soft RAID under Linux)
 2009-06-02 23:39 UTC 

[PATCH 0/20] Sysfs cleanups
 2009-06-02 22:57 UTC  (75+ messages)
` [PATCH 01/20] sysfs: Implement sysfs_rename_link
        ` [PATCH 0/24] sysfs cleanups
          ` [PATCH 01/24] sysfs: Implement sysfs_rename_link
          ` [PATCH 02/24] driver core: Use sysfs_rename_link in device_rename
          ` [PATCH 03/24] sysfs: Remove now unnecessary error reporting suppression
          ` [PATCH 04/24] sysfs: Normalize removing sysfs directories
          ` [PATCH 05/24] sysfs: Rename sysfs_d_iput to sysfs_dentry_iput
          ` [PATCH 06/24] sysfs: Use dentry_ops instead of directly playing with the dcache
          ` [PATCH 07/24] sysfs: Simplify sysfs_chmod_file semantics
          ` [PATCH 08/24] sysfs: Optimize just changing the sysfs file mode
          ` [PATCH 09/24] sysfs: Simplify iattr assignments
          ` [PATCH 10/24] sysfs: Fix locking and factor out sysfs_sd_setattr
          ` [PATCH 11/24] sysfs: Update s_iattr on link and unlink
          ` [PATCH 12/24] sysfs: Nicely indent sysfs_symlink_inode_operations
          ` [PATCH 13/24] sysfs: Implement sysfs_getattr & sysfs_permission
          ` [PATCH 14/24] sysfs: In sysfs_chmod_file lazily propagate the mode change
          ` [PATCH 15/24] sysfs: Kill sysfs_addrm_start and sysfs_addrm_finish
          ` [PATCH 16/24] sysfs: Propagate renames to the vfs on demand
          ` [PATCH 17/24] sysfs: Merge sysfs_rename_dir and sysfs_move_dir
          ` [PATCH 18/24] sysfs: Pass super_block to sysfs_get_inode
          ` [PATCH 19/24] sysfs: Kill unused sysfs_sb variable
          ` [PATCH 20/24] sysfs: Normalize error handling in sysfs_fill_inode
          ` [PATCH 21/24] sysfs: Rename sysfs_mv_dir sysfs_rename
          ` [PATCH 22/24] sysfs: Make sysfs_rename_link atomic
          ` [PATCH 23/24] driver core: Don't remove kobjects in device_shutdown
          ` [PATCH 24/24] sysfs: In sysfs_add_one fail if the targe directory has been removed
          ` [PATCH 0/26] sysfs cleanups v3
            ` [PATCH 01/26] sysfs: Implement sysfs_rename_link
              ` patch sysfs-implement-sysfs_rename_link.patch added to gregkh-2.6 tree
            ` [PATCH 02/26] driver core: Use sysfs_rename_link in device_rename
              ` patch driver-core-use-sysfs_rename_link-in-device_rename.patch added to gregkh-2.6 tree
            ` [PATCH 03/26] sysfs: Remove now unnecessary error reporting suppression
              ` patch sysfs-remove-now-unnecessary-error-reporting-suppression.patch added to gregkh-2.6 tree
            ` [PATCH 04/26] sysfs: sysfs_remove_dir stop checking for bogus cases
            ` [PATCH 05/26] sysfs: Improve sysfs directory deletion debugging
            ` [PATCH 06/26] sysfs: Don't hold addrm_start/addrm_finish over multiple removals
            ` [PATCH 07/26] sysfs: Rename sysfs_d_iput to sysfs_dentry_iput
            ` [PATCH 08/26] sysfs: Use dentry_ops instead of directly playing with the dcache
            ` [PATCH 09/26] sysfs: Simplify sysfs_chmod_file semantics
            ` [PATCH 10/26] sysfs: Optimize just changing the sysfs file mode
            ` [PATCH 11/26] sysfs: Simplify iattr assignments
            ` [PATCH 12/26] sysfs: Fix locking and factor out sysfs_sd_setattr
            ` [PATCH 13/26] sysfs: Update s_iattr on link and unlink
            ` [PATCH 14/26] sysfs: Nicely indent sysfs_symlink_inode_operations
            ` [PATCH 15/26] sysfs: Implement sysfs_getattr & sysfs_permission
            ` [PATCH 16/26] sysfs: In sysfs_chmod_file lazily propagate the mode change
            ` [PATCH 17/26] sysfs: Kill sysfs_addrm_start and sysfs_addrm_finish
            ` [PATCH 18/26] sysfs: Propagate renames to the vfs on demand
            ` [PATCH 19/26] sysfs: Merge sysfs_rename_dir and sysfs_move_dir
            ` [PATCH 20/26] sysfs: Pass super_block to sysfs_get_inode
            ` [PATCH 21/26] sysfs: Kill unused sysfs_sb variable
            ` [PATCH 22/26] sysfs: Normalize error handling in sysfs_fill_inode
            ` [PATCH 23/26] sysfs: Rename sysfs_mv_dir sysfs_rename
            ` [PATCH 24/26] sysfs: Make sysfs_rename_link atomic
            ` [PATCH 25/26] driver core: Don't remove kobjects in device_shutdown
            ` [PATCH 26/26] sysfs: In sysfs_add_one fail if the targe directory has been removed

Good Day
 2009-06-02 14:54 UTC 

[PATCH 0/12] Per-bdi writeback flusher threads v7
 2009-06-02 11:53 UTC  (5+ messages)

[patch] fs: improve remount,ro coherency
 2009-06-02 10:11 UTC 

[patch] fs: remove incorrect I_NEW warnings
 2009-06-02 10:07 UTC 

[PATCH 0/2] Use hrtimers in UBIFS
 2009-06-02  5:39 UTC  (8+ messages)
` [PATCH 1/2] hrtimer: export ktime_add_safe
` [PATCH 2/2] UBIFS: start using hrtimers

[PATCH] readahead:add blk_run_backing_dev
 2009-06-01  4:30 UTC  (16+ messages)

[PATCH] readahead:add blk_run_backing_dev
 2009-06-01  2:23 UTC  (5+ messages)

[RESEND] [PATCH] readahead:add blk_run_backing_dev
 2009-06-01  1:04 UTC  (3+ messages)

[PATCH 25/20] sysfs: Only support removing emtpy sysfs directories
 2009-05-29 20:08 UTC  (5+ messages)

UBIFS: "sync" mount option does not work
 2009-05-29 13:26 UTC  (4+ messages)

Is TRIM/DISCARD going to be a performance problem?
 2009-05-29 10:52 UTC  (6+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).