linux-hardening.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-09-30 21:11:13 to 2020-10-26 21:24:08 UTC [more...]

UBSAN: array-index-out-of-bounds in alg_bind
 2020-10-26 21:23 UTC  (8+ messages)
        ` [PATCH] crypto: af_alg - avoid undefined behavior accessing salg_name

BTI interaction between seccomp filters in systemd and glibc mprotect calls, causing service failures
 2020-10-26 16:51 UTC  (12+ messages)

[PATCH v4] mm: Optional full ASLR for mmap() and mremap()
 2020-10-26 16:05 UTC 

[RFC][PATCH v3 0/3] Fix inefficiences and rename nla_strlcpy
 2020-10-24 10:41 UTC  (17+ messages)
` [RFC][PATCH v3 1/3] Fix unefficient call to memset before memcpu in nla_strlcpy
` [RFC][PATCH v3 2/3] Modify return value of nla_strlcpy to match that of strscpy
` [RFC][PATCH v3 3/3] Rename nla_strlcpy to nla_strscpy

[RFC][PATCH v3 0/5] Fortify string function strscpy
 2020-10-24 10:36 UTC  (11+ messages)
` [PATCH v3 1/5] string.h: detect intra-object overflow in fortified string functions
` [PATCH v3 2/5] lkdtm: tests for FORTIFY_SOURCE
` [RFC][PATCH v3 3/5] Fortify string function strscpy
` [RFC][PATCH v3 4/5] Add new file in LKDTM to test fortified strscpy
` [RFC][PATCH v3 5/5] Correct wrong filenames in comment

[PATCH] mm, hugetlb: Avoid double clearing for hugetlb pages
 2020-10-23  8:23 UTC  (16+ messages)

[RFC][PATCH v1] Fortify string function strscpy
 2020-10-21 14:49 UTC  (8+ messages)
` [RFC][PATCH v2] "

[RFC][PATCH v1] Fix and rename nla_strlcpy to nla_strcpy
 2020-10-20 17:23 UTC  (31+ messages)
` [PATCH v1 1/3] Fix unefficient call to memset before memcpu in nla_strlcpy
` [PATCH v1 2/3] Modify return value of nla_strlcpy to match that of strscpy
` [PATCH v1 3/3] Rename nla_strlcpy to nla_strcpy
` [RFC][PATCH v2 0/3] Fix inefficiences and rename nla_strlcpy
  ` [RFC][PATCH v2 1/3] Fix unefficient call to memset before memcpu in nla_strlcpy
  ` [RFC][PATCH v2 2/3] Modify return value of nla_strlcpy to match that of strscpy
  ` [RFC][PATCH v2 3/3] Rename nla_strlcpy to nla_strcpy

[PATCH v3] mm: Optional full ASLR for mmap() and mremap()
 2020-10-17 19:47 UTC 

Disinfectant
 2020-10-13  7:57 UTC 

Remove all strlcpy() uses in favor of strscpy() (#89)
 2020-10-12 19:03 UTC 

[PATCH][next] net: thunderx: Use struct_size() helper in kmalloc()
 2020-10-10 17:36 UTC  (2+ messages)

[PATCH][next] amd/amdgpu_ctx: Use struct_size() helper and kmalloc()
 2020-10-09 14:39 UTC  (6+ messages)

[PATCH][next] drm/amdgpu: Use struct_size() helper in kmalloc()
 2020-10-09  7:07 UTC  (3+ messages)

[PATCH][next] media: pxa_camera: Use fallthrough pseudo-keyword
 2020-10-08 22:55 UTC 

[PATCH][next] usb: musb: gadget: Use fallthrough pseudo-keyword
 2020-10-08 22:28 UTC 

[PATCH][next] Input: libps2 - Use fallthrough pseudo-keyword
 2020-10-08 22:25 UTC 

[PATCH][next] drm/i915/display: Use fallthrough pseudo-keyword
 2020-10-08 22:18 UTC 

[PATCH][next] wlcore: Use fallthrough pseudo-keyword
 2020-10-08 22:09 UTC 

[PATCH][next] ray_cs: Use fallthrough pseudo-keyword
 2020-10-08 22:04 UTC 

[PATCH RESEND v2] mm: Optional full ASLR for mmap() and mremap()
 2020-10-08 18:24 UTC  (9+ messages)

[PATCH 00/14] drm/amd/pm: Replace one-element arrays with flexible-array members
 2020-10-08 15:53 UTC  (19+ messages)
` [PATCH 01/14] drm/amd/pm: Replace one-element array with flexible-array member
` [PATCH 02/14] drm/amd/pm: Replace one-element array with flexible-array member in struct vi_dpm_table
` [PATCH 03/14] drm/amd/pm: Replace one-element array with flexible-array in struct phm_clock_array
` [PATCH 04/14] drm/amd/pm: Replace one-element array with flexible-array in struct phm_uvd_clock_voltage_dependency_table
` [PATCH 05/14] drm/amd/pm: Replace one-element array with flexible-array in struct phm_acp_clock_voltage_dependency_table
` [PATCH 06/14] drm/amd/pm: Replace one-element array with flexible-array in struct phm_phase_shedding_limits_table
` [PATCH 07/14] drm/amd/pm: Replace one-element array with flexible-array in struct phm_vce_clock_voltage_dependency_table
` [PATCH 08/14] drm/amd/pm: Replace one-element array with flexible-array in struct phm_cac_leakage_table
` [PATCH 09/14] drm/amd/pm: Replace one-element array with flexible-array in struct phm_samu_clock_voltage_dependency_table
` [PATCH 10/14] drm/amd/pm: Replace one-element array with flexible-array in struct phm_ppt_v1_clock_voltage_dependency_table
` [PATCH 11/14] drm/amd/pm: Replace one-element array with flexible-array in struct phm_ppt_v1_mm_clock_voltage_dependency_table
` [PATCH 12/14] drm/amd/pm: Replace one-element array with flexible-array in struct phm_ppt_v1_voltage_lookup_table
` [PATCH 13/14] drm/amd/pm: Replace one-element array with flexible-array in struct phm_ppt_v1_pcie_table
` [PATCH 14/14] drm/amd/pm: Replace one-element array with flexible-array in struct ATOM_Vega10_GFXCLK_Dependency_Table

[PATCH][next] dmaengine: stm32-mdma: Use struct_size() in kzalloc()
 2020-10-08 14:18 UTC 

Linux-specific kernel hardening
 2020-10-07  7:05 UTC  (12+ messages)

[PATCH v2] MAINTAINERS: Change hardening mailing list
 2020-10-06  0:00 UTC 

[PATCH] MAINTAINERS: Change hardening mailing list
 2020-10-05 23:58 UTC  (3+ messages)

[PATCH resend] seccomp: Make duplicate listener detection non-racy
 2020-10-05 22:30 UTC 

[PATCH][next] printk: Use fallthrough pseudo-keyword
 2020-10-05 16:56 UTC  (2+ messages)

[PATCH][next] block: scsi_ioctl: Avoid the use of one-element arrays
 2020-10-05  7:25 UTC  (6+ messages)

[PATCH][next] bnx2x: Use fallthrough pseudo-keyword
 2020-10-04  0:33 UTC  (2+ messages)

[PATCH][next] net: ksz884x: Use fallthrough pseudo-keyword
 2020-10-04  0:33 UTC  (2+ messages)

[PATCH][next] net: bna: Use fallthrough pseudo-keyword
 2020-10-04  0:33 UTC  (2+ messages)

[PATCH][next] usbnet: Use fallthrough pseudo-keyword
 2020-10-04  0:33 UTC  (2+ messages)

[PATCH][next] bpf: verifier: Use fallthrough pseudo-keyword
 2020-10-03  2:41 UTC  (2+ messages)

[PATCH][next] rsxx: Use fallthrough pseudo-keyword
 2020-10-02 23:59 UTC  (2+ messages)

[PATCH][next] pata_cmd64x: Use fallthrough pseudo-keyword
 2020-10-02 23:52 UTC  (2+ messages)

[PATCH v2][next] x86/uv/time: Replace one-element array and save heap space
 2020-10-01 17:42 UTC  (3+ messages)

[PATCH 0/3][next] lib/stackdepot.c: Replace one-element array with flexible-array member
 2020-10-01 15:26 UTC  (4+ messages)
` [PATCH 1/3][next] "
` [PATCH 2/3][next] lib/stackdepot.c: Use flex_array_size() helper in memcpy()
` [PATCH 3/3][next] lib/stackdepot.c: Use array_size() helper in jhash2()

[PATCH][next] mtd: rawnand: Replace one-element array with flexible-array member
 2020-10-01  9:21 UTC  (6+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).