linux-hardening.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-10-08 21:59:06 to 2020-11-18 11:07:54 UTC [more...]

[PATCH v5 0/5] Fortify strscpy()
 2020-11-18 11:07 UTC  (3+ messages)
` [PATCH v5 1/5] string.h: detect intra-object overflow in fortified string functions
` [PATCH v5 2/5] lkdtm: tests for FORTIFY_SOURCE

[RFC PATCH v4 0/5] Fortify strscpy()
 2020-11-18 10:41 UTC  (10+ messages)
` [PATCH v4 1/5] string.h: detect intra-object overflow in fortified string functions
` [PATCH v4 2/5] lkdtm: tests for FORTIFY_SOURCE
` [RFC PATCH v4 3/5] string.h: Add FORTIFY coverage for strscpy()
` [RFC PATCH v4 4/5] Add new file in LKDTM to test fortified strscpy
` [RFC PATCH v4 5/5] Correct wrong filenames in comment

[PATCH v4] mm: Optional full ASLR for mmap() and mremap()
 2020-11-17 20:21 UTC  (3+ messages)

[PATCH][next] mwifiex: Fix fall-through warnings for Clang
 2020-11-17 16:32 UTC  (3+ messages)

[PATCH][next] iwlwifi: dvm: Fix fall-through warnings for Clang
 2020-11-17 15:59 UTC 

[PATCH][next] iwlwifi: mvm: Fix fall-through warnings for Clang
 2020-11-17 13:50 UTC 

[PATCH v5 0/3] Fix inefficiences and rename nla_strlcpy
 2020-11-16 18:18 UTC  (11+ messages)
` [PATCH v5 1/3] Fix unefficient call to memset before memcpu in nla_strlcpy
` [PATCH v5 2/3] Modify return value of nla_strlcpy to match that of strscpy
` [PATCH v5 3/3] treewide: rename nla_strlcpy to nla_strscpy

[RESEND,net-next,PATCH v5 0/3] Fix inefficiences and rename nla_strlcpy
 2020-11-16 18:17 UTC  (6+ messages)
` [RESEND,net-next,PATCH v5 1/3] Fix unefficient call to memset before memcpu in nla_strlcpy
` [RESEND,net-next,PATCH v5 2/3] Modify return value of nla_strlcpy to match that of strscpy
` [RESEND,net-next,PATCH v5 3/3] treewide: rename nla_strlcpy to nla_strscpy

[PATCH v4 0/3] Fix inefficiences and rename nla_strlcpy
 2020-11-13  9:38 UTC  (6+ messages)
` [PATCH v4 1/3] Fix unefficient call to memset before memcpu in nla_strlcpy
` [PATCH v4 2/3] Modify return value of nla_strlcpy to match that of strscpy
` [PATCH v4 3/3] treewide: rename nla_strlcpy to nla_strscpy

[PATCH][next] wlcore: Use fallthrough pseudo-keyword
 2020-11-07 11:31 UTC  (2+ messages)

[PATCH][next] ray_cs: Use fallthrough pseudo-keyword
 2020-11-07 11:30 UTC  (2+ messages)

UBSAN: array-index-out-of-bounds in alg_bind
 2020-11-06  7:01 UTC  (14+ messages)
        ` [PATCH] crypto: af_alg - avoid undefined behavior accessing salg_name

[PATCH] mm, hugetlb: Avoid double clearing for hugetlb pages
 2020-11-05 19:37 UTC  (17+ messages)

[PATCH 0/4] aarch64: avoid mprotect(PROT_BTI|PROT_EXEC) [BZ #26831]
 2020-11-05 11:31 UTC  (28+ messages)
` [PATCH 1/4] elf: Pass the fd to note processing "
` [PATCH 2/4] elf: Move note processing after l_phdr is updated "
` [PATCH 3/4] aarch64: Use mmap to add PROT_BTI instead of mprotect "
` [PATCH 4/4] aarch64: Remove the bti link_map field "

[PATCH][next] dmaengine: stm32-mdma: Use struct_size() in kzalloc()
 2020-10-28  5:56 UTC  (2+ messages)

BTI interaction between seccomp filters in systemd and glibc mprotect calls, causing service failures
 2020-10-26 16:51 UTC  (12+ messages)

[RFC][PATCH v3 0/3] Fix inefficiences and rename nla_strlcpy
 2020-10-24 10:41 UTC  (17+ messages)
` [RFC][PATCH v3 1/3] Fix unefficient call to memset before memcpu in nla_strlcpy
` [RFC][PATCH v3 2/3] Modify return value of nla_strlcpy to match that of strscpy
` [RFC][PATCH v3 3/3] Rename nla_strlcpy to nla_strscpy

[RFC][PATCH v3 0/5] Fortify string function strscpy
 2020-10-24 10:36 UTC  (11+ messages)
` [PATCH v3 1/5] string.h: detect intra-object overflow in fortified string functions
` [PATCH v3 2/5] lkdtm: tests for FORTIFY_SOURCE
` [RFC][PATCH v3 3/5] Fortify string function strscpy
` [RFC][PATCH v3 4/5] Add new file in LKDTM to test fortified strscpy
` [RFC][PATCH v3 5/5] Correct wrong filenames in comment

[RFC][PATCH v1] Fortify string function strscpy
 2020-10-21 14:49 UTC  (8+ messages)
` [RFC][PATCH v2] "

[RFC][PATCH v1] Fix and rename nla_strlcpy to nla_strcpy
 2020-10-20 17:23 UTC  (31+ messages)
` [PATCH v1 1/3] Fix unefficient call to memset before memcpu in nla_strlcpy
` [PATCH v1 2/3] Modify return value of nla_strlcpy to match that of strscpy
` [PATCH v1 3/3] Rename nla_strlcpy to nla_strcpy
` [RFC][PATCH v2 0/3] Fix inefficiences and rename nla_strlcpy
  ` [RFC][PATCH v2 1/3] Fix unefficient call to memset before memcpu in nla_strlcpy
  ` [RFC][PATCH v2 2/3] Modify return value of nla_strlcpy to match that of strscpy
  ` [RFC][PATCH v2 3/3] Rename nla_strlcpy to nla_strcpy

[PATCH v3] mm: Optional full ASLR for mmap() and mremap()
 2020-10-17 19:47 UTC 

Disinfectant
 2020-10-13  7:57 UTC 

Remove all strlcpy() uses in favor of strscpy() (#89)
 2020-10-12 19:03 UTC 

[PATCH][next] net: thunderx: Use struct_size() helper in kmalloc()
 2020-10-10 17:36 UTC  (2+ messages)

[PATCH][next] amd/amdgpu_ctx: Use struct_size() helper and kmalloc()
 2020-10-09 14:39 UTC  (5+ messages)

[PATCH][next] drm/amdgpu: Use struct_size() helper in kmalloc()
 2020-10-09  7:07 UTC  (2+ messages)

[PATCH][next] media: pxa_camera: Use fallthrough pseudo-keyword
 2020-10-08 22:55 UTC 

[PATCH][next] usb: musb: gadget: Use fallthrough pseudo-keyword
 2020-10-08 22:28 UTC 

[PATCH][next] Input: libps2 - Use fallthrough pseudo-keyword
 2020-10-08 22:25 UTC 

[PATCH][next] drm/i915/display: Use fallthrough pseudo-keyword
 2020-10-08 22:18 UTC 


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).