linux-hyperv.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Michael Kelley <mikelley@microsoft.com>
To: vkuznets <vkuznets@redhat.com>
Cc: KY Srinivasan <kys@microsoft.com>,
	Haiyang Zhang <haiyangz@microsoft.com>,
	Stephen Hemminger <sthemmin@microsoft.com>,
	"wei.liu@kernel.org" <wei.liu@kernel.org>,
	"tglx@linutronix.de" <tglx@linutronix.de>,
	"mingo@redhat.com" <mingo@redhat.com>,
	"bp@alien8.de" <bp@alien8.de>, "x86@kernel.org" <x86@kernel.org>,
	"hpa@zytor.com" <hpa@zytor.com>,
	"pbonzini@redhat.com" <pbonzini@redhat.com>,
	"sean.j.christopherson@intel.com"
	<sean.j.christopherson@intel.com>,
	"wanpengli@tencent.com" <wanpengli@tencent.com>,
	"jmattson@google.com" <jmattson@google.com>,
	"joro@8bytes.org" <joro@8bytes.org>,
	"kvm@vger.kernel.org" <kvm@vger.kernel.org>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	"linux-hyperv@vger.kernel.org" <linux-hyperv@vger.kernel.org>
Subject: RE: [PATCH 4/4] asm-generic/hyperv: Add definitions for Get/SetVpRegister hypercalls
Date: Wed, 22 Apr 2020 20:04:08 +0000	[thread overview]
Message-ID: <MW2PR2101MB10522065BF1835CE5D2B233AD7D20@MW2PR2101MB1052.namprd21.prod.outlook.com> (raw)
In-Reply-To: <MW2PR2101MB1052EF4972CDCF9BF2B0356AD7D50@MW2PR2101MB1052.namprd21.prod.outlook.com>

From: Michael Kelley Sent: Tuesday, April 21, 2020 8:50 AM
> 
> From: Vitaly Kuznetsov <vkuznets@redhat.com> Sent: Tuesday, April 21, 2020 6:03 AM
> >
> > Michael Kelley <mikelley@microsoft.com> writes:
> >
> > > Add definitions for GetVpRegister and SetVpRegister hypercalls, which
> > > are implemented for both x86 and ARM64.
> > >
> > > Signed-off-by: Michael Kelley <mikelley@microsoft.com>
> > > ---
> > >  include/asm-generic/hyperv-tlfs.h | 28 ++++++++++++++++++++++++++++
> > >  1 file changed, 28 insertions(+)
> > >
> > > diff --git a/include/asm-generic/hyperv-tlfs.h b/include/asm-generic/hyperv-tlfs.h
> > > index 1f92ef92eb56..29b60f5b6323 100644
> > > --- a/include/asm-generic/hyperv-tlfs.h
> > > +++ b/include/asm-generic/hyperv-tlfs.h
> > > @@ -141,6 +141,8 @@ struct ms_hyperv_tsc_page {
> > >  #define HVCALL_FLUSH_VIRTUAL_ADDRESS_SPACE_EX	0x0013
> > >  #define HVCALL_FLUSH_VIRTUAL_ADDRESS_LIST_EX	0x0014
> > >  #define HVCALL_SEND_IPI_EX			0x0015
> > > +#define HVCALL_GET_VP_REGISTERS			0x0050
> > > +#define HVCALL_SET_VP_REGISTERS			0x0051
> > >  #define HVCALL_POST_MESSAGE			0x005c
> > >  #define HVCALL_SIGNAL_EVENT			0x005d
> > >  #define HVCALL_RETARGET_INTERRUPT		0x007e
> > > @@ -439,4 +441,30 @@ struct hv_retarget_device_interrupt {
> > >  	struct hv_device_interrupt_target int_target;
> > >  } __packed __aligned(8);
> > >
> > > +
> > > +/* HvGetVPRegister hypercall */
> >
> > Nit: 'HvGetVpRegisters' in TLFS
> >
> > > +struct hv_get_vp_register_input {
> >
> > Nit: I would also to name it 'hv_get_vp_registers_input' (plural, like
> > the hypercall).
> >
> > > +	u64 partitionid;
> > > +	u32 vpindex;
> > > +	u8  inputvtl;
> > > +	u8  padding[3];
> > > +	u32 name0;
> > > +	u32 name1;
> > > +} __packed;
> >
> > Isn't it a REP hypercall where we can we can pass a list? In that case
> > this should look like
> >
> > struct hv_get_vp_registers_input {
> > 	struct {
> > 		u64 partitionid;
> > 		u32 vpindex;
> > 		u8  inputvtl;
> > 		u8  padding[3];
> >         } header;
> > 	struct {
> > 		u32 name0;
> > 		u32 name1;
> >         } elem[];
> > } __packed;
> >
> > > +
> > > +struct hv_get_vp_register_output {
> >
> > Ditto.

I've sent out a new version, but didn't change
hv_get_vp_register_output except to make
it hv_get_vp_registers_output.   The C compiler
wont' let me put a  variable size array as the
only field in the struct.

> >
> > > +	union {
> > > +		struct {
> > > +			u32 a;
> > > +			u32 b;
> >  > +			u32 c;
> > > +			u32 d;
> > > +		} as32 __packed;
> > > +		struct {
> > > +			u64 low;
> > > +			u64 high;
> > > +		} as64 __packed;
> > > +	};
> > > +};
> >
> > I'm wondering why you define both
> > HVCALL_GET_VP_REGISTERS/HVCALL_SET_VP_REGISTERS but only add 'struct
> > hv_get_vp_register_input' and not 'struct hv_set_vp_register_input'.
> >
> > The later should look similar, AFAIU it is:
> >
> > struct hv_set_vp_registers_input {
> > 	struct {
> > 		u64 partitionid;
> > 		u32 vpindex;
> > 		u8  inputvtl;
> > 		u8  padding[3];
> >         } header;
> > 	struct {
> > 		u32 name;
> > 		u32 padding1;
> > 		u64 padding2; //not sure this is not a mistake in TLFS

The additional padding is not a mistake.  Hyper-V wants
the register value to be aligned to 128 bits even though
it is described in the TLFS document as two 64 bit fields.

> >             	u64 regvallow;
> >             	u64 regvalhigh;
> > 	} elem[];
> > } __packed;
> >
> > > +
> > >  #endif
> >

Michael

  reply	other threads:[~2020-04-22 20:04 UTC|newest]

Thread overview: 13+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-04-20 17:38 [PATCH 0/4] Split hyperv-tlfs.h into generic and arch specific files Michael Kelley
2020-04-20 17:38 ` [PATCH 1/4] KVM: x86: hyperv: Remove duplicate definitions of Reference TSC Page Michael Kelley
2020-04-21  9:29   ` Wei Liu
2020-04-21 11:16     ` Paolo Bonzini
2020-04-21 11:18       ` Wei Liu
2020-04-21 12:37   ` Vitaly Kuznetsov
2020-04-20 17:38 ` [PATCH 2/4] x86/hyperv: Remove HV_PROCESSOR_POWER_STATE #defines Michael Kelley
2020-04-20 17:38 ` [PATCH 3/4] x86/hyperv: Split hyperv-tlfs.h into arch dependent and independent files Michael Kelley
2020-04-20 17:38 ` [PATCH 4/4] asm-generic/hyperv: Add definitions for Get/SetVpRegister hypercalls Michael Kelley
2020-04-21 13:02   ` Vitaly Kuznetsov
2020-04-21 15:50     ` Michael Kelley
2020-04-22 20:04       ` Michael Kelley [this message]
2020-04-21 11:24 ` [PATCH 0/4] Split hyperv-tlfs.h into generic and arch specific files Wei Liu

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=MW2PR2101MB10522065BF1835CE5D2B233AD7D20@MW2PR2101MB1052.namprd21.prod.outlook.com \
    --to=mikelley@microsoft.com \
    --cc=bp@alien8.de \
    --cc=haiyangz@microsoft.com \
    --cc=hpa@zytor.com \
    --cc=jmattson@google.com \
    --cc=joro@8bytes.org \
    --cc=kvm@vger.kernel.org \
    --cc=kys@microsoft.com \
    --cc=linux-hyperv@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@redhat.com \
    --cc=pbonzini@redhat.com \
    --cc=sean.j.christopherson@intel.com \
    --cc=sthemmin@microsoft.com \
    --cc=tglx@linutronix.de \
    --cc=vkuznets@redhat.com \
    --cc=wanpengli@tencent.com \
    --cc=wei.liu@kernel.org \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).