linux-input.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Hans de Goede <hdegoede@redhat.com>
To: Luis Chamberlain <mcgrof@kernel.org>
Cc: Ard Biesheuvel <ard.biesheuvel@linaro.org>,
	Darren Hart <dvhart@infradead.org>,
	Andy Shevchenko <andy@infradead.org>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	"Rafael J . Wysocki" <rafael@kernel.org>,
	Thomas Gleixner <tglx@linutronix.de>,
	Ingo Molnar <mingo@redhat.com>, Borislav Petkov <bp@alien8.de>,
	"H . Peter Anvin" <hpa@zytor.com>,
	Jonathan Corbet <corbet@lwn.net>,
	Dmitry Torokhov <dmitry.torokhov@gmail.com>,
	Peter Jones <pjones@redhat.com>, Dave Olsthoorn <dave@bewaar.me>,
	x86@kernel.org, platform-driver-x86@vger.kernel.org,
	linux-efi@vger.kernel.org, linux-kernel@vger.kernel.org,
	linux-doc@vger.kernel.org, linux-input@vger.kernel.org
Subject: Re: [PATCH v10 05/10] test_firmware: add support for firmware_request_platform
Date: Fri, 10 Jan 2020 20:48:53 +0100	[thread overview]
Message-ID: <071db8c5-4be1-c6d1-0ccb-a2268cd5b347@redhat.com> (raw)
In-Reply-To: <20200106213343.GV11244@42.do-not-panic.com>

Hi,

On 1/6/20 10:33 PM, Luis Chamberlain wrote:
> On Tue, Dec 10, 2019 at 12:51:12PM +0100, Hans de Goede wrote:
>> Add support for testing firmware_request_platform through a new
>> trigger_request_platform trigger.
>>
>> Signed-off-by: Hans de Goede <hdegoede@redhat.com>
>> ---
>>   lib/test_firmware.c | 68 +++++++++++++++++++++++++++++++++++++++++++++
>>   1 file changed, 68 insertions(+)
>>
>> diff --git a/lib/test_firmware.c b/lib/test_firmware.c
>> index 251213c872b5..9af00cfc8979 100644
>> --- a/lib/test_firmware.c
>> +++ b/lib/test_firmware.c
>> @@ -24,6 +24,7 @@
>>   #include <linux/delay.h>
>>   #include <linux/kthread.h>
>>   #include <linux/vmalloc.h>
>> +#include <linux/efi_embedded_fw.h>
>>   
>>   #define TEST_FIRMWARE_NAME	"test-firmware.bin"
>>   #define TEST_FIRMWARE_NUM_REQS	4
>> @@ -507,12 +508,76 @@ static ssize_t trigger_request_store(struct device *dev,
>>   }
>>   static DEVICE_ATTR_WO(trigger_request);
>>   
>> +#ifdef CONFIG_EFI_EMBEDDED_FIRMWARE
>> +static ssize_t trigger_request_platform_store(struct device *dev,
>> +					      struct device_attribute *attr,
>> +					      const char *buf, size_t count)
>> +{
>> +	static const u8 test_data[] = {
>> +		0x55, 0xaa, 0x55, 0xaa, 0x01, 0x02, 0x03, 0x04,
>> +		0x55, 0xaa, 0x55, 0xaa, 0x05, 0x06, 0x07, 0x08,
>> +		0x55, 0xaa, 0x55, 0xaa, 0x10, 0x20, 0x30, 0x40,
>> +		0x55, 0xaa, 0x55, 0xaa, 0x50, 0x60, 0x70, 0x80
>> +	};
>> +	struct efi_embedded_fw fw;
>> +	int rc;
>> +	char *name;
>> +
>> +	name = kstrndup(buf, count, GFP_KERNEL);
>> +	if (!name)
>> +		return -ENOSPC;
>> +
>> +	pr_info("inserting test platform fw '%s'\n", name);
>> +	fw.name = name;
>> +	fw.data = (void *)test_data;
>> +	fw.length = sizeof(test_data);
>> +	list_add(&fw.list, &efi_embedded_fw_list);
>> +
>> +	pr_info("loading '%s'\n", name);
>> +
>> +	mutex_lock(&test_fw_mutex);
>> +	release_firmware(test_firmware);
>> +	test_firmware = NULL;
> 
> Seems odd to have the above two lines here before the request, why not
> after as noted below.

I modelled this after trigger_request_store which keeps the
test_firmware around after it has been called so that its contents can be
read back from the char misc device which the test_firmware module registers.

Since e.g. trigger_request_store which keeps the test_firmware around
we must check and free it before assigning a new firmware to it using
firmware_request_platform, which is why this is done before and not
after the request.

> 
>> +	rc = firmware_request_platform(&test_firmware, name, dev);
>> +	if (rc) {
>> +		pr_info("load of '%s' failed: %d\n", name, rc);
>> +		goto out;
>> +	}
>> +	if (test_firmware->size != sizeof(test_data) ||
>> +	    memcmp(test_firmware->data, test_data, sizeof(test_data)) != 0) {
>> +		pr_info("firmware contents mismatch for '%s'\n", name);
>> +		rc = -EINVAL;
>> +		goto out;
>> +	}
>> +	pr_info("loaded: %zu\n", test_firmware->size);
>> +	rc = count;
> 
> Here.
> 
>> +
>> +out:
>> +	mutex_unlock(&test_fw_mutex);
>> +
>> +	list_del(&fw.list);
>> +	kfree(name);
>> +
>> +	return rc;
>> +}
>> +static DEVICE_ATTR_WO(trigger_request_platform);
>> +#endif
>> +
>>   static DECLARE_COMPLETION(async_fw_done);
>>   
>>   static void trigger_async_request_cb(const struct firmware *fw, void *context)
>>   {
>>   	test_firmware = fw;
>>   	complete(&async_fw_done);
>> +
>> +
>> +
>> +
>> +
>> +
>> +
>> +
>> +
>>   }
> 
> Ummm, new empty lines without any code added... did you forget
> something?  Please address this.

This is a left over from an earlier version of the patch, my bad, I will remove
this and send out a new version.

Regards,

Hans


  reply	other threads:[~2020-01-10 19:49 UTC|newest]

Thread overview: 16+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-12-10 11:51 [PATCH v10 00/10] efi/firmware/platform-x86: Add EFI embedded fw support Hans de Goede
2019-12-10 11:51 ` [PATCH v10 01/10] efi: Export boot-services code and data as debugfs-blobs Hans de Goede
2019-12-10 11:51 ` [PATCH v10 02/10] efi: Add embedded peripheral firmware support Hans de Goede
2019-12-10 11:51 ` [PATCH v10 03/10] firmware: Rename FW_OPT_NOFALLBACK to FW_OPT_NOFALLBACK_SYSFS Hans de Goede
2019-12-10 11:51 ` [PATCH v10 04/10] firmware: Add new platform fallback mechanism and firmware_request_platform() Hans de Goede
2019-12-10 11:51 ` [PATCH v10 05/10] test_firmware: add support for firmware_request_platform Hans de Goede
2020-01-06 21:33   ` Luis Chamberlain
2020-01-10 19:48     ` Hans de Goede [this message]
2019-12-10 11:51 ` [PATCH v10 06/10] selftests: firmware: Add firmware_request_platform tests Hans de Goede
2019-12-10 11:51 ` [PATCH v10 07/10] Input: silead - Switch to firmware_request_platform for retreiving the fw Hans de Goede
2019-12-10 11:51 ` [PATCH v10 08/10] Input: icn8505 " Hans de Goede
2019-12-10 11:51 ` [PATCH v10 09/10] platform/x86: touchscreen_dmi: Add EFI embedded firmware info support Hans de Goede
2019-12-10 11:51 ` [PATCH v10 10/10] platform/x86: touchscreen_dmi: Add info for the Chuwi Vi8 Plus tablet Hans de Goede
2020-01-03 11:27 ` [PATCH v10 00/10] efi/firmware/platform-x86: Add EFI embedded fw support Hans de Goede
2020-01-03 11:36   ` Ard Biesheuvel
2020-01-06 21:35     ` Luis Chamberlain

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=071db8c5-4be1-c6d1-0ccb-a2268cd5b347@redhat.com \
    --to=hdegoede@redhat.com \
    --cc=andy@infradead.org \
    --cc=ard.biesheuvel@linaro.org \
    --cc=bp@alien8.de \
    --cc=corbet@lwn.net \
    --cc=dave@bewaar.me \
    --cc=dmitry.torokhov@gmail.com \
    --cc=dvhart@infradead.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=hpa@zytor.com \
    --cc=linux-doc@vger.kernel.org \
    --cc=linux-efi@vger.kernel.org \
    --cc=linux-input@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mcgrof@kernel.org \
    --cc=mingo@redhat.com \
    --cc=pjones@redhat.com \
    --cc=platform-driver-x86@vger.kernel.org \
    --cc=rafael@kernel.org \
    --cc=tglx@linutronix.de \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).