linux-mm.kvack.org archive mirror
 help / color / mirror / Atom feed
From: Axel Rasmussen <axelrasmussen@google.com>
To: Peter Xu <peterx@redhat.com>
Cc: linux-kernel@vger.kernel.org, linux-mm@kvack.org,
	 Andrew Morton <akpm@linux-foundation.org>,
	Andrea Arcangeli <aarcange@redhat.com>,
	 Mike Kravetz <mike.kravetz@oracle.com>,
	Nadav Amit <nadav.amit@gmail.com>,
	 David Hildenbrand <david@redhat.com>,
	Mike Rapoport <rppt@linux.vnet.ibm.com>,
	 Leonardo Bras Soares Passos <lsoaresp@redhat.com>
Subject: Re: [PATCH v2 16/31] selftests/mm: UFFDIO_API test
Date: Wed, 12 Apr 2023 12:47:39 -0700	[thread overview]
Message-ID: <CAJHvVcgtAhEkqkYegHONCJz5uJoxRLRdm9Kp8DmkcnZhU=w=9g@mail.gmail.com> (raw)
In-Reply-To: <20230412164257.328375-1-peterx@redhat.com>

On Wed, Apr 12, 2023 at 9:43 AM Peter Xu <peterx@redhat.com> wrote:
>
> Add one simple test for UFFDIO_API.  With that, I also added a bunch of
> small but handy helpers along the way.
>
> Signed-off-by: Peter Xu <peterx@redhat.com>
> ---
>  tools/testing/selftests/mm/uffd-unit-tests.c | 109 ++++++++++++++++++-
>  1 file changed, 108 insertions(+), 1 deletion(-)
>
> diff --git a/tools/testing/selftests/mm/uffd-unit-tests.c b/tools/testing/selftests/mm/uffd-unit-tests.c
> index 6857388783be..bb492c258486 100644
> --- a/tools/testing/selftests/mm/uffd-unit-tests.c
> +++ b/tools/testing/selftests/mm/uffd-unit-tests.c
> @@ -9,9 +9,116 @@
>
>  #ifdef __NR_userfaultfd
>
> +static void uffd_test_report(void)
> +{
> +       printf("Userfaults unit tests: pass=%u, skip=%u, fail=%u (total=%u)\n",
> +              ksft_get_pass_cnt(),
> +              ksft_get_xskip_cnt(),
> +              ksft_get_fail_cnt(),
> +              ksft_test_num());
> +}
> +
> +static void uffd_test_pass(void)
> +{
> +       printf("done\n");
> +       ksft_inc_pass_cnt();
> +}
> +
> +#define  uffd_test_start(...)  do {            \
> +               printf("Testing ");             \
> +               printf(__VA_ARGS__);            \
> +               printf("... ");                 \
> +               fflush(stdout);                 \
> +       } while (0)
> +
> +#define  uffd_test_fail(...)  do {             \
> +               printf("failed [reason: ");     \
> +               printf(__VA_ARGS__);            \
> +               printf("]\n");                  \
> +               ksft_inc_fail_cnt();            \
> +       } while (0)
> +
> +#define  uffd_test_skip(...)  do {             \
> +               printf("skipped [reason: ");    \
> +               printf(__VA_ARGS__);            \
> +               printf("]\n");                  \
> +               ksft_inc_xskip_cnt();           \
> +       } while (0)

Some of this is duplicating what's in kselftest_harness.h - e.g.
assertions, printing test summary, keeping track of pass/fail/skip
counts, etc.

I wonder how you feel about using the standard harness? E.g. is the
plan to do this (more straightforward?) refactor first, and then
switch later? Or is there some reason it can't be used?

> +
> +/*
> + * Returns 1 if specific userfaultfd supported, 0 otherwise.  Note, we'll
> + * return 1 even if some test failed as long as uffd supported, because in
> + * that case we still want to proceed with the rest uffd unit tests.
> + */
> +static int test_uffd_api(bool use_dev)
> +{
> +       struct uffdio_api uffdio_api;
> +       int uffd;
> +
> +       uffd_test_start("UFFDIO_API (with %s)",
> +                       use_dev ? "/dev/userfaultfd" : "syscall");
> +
> +       if (use_dev)
> +               uffd = uffd_open_dev(UFFD_FLAGS);
> +       else
> +               uffd = uffd_open_sys(UFFD_FLAGS);
> +       if (uffd < 0) {
> +               uffd_test_skip("cannot open userfaultfd handle");
> +               return 0;
> +       }
> +
> +       /* Test wrong UFFD_API */
> +       uffdio_api.api = 0xab;
> +       uffdio_api.features = 0;
> +       if (ioctl(uffd, UFFDIO_API, &uffdio_api) == 0) {
> +               uffd_test_fail("UFFDIO_API should fail with wrong api but didn't");
> +               goto out;
> +       }
> +
> +       /* Test wrong feature bit */
> +       uffdio_api.api = UFFD_API;
> +       uffdio_api.features = BIT_ULL(63);
> +       if (ioctl(uffd, UFFDIO_API, &uffdio_api) == 0) {
> +               uffd_test_fail("UFFDIO_API should fail with wrong feature but didn't");
> +               goto out;
> +       }
> +
> +       /* Test normal UFFDIO_API */
> +       uffdio_api.api = UFFD_API;
> +       uffdio_api.features = 0;
> +       if (ioctl(uffd, UFFDIO_API, &uffdio_api)) {
> +               uffd_test_fail("UFFDIO_API should succeed but failed");
> +               goto out;
> +       }
> +
> +       /* Test double requests of UFFDIO_API with a random feature set */
> +       uffdio_api.features = BIT_ULL(0);
> +       if (ioctl(uffd, UFFDIO_API, &uffdio_api) == 0) {
> +               uffd_test_fail("UFFDIO_API should reject initialized uffd");
> +               goto out;
> +       }
> +
> +       uffd_test_pass();
> +out:
> +       close(uffd);
> +       /* We have a valid uffd handle */
> +       return 1;
> +}
> +
>  int main(int argc, char *argv[])
>  {
> -       return KSFT_PASS;
> +       int has_uffd;
> +
> +       has_uffd = test_uffd_api(false);
> +       has_uffd |= test_uffd_api(true);
> +
> +       if (!has_uffd) {
> +               printf("Userfaultfd not supported or unprivileged, skip all tests\n");
> +               exit(KSFT_SKIP);
> +       }
> +       uffd_test_report();
> +
> +       return ksft_get_fail_cnt() ? KSFT_FAIL : KSFT_PASS;
>  }
>
>  #else /* __NR_userfaultfd */
> --
> 2.39.1
>


  reply	other threads:[~2023-04-12 19:48 UTC|newest]

Thread overview: 43+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-04-12 16:38 [PATCH v2 00/31] selftests/mm: Split / Refactor userfault test Peter Xu
2023-04-12 16:38 ` [PATCH v2 01/31] Revert "userfaultfd: don't fail on unrecognized features" Peter Xu
2023-04-12 16:41 ` [PATCH v2 02/31] selftests/mm: Update .gitignore with two missing tests Peter Xu
2023-04-12 16:41 ` [PATCH v2 03/31] selftests/mm: Dump a summary in run_vmtests.sh Peter Xu
2023-04-12 16:41 ` [PATCH v2 04/31] selftests/mm: Merge util.h into vm_util.h Peter Xu
2023-04-12 16:42 ` [PATCH v2 05/31] selftests/mm: Use TEST_GEN_PROGS where proper Peter Xu
2023-04-15 15:44   ` Lorenzo Stoakes
2023-04-12 16:42 ` [PATCH v2 06/31] selftests/mm: Link vm_util.c always Peter Xu
2023-04-12 16:42 ` [PATCH v2 07/31] selftests/mm: Merge default_huge_page_size() into one Peter Xu
2023-04-12 16:42 ` [PATCH v2 08/31] selftests/mm: Use PM_* macros in vm_utils.h Peter Xu
2023-04-12 16:42 ` [PATCH v2 09/31] selftests/mm: Reuse pagemap_get_entry() in vm_util.h Peter Xu
2023-04-12 16:42 ` [PATCH v2 10/31] selftests/mm: Test UFFDIO_ZEROPAGE only when !hugetlb Peter Xu
2023-04-12 17:07   ` Axel Rasmussen
2023-04-12 16:42 ` [PATCH v2 11/31] selftests/mm: Drop test_uffdio_zeropage_eexist Peter Xu
2023-04-12 16:42 ` [PATCH v2 12/31] selftests/mm: Create uffd-common.[ch] Peter Xu
2023-04-12 17:59   ` Axel Rasmussen
2023-04-12 16:42 ` [PATCH v2 13/31] selftests/mm: Split uffd tests into uffd-stress and uffd-unit-tests Peter Xu
2023-04-12 18:03   ` Axel Rasmussen
2023-04-12 16:42 ` [PATCH v2 14/31] selftests/mm: uffd_[un]register() Peter Xu
2023-04-12 18:20   ` Axel Rasmussen
2023-04-12 19:33     ` Peter Xu
2023-04-12 16:42 ` [PATCH v2 15/31] selftests/mm: uffd_open_{dev|sys}() Peter Xu
2023-04-12 18:25   ` Axel Rasmussen
2023-04-12 16:42 ` [PATCH v2 16/31] selftests/mm: UFFDIO_API test Peter Xu
2023-04-12 19:47   ` Axel Rasmussen [this message]
2023-04-12 20:08     ` Peter Xu
2023-04-20 10:54   ` Mike Rapoport
2023-04-12 16:43 ` [PATCH v2 17/31] selftests/mm: Drop global mem_fd in uffd tests Peter Xu
2023-04-12 16:43 ` [PATCH v2 18/31] selftests/mm: Drop global hpage_size " Peter Xu
2023-04-12 16:43 ` [PATCH v2 19/31] selftests/mm: Rename uffd_stats to uffd_args Peter Xu
2023-04-20 10:55   ` Mike Rapoport
2023-04-12 16:43 ` [PATCH v2 20/31] selftests/mm: Let uffd_handle_page_fault() take wp parameter Peter Xu
2023-04-12 16:43 ` [PATCH v2 21/31] selftests/mm: Allow allocate_area() to fail properly Peter Xu
2023-04-12 16:43 ` [PATCH v2 22/31] selftests/mm: Add framework for uffd-unit-test Peter Xu
2023-04-12 16:43 ` [PATCH v2 23/31] selftests/mm: Move uffd pagemap test to unit test Peter Xu
2023-04-12 16:43 ` [PATCH v2 24/31] selftests/mm: Move uffd minor " Peter Xu
2023-04-12 16:44 ` [PATCH v2 25/31] selftests/mm: Move uffd sig/events tests into uffd unit tests Peter Xu
2023-04-12 16:44 ` [PATCH v2 26/31] selftests/mm: Move zeropage test " Peter Xu
2023-04-12 16:45 ` [PATCH v2 27/31] selftests/mm: Workaround no way to detect uffd-minor + wp Peter Xu
2023-04-12 16:45 ` [PATCH v2 28/31] selftests/mm: Allow uffd test to skip properly with no privilege Peter Xu
2023-04-12 16:45 ` [PATCH v2 29/31] selftests/mm: Drop sys/dev test in uffd-stress test Peter Xu
2023-04-12 16:45 ` [PATCH v2 30/31] selftests/mm: Add shmem-private test to uffd-stress Peter Xu
2023-04-12 16:45 ` [PATCH v2 31/31] selftests/mm: Add uffdio register ioctls test Peter Xu

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='CAJHvVcgtAhEkqkYegHONCJz5uJoxRLRdm9Kp8DmkcnZhU=w=9g@mail.gmail.com' \
    --to=axelrasmussen@google.com \
    --cc=aarcange@redhat.com \
    --cc=akpm@linux-foundation.org \
    --cc=david@redhat.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=lsoaresp@redhat.com \
    --cc=mike.kravetz@oracle.com \
    --cc=nadav.amit@gmail.com \
    --cc=peterx@redhat.com \
    --cc=rppt@linux.vnet.ibm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).