linux-mm.kvack.org archive mirror
 help / color / mirror / Atom feed
From: Yu Zhao <yuzhao@google.com>
To: Ryan Roberts <ryan.roberts@arm.com>
Cc: Matthew Wilcox <willy@infradead.org>,
	"Huang, Ying" <ying.huang@intel.com>,
	 Andrew Morton <akpm@linux-foundation.org>,
	Yin Fengwei <fengwei.yin@intel.com>,
	 David Hildenbrand <david@redhat.com>,
	Yang Shi <shy828301@gmail.com>, Zi Yan <ziy@nvidia.com>,
	 linux-kernel@vger.kernel.org, linux-mm@kvack.org
Subject: Re: [PATCH v3 2/3] mm: Implement folio_remove_rmap_range()
Date: Thu, 27 Jul 2023 10:38:42 -0600	[thread overview]
Message-ID: <CAOUHufa38H0o0ZoX-KYMSeAiJghMWtjfHM2F4OjUZ-a--_Kt_w@mail.gmail.com> (raw)
In-Reply-To: <faf8d723-afb8-ac4e-7861-4004bb78c5a9@arm.com>

On Thu, Jul 27, 2023 at 1:26 AM Ryan Roberts <ryan.roberts@arm.com> wrote:
>
> On 27/07/2023 03:35, Matthew Wilcox wrote:
> > On Thu, Jul 27, 2023 at 09:29:24AM +0800, Huang, Ying wrote:
> >> Matthew Wilcox <willy@infradead.org> writes:
> >>> I think that can make sense.  Because we limit to a single page table,
> >>> specifying 'nr = 1 << PMD_ORDER' is the same as 'compound = true'.
> >>> Just make it folio, page, nr, vma.  I'd actually prefer it as (vma,
> >>> folio, page, nr), but that isn't the convention we've had in rmap up
> >>> until now.
> >>
> >> IIUC, even if 'nr = 1 << PMD_ORDER', we may remove one PMD 'compound'
> >> mapping, or 'nr' PTE mapping.  So, we will still need 'compound' (or
> >> some better name) as parameter.
> >
> > Oh, this is removing ... so you're concerned with the case where we've
> > split the PMD into PTEs, but all the PTEs are still present in a single
> > page table?  OK, I don't have a good answer to that.  Maybe that torpedoes
> > the whole idea; I'll think about it.
>
> This is exactly why I think the approach I've already taken is the correct one;
> a 'range' makes no sense when you are dealing with 'compound' pages because you
> are accounting the entire folio. So surely its better to reflect that by only
> accounting small pages in the range version of the API.

If the argument is the compound case is a separate one, then why not a
separate API for it?

I don't really care about whether we think 'range' makes sense for
'compound' or not. What I'm saying is:
1. if they are considered one general case, then one API with the
compound parameter.
2. if they are considered two specific cases, there should be two APIs.
This common design pattern is cleaner IMO.

Right now we have an overlap (redundancy) -- people would have to do
two code searches: one for page_remove_rmap() and the other for
folio_remove_rmap_range(nr=1), and this IMO is a bad design pattern.


  reply	other threads:[~2023-07-27 16:39 UTC|newest]

Thread overview: 21+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-07-20 11:29 [PATCH v3 0/3] Optimize large folio interaction with deferred split Ryan Roberts
2023-07-20 11:29 ` [PATCH v3 1/3] mm: Allow deferred splitting of arbitrary large anon folios Ryan Roberts
2023-07-20 11:29 ` [PATCH v3 2/3] mm: Implement folio_remove_rmap_range() Ryan Roberts
2023-07-26  5:53   ` Yu Zhao
2023-07-26  6:42     ` Ryan Roberts
2023-07-26 16:44     ` Matthew Wilcox
2023-07-27  1:29       ` Huang, Ying
2023-07-27  2:35         ` Matthew Wilcox
2023-07-27  7:26           ` Ryan Roberts
2023-07-27 16:38             ` Yu Zhao [this message]
2023-07-28  9:00               ` Ryan Roberts
2023-08-01  7:40                 ` Yu Zhao
2023-07-20 11:29 ` [PATCH v3 3/3] mm: Batch-zap large anonymous folio PTE mappings Ryan Roberts
2023-07-26 16:19   ` Nathan Chancellor
2023-07-26 16:32     ` Ryan Roberts
2023-07-26 16:35       ` Nathan Chancellor
2023-07-26 19:38     ` Ryan Roberts
2023-07-26 19:50       ` Nathan Chancellor
2023-07-26 21:17         ` Ryan Roberts
2023-07-26 21:23           ` Nathan Chancellor
2023-07-26 21:28             ` Ryan Roberts

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=CAOUHufa38H0o0ZoX-KYMSeAiJghMWtjfHM2F4OjUZ-a--_Kt_w@mail.gmail.com \
    --to=yuzhao@google.com \
    --cc=akpm@linux-foundation.org \
    --cc=david@redhat.com \
    --cc=fengwei.yin@intel.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=ryan.roberts@arm.com \
    --cc=shy828301@gmail.com \
    --cc=willy@infradead.org \
    --cc=ying.huang@intel.com \
    --cc=ziy@nvidia.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).