linux-riscv.lists.infradead.org archive mirror
 help / color / mirror / Atom feed
From: Conor Dooley <conor.dooley@microchip.com>
To: Damien Le Moal <damien.lemoal@opensource.wdc.com>
Cc: Conor Dooley <conor@kernel.org>,
	<linux-riscv@lists.infradead.org>, <palmer@dabbelt.com>,
	<geert@linux-mk68.org>, <heiko@sntech.de>, <kernel@esmil.dk>,
	<arnd@arndb.de>
Subject: Re: [RFC 00/27] RISC-V: Convert SOC_FOO symbols to ARCH_FOO
Date: Mon, 26 Sep 2022 09:02:57 +0100	[thread overview]
Message-ID: <YzFcsV2XV1Ovy5Dq@wendy> (raw)
In-Reply-To: <915949be-ab11-8364-4ac2-07d964d66560@opensource.wdc.com>

On Mon, Sep 26, 2022 at 10:50:42AM +0900, Damien Le Moal wrote:
> On 9/24/22 03:55, Conor Dooley wrote:
> > From: Conor Dooley <conor.dooley@microchip.com>
> > 
> > Following on from LPC, here's the start of my efforts to clean up
> > Kconfig.socs.
> > 
> > My preference would be to take the whole thing through the RISC-V tree
> > for v6.2 to make things a bit less fiddly, but I am sending this as an
> > RFC in the hopes of getting some opinions on how the series should be
> > split up & merged. I guess it would always be possible to create a few
> > immutable branches for the individual subsystems that are being modified
> > & take the series through the riscv tree unless we hit a conflict in
> > -next. Obiviously for that route, maintainer acks will be needed.
> > 
> > The only SoCs I have, at the moment ;), are the jh7100, mpfs, fu540 and
> > the k210 so I've given those a whirl to make sure I didn't break
> > something.
> > 
> > I have also yet to deal with ARCH_VIRT, but just throwing this out for
> > some opinions on how to apply/split up the set before finalising a v1.
> > 
> > I've CCed a few people that may have an opinion here, but anyone that
> > has an opinion here - please shout!
> > 
> > One other point, is it worth adding something to the patch acceptance
> > policy to say "do your kconfig xyz way" or is that not something that's
> > worth doing since it is easy to push people in the right direction
> > during review?
> > 
> > The series is currently on top of:
> > https://lore.kernel.org/all/20220908142914.359777-1-cristian.ciocaltea@collabora.com/
> 
> It is not very nice to change the config option names as that can break
> user build environments, e.g. buildroot setups that have tweaked kernel
> configs.

Yeah & I am not sure what could be done there other than define both
symbols in the defconfig externally. I am loathe to break someone's
setup, but defconfig is not in the "thou shalt not break" category is
it?

> What's wrong with the SOC_XXX names? Changing these to ARCH_XXX is
> weird since the ARCH prefix is generally used for ISA differentiation
> rather than boards/SoCs.

The ARM{,64} vendors coming to RISC-V already have an ARCH_FOO symbol
defined. For the sake of consistency (and to avoid having two symbols
for one SoC since they already have ARCH_FOO scattered around the
kernel) I renamed the "incumbent" symbols to match. FWIW ARCH_FOO for
uarchs is more common than SOC_FOO..

My heart is not dead-set on the rename, only my OCD!

Thanks,
Conor.

> > 
> > Conor Dooley (27):
> >   clk: microchip: replace SOC_MICROCHIP_POLARFIRE with ARCH_MICROCHIP
> >   i2c: microchip-corei2c: replace SOC_MICROCHIP_POLARFIRE with
> >     ARCH_MICROCHIP
> >   mailbox: mpfs: replace SOC_MICROCHIP_POLARFIRE with ARCH_MICROCHIP
> >   usb: musb: mpfs: replace SOC_MICROCHIP_POLARFIRE with ARCH_MICROCHIP
> >   rtc: mpfs: replace SOC_MICROCHIP_POLARFIRE with ARCH_MICROCHIP
> >   riscv: stop selecting the PolarFire SoC clock driver
> >   riscv: replace SOC_STARFIVE with ARCH_STARFIVE
> >   clk: starfive: replace SOC_STARFIVE with ARCH_STARFIVE
> >   pinctrl: starfive: replace SOC_STARFIVE with ARCH_STARFIVE
> >   reset: starfive: replace SOC_STARFIVE with ARCH_STARFIVE
> >   riscv: replace SOC_SIFIVE with ARCH_SIFIVE
> >   soc: sifive: convert SOC_SIFIVE to ARCH_SIFIVE
> >   clk: sifive: convert SOC_SIFIVE to ARCH_SIFIVE
> >   clk: sifive: select by default if ARCH_SIFIVE
> >   serial: sifive: select by default if ARCH_SIFIVE
> >   PCI: dwc: fu740: convert SOC_SIFIVE to ARCH_SIFIVE
> >   riscv: stop selecting SiFive clock and serial drivers directly
> >   riscv: convert SOC_VIRT to ARCH_VIRT
> >   kunit: tool: rename SOC_VIRT to ARCH_VIRT in riscv's QEMU config
> >   wireguard: selftests: swap SOC_VIRT for ARCH_VIRT on riscv
> >   riscv: convert SOC_CANAAN to ARCH_CANAAN
> >   clk: k210: convert SOC_CANAAN to ARCH_CANAAN
> >   pinctrl: k210: convert SOC_CANAAN to ARCH_CANAAN
> >   soc: k210: convert SOC_CANAAN to ARCH_CANAAN
> >   reset: k210: convert SOC_CANAAN to ARCH_CANAAN
> >   serial: sifive: select by default if ARCH_CANAAN
> >   riscv: stop directly selecting drivers for ARCH_CANAAN
> > 
> >  arch/riscv/Kconfig.socs                       | 30 +++++++------------
> >  arch/riscv/Makefile                           |  2 +-
> >  arch/riscv/boot/dts/Makefile                  |  2 +-
> >  arch/riscv/boot/dts/canaan/Makefile           | 14 ++++-----
> >  arch/riscv/boot/dts/sifive/Makefile           |  2 +-
> >  arch/riscv/boot/dts/starfive/Makefile         |  2 +-
> >  arch/riscv/configs/defconfig                  |  6 ++--
> >  arch/riscv/configs/nommu_k210_defconfig       |  2 +-
> >  .../riscv/configs/nommu_k210_sdcard_defconfig |  2 +-
> >  arch/riscv/configs/nommu_virt_defconfig       |  2 +-
> >  arch/riscv/configs/rv32_defconfig             |  4 +--
> >  drivers/clk/Kconfig                           |  4 +--
> >  drivers/clk/Makefile                          |  2 +-
> >  drivers/clk/microchip/Kconfig                 |  3 +-
> >  drivers/clk/sifive/Kconfig                    |  4 ++-
> >  drivers/clk/starfive/Kconfig                  |  6 ++--
> >  drivers/i2c/busses/Kconfig                    |  2 +-
> >  drivers/mailbox/Kconfig                       |  2 +-
> >  drivers/pci/controller/dwc/Kconfig            |  2 +-
> >  drivers/pinctrl/Kconfig                       |  8 ++---
> >  drivers/reset/Kconfig                         |  8 ++---
> >  drivers/rtc/Kconfig                           |  2 +-
> >  drivers/soc/Makefile                          |  4 +--
> >  drivers/soc/canaan/Kconfig                    |  4 +--
> >  drivers/soc/sifive/Kconfig                    |  2 +-
> >  drivers/tty/serial/Kconfig                    |  2 ++
> >  drivers/usb/musb/Kconfig                      |  2 +-
> >  tools/testing/kunit/qemu_configs/riscv.py     |  2 +-
> >  .../wireguard/qemu/arch/riscv32.config        |  2 +-
> >  .../wireguard/qemu/arch/riscv64.config        |  2 +-
> >  30 files changed, 64 insertions(+), 67 deletions(-)
> > 
> 
> -- 
> Damien Le Moal
> Western Digital Research
> 
> 
> _______________________________________________
> linux-riscv mailing list
> linux-riscv@lists.infradead.org
> http://lists.infradead.org/mailman/listinfo/linux-riscv

_______________________________________________
linux-riscv mailing list
linux-riscv@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-riscv

  reply	other threads:[~2022-09-26  8:03 UTC|newest]

Thread overview: 43+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-09-23 18:55 [RFC 00/27] RISC-V: Convert SOC_FOO symbols to ARCH_FOO Conor Dooley
2022-09-23 18:55 ` [RFC 01/27] clk: microchip: replace SOC_MICROCHIP_POLARFIRE with ARCH_MICROCHIP Conor Dooley
2022-09-28 12:16   ` Christoph Hellwig
2022-09-28 12:51     ` Conor Dooley
2022-09-23 18:55 ` [RFC 02/27] i2c: microchip-corei2c: " Conor Dooley
2022-09-23 18:55 ` [RFC 03/27] mailbox: mpfs: " Conor Dooley
2022-09-23 18:55 ` [RFC 04/27] usb: musb: " Conor Dooley
2022-09-23 18:55 ` [RFC 05/27] rtc: " Conor Dooley
2022-09-23 18:55 ` [RFC 06/27] riscv: stop selecting the PolarFire SoC clock driver Conor Dooley
2022-09-23 18:55 ` [RFC 07/27] riscv: replace SOC_STARFIVE with ARCH_STARFIVE Conor Dooley
2022-09-23 19:09   ` Heiko Stuebner
2022-09-23 19:14     ` Conor Dooley
2022-09-23 19:20       ` Heiko Stuebner
2022-09-23 19:22         ` Conor Dooley
2022-09-23 18:55 ` [RFC 08/27] clk: starfive: " Conor Dooley
2022-09-23 18:55 ` [RFC 09/27] pinctrl: " Conor Dooley
2022-09-23 18:55 ` [RFC 10/27] reset: " Conor Dooley
2022-09-23 18:55 ` [RFC 11/27] riscv: replace SOC_SIFIVE with ARCH_SIFIVE Conor Dooley
2022-09-23 18:55 ` [RFC 12/27] soc: sifive: convert SOC_SIFIVE to ARCH_SIFIVE Conor Dooley
2022-09-23 18:55 ` [RFC 13/27] clk: " Conor Dooley
2022-09-23 18:55 ` [RFC 14/27] clk: sifive: select by default if ARCH_SIFIVE Conor Dooley
2022-09-23 18:55 ` [RFC 15/27] serial: " Conor Dooley
2022-09-23 18:55 ` [RFC 16/27] PCI: dwc: fu740: convert SOC_SIFIVE to ARCH_SIFIVE Conor Dooley
2022-09-23 18:55 ` [RFC 17/27] riscv: stop selecting SiFive clock and serial drivers directly Conor Dooley
2022-09-23 18:55 ` [RFC 18/27] riscv: convert SOC_VIRT to ARCH_VIRT Conor Dooley
2022-09-23 18:55 ` [RFC 19/27] kunit: tool: rename SOC_VIRT to ARCH_VIRT in riscv's QEMU config Conor Dooley
2022-09-23 18:55 ` [RFC 20/27] wireguard: selftests: swap SOC_VIRT for ARCH_VIRT on riscv Conor Dooley
2022-09-24 10:03   ` Jason A. Donenfeld
2022-09-23 18:56 ` [RFC 21/27] riscv: convert SOC_CANAAN to ARCH_CANAAN Conor Dooley
2022-09-23 18:56 ` [RFC 22/27] clk: k210: " Conor Dooley
2022-09-23 18:56 ` [RFC 23/27] pinctrl: " Conor Dooley
2022-09-23 18:56 ` [RFC 24/27] soc: " Conor Dooley
2022-09-23 18:56 ` [RFC 25/27] reset: " Conor Dooley
2022-09-23 18:56 ` [RFC 26/27] serial: sifive: select by default if ARCH_CANAAN Conor Dooley
2022-09-23 18:56 ` [RFC 27/27] riscv: stop directly selecting drivers for ARCH_CANAAN Conor Dooley
2022-09-23 18:59 ` [RFC 00/27] RISC-V: Convert SOC_FOO symbols to ARCH_FOO Conor Dooley
2022-09-26  1:50 ` Damien Le Moal
2022-09-26  8:02   ` Conor Dooley [this message]
2022-09-26  9:04 ` Geert Uytterhoeven
2022-09-27  6:34   ` Conor Dooley
2022-09-27  6:48     ` Arnd Bergmann
2022-09-27  6:57       ` Conor Dooley
2022-09-27  7:03         ` Geert Uytterhoeven

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=YzFcsV2XV1Ovy5Dq@wendy \
    --to=conor.dooley@microchip.com \
    --cc=arnd@arndb.de \
    --cc=conor@kernel.org \
    --cc=damien.lemoal@opensource.wdc.com \
    --cc=geert@linux-mk68.org \
    --cc=heiko@sntech.de \
    --cc=kernel@esmil.dk \
    --cc=linux-riscv@lists.infradead.org \
    --cc=palmer@dabbelt.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).