linux-scsi.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: "Martin K. Petersen" <martin.petersen@oracle.com>
To: "James E . J . Bottomley" <jejb@linux.vnet.ibm.com>,
	Bart Van Assche <bvanassche@acm.org>
Cc: "Martin K . Petersen" <martin.petersen@oracle.com>,
	Arun Easi <aeasi@marvell.com>,
	linux-scsi@vger.kernel.org, Hannes Reinecke <hare@suse.de>
Subject: Re: [PATCH v7 00/15] Fix qla2xxx endianness annotations
Date: Tue, 19 May 2020 22:30:03 -0400	[thread overview]
Message-ID: <158994171818.20861.11581994731205196049.b4-ty@oracle.com> (raw)
In-Reply-To: <20200518211712.11395-1-bvanassche@acm.org>

On Mon, 18 May 2020 14:16:57 -0700, Bart Van Assche wrote:

> This patch series fixes the endianness annotations in the qla2xxx driver.
> Please consider this patch series for the v5.8 kernel.
> 
> Thanks,
> 
> Bart.
> 
> [...]

Applied to 5.8/scsi-queue, thanks!

[01/15] scsi: qla2xxx: Fix spelling of a variable name
        https://git.kernel.org/mkp/scsi/c/246ee22583ed
[02/15] scsi: qla2xxx: Suppress two recently introduced compiler warnings
        https://git.kernel.org/mkp/scsi/c/fbbc95a49d5b
[03/15] scsi: qla2xxx: Simplify the functions for dumping firmware
        https://git.kernel.org/mkp/scsi/c/8ae178760b23
[04/15] scsi: qla2xxx: Sort BUILD_BUG_ON() statements alphabetically
        https://git.kernel.org/mkp/scsi/c/59d23cf3f2e4
[05/15] scsi: qla2xxx: Add more BUILD_BUG_ON() statements
        https://git.kernel.org/mkp/scsi/c/8a73a0e002b3
[06/15] scsi: qla2xxx: Make a gap in struct qla2xxx_offld_chain explicit
        https://git.kernel.org/mkp/scsi/c/66f863677715
[07/15] scsi: qla2xxx: Increase the size of struct qla_fcp_prio_cfg to FCP_PRIO_CFG_SIZE
        https://git.kernel.org/mkp/scsi/c/d9ab5f1f05fc
[08/15] scsi: qla2xxx: Change two hardcoded constants into offsetof() / sizeof() expressions
        https://git.kernel.org/mkp/scsi/c/e544b720ef31
[09/15] scsi: qla2xxx: Use register names instead of register offsets
        https://git.kernel.org/mkp/scsi/c/c38884162218
[10/15] scsi: qla2xxx: Fix the code that reads from mailbox registers
        https://git.kernel.org/mkp/scsi/c/37139da1b097
[11/15] scsi: qla2xxx: Change {RD,WRT}_REG_*() function names from upper case into lower case
        https://git.kernel.org/mkp/scsi/c/04474d3a1c96
[12/15] scsi: qla2xxx: Cast explicitly to uint16_t / uint32_t
        https://git.kernel.org/mkp/scsi/c/ab053c09ee20
[13/15] scsi: qla2xxx: Use make_handle() instead of open-coding it
        https://git.kernel.org/mkp/scsi/c/2a4b684ab0aa
[14/15] scsi: qla2xxx: Fix endianness annotations in header files
        https://git.kernel.org/mkp/scsi/c/21038b0900d1
[15/15] scsi: qla2xxx: Fix endianness annotations in source files
        https://git.kernel.org/mkp/scsi/c/7ffa5b939751

-- 
Martin K. Petersen	Oracle Linux Engineering

      parent reply	other threads:[~2020-05-20  2:32 UTC|newest]

Thread overview: 24+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-05-18 21:16 [PATCH v7 00/15] Fix qla2xxx endianness annotations Bart Van Assche
2020-05-18 21:16 ` [PATCH v7 01/15] qla2xxx: Fix spelling of a variable name Bart Van Assche
2020-05-18 21:16 ` [PATCH v7 02/15] qla2xxx: Suppress two recently introduced compiler warnings Bart Van Assche
2020-05-18 21:17 ` [PATCH v7 03/15] qla2xxx: Simplify the functions for dumping firmware Bart Van Assche
2020-05-18 21:17 ` [PATCH v7 04/15] qla2xxx: Sort BUILD_BUG_ON() statements alphabetically Bart Van Assche
2020-05-18 21:17 ` [PATCH v7 05/15] qla2xxx: Add more BUILD_BUG_ON() statements Bart Van Assche
2020-05-18 21:17 ` [PATCH v7 06/15] qla2xxx: Make a gap in struct qla2xxx_offld_chain explicit Bart Van Assche
2020-05-18 21:17 ` [PATCH v7 07/15] qla2xxx: Increase the size of struct qla_fcp_prio_cfg to FCP_PRIO_CFG_SIZE Bart Van Assche
2020-05-18 21:17 ` [PATCH v7 08/15] qla2xxx: Change two hardcoded constants into offsetof() / sizeof() expressions Bart Van Assche
2020-05-18 21:17 ` [PATCH v7 09/15] qla2xxx: Use register names instead of register offsets Bart Van Assche
2020-05-18 21:17 ` [PATCH v7 10/15] qla2xxx: Fix the code that reads from mailbox registers Bart Van Assche
2020-05-18 21:17 ` [PATCH v7 11/15] qla2xxx: Change {RD,WRT}_REG_*() function names from upper case into lower case Bart Van Assche
2020-05-18 21:17 ` [PATCH v7 12/15] qla2xxx: Cast explicitly to uint16_t / uint32_t Bart Van Assche
2020-05-19 15:29   ` Daniel Wagner
2020-05-18 21:17 ` [PATCH v7 13/15] qla2xxx: Use make_handle() instead of open-coding it Bart Van Assche
2020-05-18 21:17 ` [PATCH v7 14/15] qla2xxx: Fix endianness annotations in header files Bart Van Assche
2020-05-18 21:17 ` [PATCH v7 15/15] qla2xxx: Fix endianness annotations in source files Bart Van Assche
2020-05-19 15:24   ` Daniel Wagner
2020-05-20  7:39     ` Finn Thain
2020-05-20  8:56       ` Daniel Wagner
2020-05-24  4:28         ` Finn Thain
2020-05-24 15:50           ` Bart Van Assche
2020-05-24 23:45             ` Finn Thain
2020-05-20  2:30 ` Martin K. Petersen [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=158994171818.20861.11581994731205196049.b4-ty@oracle.com \
    --to=martin.petersen@oracle.com \
    --cc=aeasi@marvell.com \
    --cc=bvanassche@acm.org \
    --cc=hare@suse.de \
    --cc=jejb@linux.vnet.ibm.com \
    --cc=linux-scsi@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).