linux-trace-devel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: "Yordan Karadzhov (VMware)" <y.karadz@gmail.com>
To: Steven Rostedt <rostedt@goodmis.org>
Cc: linux-trace-devel@vger.kernel.org
Subject: Re: [PATCH v2 20/20] kernel-shark: Integrate streams with libkshark-configio
Date: Mon, 9 Nov 2020 16:55:58 +0200	[thread overview]
Message-ID: <af6f31bc-b5cb-d3fa-bb2f-fb953ef19734@gmail.com> (raw)
In-Reply-To: <20201105142253.69485d76@gandalf.local.home>



On 5.11.20 г. 21:22 ч., Steven Rostedt wrote:
> On Mon, 12 Oct 2020 16:35:23 +0300
> "Yordan Karadzhov (VMware)" <y.karadz@gmail.com> wrote:
> 
>> +int kshark_import_trace_file(struct kshark_context *kshark_ctx,
>> +			     struct kshark_config_doc *conf)
>>   {
>> -	const char *file = NULL;
>> +	const char *file = NULL, *name = NULL;
>> +	int sd = -1;
>> +
>>   	switch (conf->format) {
>>   	case KS_CONFIG_JSON:
>> -		if (kshark_trace_file_from_json(&file, conf->conf_doc))
>> -			kshark_open(kshark_ctx, file);
>> +		if (kshark_trace_file_from_json(&file, &name, "data",
>> +						conf->conf_doc)) {
>> +			if (strcmp(name, "top") == 0) {
> 
> Is "top" something that could be named by a user? That is, we could have a
> conflict if a buffer is called "top"?
> 
> If this is a special meaning, then we should probably make this something A
> user can not do, or even better, unlikely to have. And we shouldn't have it
> hardcoded as "top" anyway, it should be a macro.
> 
> 
> #define KERNEL_SHARK_TOP_STREAM		"/ / / __Top__ / / /"
> 
> Then everywhere use that.
> 
> Like in kshark_tep_init_input():
> 
> 	stream->name = strdup(KERNEL_SHARK_TOP_STREAM);
> 
> And also replace "top" in this code with that macro as well.

Hi Steven,

In the review of patch 13/20 you already suggested to replace the name 
"top" with a non-printable character:

const char top_name[] = { 0x1b, 0x00 }; // Non printable character
#define TOP_NAME	(char *)&top_name

This change will be included in v3.

Thanks!
Yordan


> 
> -- Steve
> 
> 
>> +				sd = kshark_open(kshark_ctx, file);
>> +			} else {
>> +				int sd_top;
>> +
>> +				sd_top = kshark_tep_find_top_stream(kshark_ctx,
>> +								    file);
>> +				if (sd_top < 0) {
>> +					/*
>> +					 * The "top" steam (buffer) has to be
>> +					 * initialized first.
>> +					 */
>> +					sd_top = kshark_open(kshark_ctx, file);
>> +				}
>> +
>> +				if (sd_top >= 0)
>> +					sd = kshark_tep_open_buffer(kshark_ctx,
>> +								    sd_top,
>> +								    name);
>> +
>> +				if (sd >= 0)
>> +				kshark_tep_handle_plugins(kshark_ctx, sd);
>> +			}
>> +		}
>> +
>> +		break;
>>   
>> +	default:
>> +		fprintf(stderr, "Document format %d not supported\n",
>> +			conf->format);
>>   		break;
>> +	}
>> +
>> +	return sd;
>> +}

  reply	other threads:[~2020-11-09 14:56 UTC|newest]

Thread overview: 47+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-10-12 13:35 [PATCH v2 00/20] Start KernelShark v2 transformation Yordan Karadzhov (VMware)
2020-10-12 13:35 ` [PATCH v2 01/20] kernel-shark: Start introducing KernelShark 2.0 Yordan Karadzhov (VMware)
2020-10-12 13:35 ` [PATCH v2 02/20] kernel-shark: Use only signed types in kshark_entry Yordan Karadzhov (VMware)
2020-10-12 13:35 ` [PATCH v2 03/20] kernel-shark: Introduce libkshark-hash Yordan Karadzhov (VMware)
2020-10-12 14:05   ` Steven Rostedt
2020-10-12 14:05     ` Steven Rostedt
2020-10-12 14:18       ` Yordan Karadzhov (VMware)
2020-10-12 13:35 ` [PATCH v2 04/20] kernel-shark: Introduce Data streams Yordan Karadzhov (VMware)
2020-10-12 13:35 ` [PATCH v2 05/20] kernel-shark: Add stream_id to kshark_entry Yordan Karadzhov (VMware)
2020-10-13  0:05   ` Steven Rostedt
2020-10-29 10:08     ` Yordan Karadzhov (VMware)
2020-10-12 13:35 ` [PATCH v2 06/20] kernel-shark: Rename static methods in libkshark Yordan Karadzhov (VMware)
2020-10-12 13:35 ` [PATCH v2 07/20] kernel-shark: Add basic methods for Data streams Yordan Karadzhov (VMware)
2020-10-13  0:18   ` Steven Rostedt
2020-10-29 10:10     ` Yordan Karadzhov (VMware)
2020-10-29 14:04       ` Steven Rostedt
2020-10-29 14:49         ` Yordan Karadzhov (VMware)
2020-10-30  1:57           ` Steven Rostedt
2020-11-03 13:38             ` Yordan Karadzhov (VMware)
2020-11-04 15:41               ` Steven Rostedt
2020-11-05 14:35                 ` Yordan Karadzhov (VMware)
2020-10-12 13:35 ` [PATCH v2 08/20] kernel-shark: Housekeeping before implementing stream interface Yordan Karadzhov (VMware)
2020-10-12 13:35 ` [PATCH v2 09/20] kernel-shark: Add stream interface for trace-cmd data Yordan Karadzhov (VMware)
2020-10-13  0:44   ` Steven Rostedt
2020-10-29 11:16     ` Yordan Karadzhov (VMware)
2020-10-12 13:35 ` [PATCH v2 10/20] kernel-shark: Start using data streams Yordan Karadzhov (VMware)
2020-10-14 18:56   ` Steven Rostedt
2020-11-05 14:58     ` Yordan Karadzhov (VMware)
2020-11-05 18:17       ` Steven Rostedt
2020-11-06 14:31         ` Yordan Karadzhov (VMware)
2020-11-06 15:18           ` Steven Rostedt
2020-11-09 14:49             ` Yordan Karadzhov (VMware)
2020-10-12 13:35 ` [PATCH v2 11/20] kernel-shark: Remove dead code Yordan Karadzhov (VMware)
2020-10-12 13:35 ` [PATCH v2 12/20] kernel-shark: Redesign the plugin interface Yordan Karadzhov (VMware)
2020-10-14 21:09   ` Steven Rostedt
2020-10-12 13:35 ` [PATCH v2 13/20] kernel-shark: Complete the stream integration Yordan Karadzhov (VMware)
2020-10-14 23:52   ` Steven Rostedt
2020-10-12 13:35 ` [PATCH v2 14/20] kernel-shark: Provide merging of multiple data streams Yordan Karadzhov (VMware)
2020-10-12 13:35 ` [PATCH v2 15/20] kernel-shark: Integrate the stream definitions with data model Yordan Karadzhov (VMware)
2020-10-12 13:35 ` [PATCH v2 16/20] kernel-shark: Use only signed types for model defs Yordan Karadzhov (VMware)
2020-10-12 13:35 ` [PATCH v2 17/20] kernel-shark: Add ksmodel_get_bin() Yordan Karadzhov (VMware)
2020-10-12 13:35 ` [PATCH v2 18/20] kernel-shark: Protect ksmodel_set_in_range_bining() Yordan Karadzhov (VMware)
2020-10-12 13:35 ` [PATCH v2 19/20] kernel-shark: Add methods for time calibration Yordan Karadzhov (VMware)
2020-10-12 13:35 ` [PATCH v2 20/20] kernel-shark: Integrate streams with libkshark-configio Yordan Karadzhov (VMware)
2020-11-05 19:22   ` Steven Rostedt
2020-11-09 14:55     ` Yordan Karadzhov (VMware) [this message]
2020-11-09 15:28       ` Steven Rostedt

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=af6f31bc-b5cb-d3fa-bb2f-fb953ef19734@gmail.com \
    --to=y.karadz@gmail.com \
    --cc=linux-trace-devel@vger.kernel.org \
    --cc=rostedt@goodmis.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).