linux-xfs.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: "Darrick J. Wong" <darrick.wong@oracle.com>
To: Dave Chinner <david@fromorbit.com>
Cc: linux-xfs@vger.kernel.org, hch@infradead.org
Subject: Re: [PATCH 2/2] xfs: convert open coded corruption check to use XFS_IS_CORRUPT
Date: Sat, 9 Nov 2019 16:18:03 -0800	[thread overview]
Message-ID: <20191110001803.GP6219@magnolia> (raw)
In-Reply-To: <20191109223238.GH4614@dread.disaster.area>

On Sun, Nov 10, 2019 at 09:32:38AM +1100, Dave Chinner wrote:
> On Thu, Nov 07, 2019 at 11:05:21PM -0800, Darrick J. Wong wrote:
> > From: Darrick J. Wong <darrick.wong@oracle.com>
> > 
> > Convert the last of the open coded corruption check and report idioms to
> > use the XFS_IS_CORRUPT macro.
> 
> hmmm.
> 
> > +	if (XFS_IS_CORRUPT(mp,
> > +	    ir.loaded != XFS_IFORK_NEXTENTS(ip, whichfork))) {
> 
> This pattern is weird. It looks like there are two separate logic
> statements to the if() condition, when in fact the second line is
> part of the XFS_IS_CORRUPT() macro.
> 
> It just looks wrong to me, especially when everything other
> multi-line macro is indented based on the indenting of the macro
> parameters....
> 
> Yes, in this case it looks a bit strange, too:
> 
> 	if (XFS_IS_CORRUPT(mp,
> 			   ir.loaded != XFS_IFORK_NEXTENTS(ip, whichfork))) {
> 
> but there is no mistaking it for separate logic statements.

They're all ugly, because of all the stupid identing when the
conditional gets too long.

> I kinda value being able to glance at the indent levels to see
> separate logic elements....
> 
> > -		if (unlikely(
> > -		       be32_to_cpu(sib_info->back) != last_blkno ||
> > -		       sib_info->magic != dead_info->magic)) {
> > -			XFS_ERROR_REPORT("xfs_da_swap_lastblock(3)",
> > -					 XFS_ERRLEVEL_LOW, mp);
> > +		if (XFS_IS_CORRUPT(mp,
> > +		    be32_to_cpu(sib_info->back) != last_blkno ||
> > +		    sib_info->magic != dead_info->magic)) {

They're both ugly, IMHO.  One has horrible indentation that's too close
to the code in the if statement body, the other is hard to read as an if
statement.

> >  			error = -EFSCORRUPTED;
> >  			goto done;
> >  		}
> 
> This is kind of what I mean - is it two or three  logic statments
> here? No, it's actually one, but it has two nested checks...
> 
> There's a few other list this that are somewhat non-obvious as to
> the logic...

I'd thought about giving it the shortest name possible, not bothering to
log the fsname that goes with the error report, and making the if part
of the macro:

#define IFBAD(cond) if ((unlikely(cond) ? assert(...), true : false))

IFBAD(be32_to_cpu(sib_info->back) != last_blkno ||
      sib_info->magic != dead_info->magic)) {
	xfs_whatever();
	return -EFSCORRUPTED;
}

Is that better?

--D

> 
> Cheers,
> 
> Dave.
> -- 
> Dave Chinner
> david@fromorbit.com

  reply	other threads:[~2019-11-10  0:19 UTC|newest]

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-11-08  7:05 [PATCH v3 0/2] xfs: refactor corruption checking and reporting Darrick J. Wong
2019-11-08  7:05 ` [PATCH 1/2] xfs: refactor "does this fork map blocks" predicate Darrick J. Wong
2019-11-08  7:15   ` Christoph Hellwig
2019-11-08  7:05 ` [PATCH 2/2] xfs: convert open coded corruption check to use XFS_IS_CORRUPT Darrick J. Wong
2019-11-08  7:21   ` Christoph Hellwig
2019-11-09 22:32   ` Dave Chinner
2019-11-10  0:18     ` Darrick J. Wong [this message]
2019-11-10  2:49       ` Dave Chinner
2019-11-10 18:20         ` Darrick J. Wong

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20191110001803.GP6219@magnolia \
    --to=darrick.wong@oracle.com \
    --cc=david@fromorbit.com \
    --cc=hch@infradead.org \
    --cc=linux-xfs@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).