linux-xfs.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-02-25 21:50:30 to 2020-02-27 17:52:31 UTC [more...]

[PATCH V4 00/13] Enable per-file/per-directory DAX operations V4
 2020-02-27 17:52 UTC  (29+ messages)
` [PATCH V4 01/13] fs/xfs: Remove unnecessary initialization of i_rwsem
` [PATCH V4 07/13] fs: Add locking for a dynamic address space operations state
` [PATCH V4 09/13] fs/xfs: Add write aops lock to xfs layer

[PATCH V5 00/12] Enable per-file/per-directory DAX operations V5
 2020-02-27 17:25 UTC  (14+ messages)
` [PATCH V5 01/12] fs/xfs: Remove unnecessary initialization of i_rwsem
` [PATCH V5 02/12] fs: Remove unneeded IS_DAX() check
` [PATCH V5 03/12] fs/stat: Define DAX statx attribute
` [PATCH V5 04/12] fs/xfs: Isolate the physical DAX flag from enabled
` [PATCH V5 05/12] fs/xfs: Create function xfs_inode_enable_dax()
` [PATCH V5 06/12] fs: Add locking for a dynamic address space operations state
` [PATCH V5 07/12] fs: Prevent DAX state change if file is mmap'ed
` [PATCH V5 08/12] fs/xfs: Hold off aops users while changing DAX state
` [PATCH V5 09/12] fs/xfs: Clean up locking in dax invalidate
` [PATCH V5 10/12] fs/xfs: Allow toggle of effective DAX flag
` [PATCH V5 11/12] fs/xfs: Remove xfs_diflags_to_linux()
` [PATCH V5 12/12] Documentation/dax: Update Usage section

[PATCH 0/3] xfs: prepare repair for bulk loading
 2020-02-27 15:51 UTC  (7+ messages)
` [PATCH 2/3] xfs: implement block reservation accounting for btrees we're staging

[RFC v5 PATCH 0/9] xfs: automatic relogging experiment
 2020-02-27 15:22 UTC  (13+ messages)
` [RFC v5 PATCH 1/9] xfs: set t_task at wait time instead of alloc time
` [RFC v5 PATCH 2/9] xfs: introduce ->tr_relog transaction
` [RFC v5 PATCH 3/9] xfs: automatic relogging reservation management
` [RFC v5 PATCH 4/9] xfs: automatic relogging item management
` [RFC v5 PATCH 5/9] xfs: automatic log item relog mechanism
` [RFC v5 PATCH 6/9] xfs: automatically relog the quotaoff start intent
` [RFC v5 PATCH 7/9] xfs: buffer relogging support prototype
` [RFC v5 PATCH 8/9] xfs: create an error tag for random relog reservation
` [RFC v5 PATCH 9/9] xfs: relog random buffers based on errortag

[PATCH V4 RESEND 0/7] Fix log reservation calculation for xattr insert operation
 2020-02-27 13:38 UTC  (22+ messages)
` [PATCH V4 RESEND 1/7] xfs: Pass xattr name and value length explicitly to xfs_attr_leaf_newentsize
` [PATCH V4 RESEND 2/7] xfs: xfs_attr_calc_size: Use local variables to track individual space components
` [PATCH V4 RESEND 3/7] xfs: xfs_attr_calc_size: Calculate Bmbt blks only once
` [PATCH V4 RESEND 4/7] xfs: Introduce struct xfs_attr_set_resv
` [PATCH V4 RESEND 7/7] xfs: Fix log reservation calculation for xattr insert operation

[PATCH] xfs/XXX: Add xfs/XXX
 2020-02-27  5:38 UTC 

[PATCH v7 00/19] xfs: Delayed Ready Attrs
 2020-02-27  4:18 UTC  (52+ messages)
` [PATCH v7 02/19] xfs: Embed struct xfs_name in xfs_da_args
` [PATCH v7 03/19] xfs: Add xfs_has_attr and subroutines
` [PATCH v7 05/19] xfs: Factor out new helper functions xfs_attr_rmtval_set
` [PATCH v7 07/19] xfs: Factor out xfs_attr_leaf_addname helper
` [PATCH v7 12/19] xfs: Add helper function xfs_attr_rmtval_unmap
` [PATCH v7 13/19] xfs: Add delay ready attr remove routines
` [PATCH v7 15/19] xfs: Add helper function xfs_attr_node_shrink
` [PATCH v7 16/19] xfs: Simplify xfs_attr_set_iter
` [PATCH v7 17/19] xfs: Add helper function xfs_attr_leaf_mark_incomplete

clean up the attr interface v7
 2020-02-26 21:40 UTC  (37+ messages)
` [PATCH 01/32] xfs: reject invalid flags combinations in XFS_IOC_ATTRLIST_BY_HANDLE
` [PATCH 02/32] xfs: remove the ATTR_INCOMPLETE flag
` [PATCH 03/32] xfs: merge xfs_attr_remove into xfs_attr_set
` [PATCH 04/32] xfs: merge xfs_attrmulti_attr_remove into xfs_attrmulti_attr_set
` [PATCH 05/32] xfs: use strndup_user in XFS_IOC_ATTRMULTI_BY_HANDLE
` [PATCH 06/32] xfs: factor out a helper for a single XFS_IOC_ATTRMULTI_BY_HANDLE op
` [PATCH 07/32] xfs: remove the name == NULL check from xfs_attr_args_init
` [PATCH 08/32] xfs: remove the MAXNAMELEN "
` [PATCH 09/32] xfs: turn xfs_da_args.value into a void pointer
` [PATCH 10/32] xfs: pass an initialized xfs_da_args structure to xfs_attr_set
` [PATCH 11/32] xfs: pass an initialized xfs_da_args to xfs_attr_get
` [PATCH 12/32] xfs: remove the xfs_inode argument to xfs_attr_get_ilocked
` [PATCH 13/32] xfs: remove ATTR_KERNOVAL
` [PATCH 14/32] xfs: remove ATTR_ALLOC and XFS_DA_OP_ALLOCVAL
` [PATCH 15/32] xfs: replace ATTR_KERNOTIME with XFS_DA_OP_NOTIME
` [PATCH 16/32] xfs: factor out a xfs_attr_match helper
` [PATCH 17/32] xfs: cleanup struct xfs_attr_list_context
` [PATCH 18/32] xfs: remove the unused ATTR_ENTRY macro
` [PATCH 19/32] xfs: open code ATTR_ENTSIZE
` [PATCH 20/32] xfs: move the legacy xfs_attr_list to xfs_ioctl.c
` [PATCH 21/32] xfs: rename xfs_attr_list_int to xfs_attr_list
` [PATCH 22/32] xfs: lift common checks into xfs_ioc_attr_list
` [PATCH 23/32] xfs: lift buffer allocation "
` [PATCH 24/32] xfs: lift cursor copy in/out "
` [PATCH 25/32] xfs: improve xfs_forget_acl
` [PATCH 26/32] xfs: clean up the ATTR_REPLACE checks
` [PATCH 27/32] xfs: clean up the attr flag confusion
` [PATCH 28/32] xfs: remove XFS_DA_OP_INCOMPLETE
` [PATCH 29/32] xfs: embedded the attrlist cursor into struct xfs_attr_list_context
` [PATCH 30/32] xfs: clean up bufsize alignment in xfs_ioc_attr_list
` [PATCH 31/32] xfs: only allocate the buffer size actually needed in __xfs_set_acl
` [PATCH 32/32] xfs: switch xfs_attrmulti_attr_get to lazy attr buffer allocation

[PATCH 0/2] xfs: don't take addresses of packed structures
 2020-02-26 18:45 UTC  (7+ messages)
` [PATCH 2/2] xfs: don't take addresses of packed xfs_rmap_key
  ` [PATCH 2/2 V2] xfs: don't take addresses of packed xfs_rmap_key member
    ` [PATCH 2/2 V3] "

[PATCH v4 0/7] xfs_repair: do not trash valid root dirs
 2020-02-26 17:55 UTC  (13+ messages)
` [PATCH 1/7] xfs_repair: replace verify_inum with libxfs inode validators
` [PATCH 3/7] xfs_repair: enforce that inode btree chunks can't point to AG headers
` [PATCH 7/7] xfs_repair: try to correct sb_unit value from secondaries

[PATCH v8 00/25] Change readahead API
 2020-02-26 17:13 UTC  (26+ messages)
` [PATCH v8 02/25] mm: Return void from various readahead functions
` [PATCH v8 05/25] mm: Add new readahead_control API
` [PATCH v8 07/25] mm: Rename various 'offset' parameters to 'index'
` [PATCH v8 08/25] mm: rename readahead loop variable to 'i'
` [PATCH v8 10/25] mm: Put readahead pages in cache earlier
` [PATCH v8 11/25] mm: Add readahead address space operation
` [PATCH v8 12/25] mm: Move end_index check out of readahead loop
` [PATCH v8 13/25] mm: Add page_cache_readahead_unbounded
` [PATCH v8 14/25] mm: Document why we don't set PageReadahead
` [PATCH v8 15/25] mm: Use memalloc_nofs_save in readahead path
` [PATCH v8 17/25] btrfs: Convert from readpages to readahead
` [PATCH v8 18/25] erofs: Convert uncompressed files "
` [PATCH v8 20/25] ext4: Convert "
` [PATCH v8 21/25] ext4: Pass the inode to ext4_mpage_readpages
` [PATCH v8 22/25] f2fs: Convert from readpages to readahead
` [PATCH v8 23/25] f2fs: Pass the inode to f2fs_mpage_readpages
` [PATCH v8 25/25] iomap: Convert from readpages to readahead

[PATCH 0/2] libfrog: various small fixes
 2020-02-26 16:55 UTC  (7+ messages)
` [PATCH 2/2] libfrog: move topology.[ch] to libxfs

[PATCH v3] xfs: fix an undefined behaviour in _da3_path_shift
 2020-02-26 16:28 UTC  (3+ messages)

clean up the attr interface v6
 2020-02-26 16:27 UTC  (46+ messages)
` [PATCH 01/30] xfs: reject invalid flags combinations in XFS_IOC_ATTRLIST_BY_HANDLE
` [PATCH 02/30] xfs: remove the ATTR_INCOMPLETE flag
` [PATCH 03/30] xfs: merge xfs_attr_remove into xfs_attr_set
` [PATCH 04/30] xfs: merge xfs_attrmulti_attr_remove into xfs_attrmulti_attr_set
` [PATCH 05/30] xfs: use strndup_user in XFS_IOC_ATTRMULTI_BY_HANDLE
` [PATCH 06/30] xfs: factor out a helper for a single XFS_IOC_ATTRMULTI_BY_HANDLE op
` [PATCH 07/30] xfs: remove the name == NULL check from xfs_attr_args_init
` [PATCH 08/30] xfs: remove the MAXNAMELEN "
` [PATCH 09/30] xfs: turn xfs_da_args.value into a void pointer
` [PATCH 10/30] xfs: pass an initialized xfs_da_args structure to xfs_attr_set
` [PATCH 11/30] xfs: pass an initialized xfs_da_args to xfs_attr_get
` [PATCH 12/30] xfs: remove the xfs_inode argument to xfs_attr_get_ilocked
` [PATCH 13/30] xfs: remove ATTR_KERNOVAL
` [PATCH 14/30] xfs: remove ATTR_ALLOC and XFS_DA_OP_ALLOCVAL
` [PATCH 15/30] xfs: replace ATTR_KERNOTIME with XFS_DA_OP_NOTIME
` [PATCH 16/30] xfs: factor out a xfs_attr_match helper
` [PATCH 17/30] xfs: cleanup struct xfs_attr_list_context
` [PATCH 18/30] xfs: remove the unused ATTR_ENTRY macro
` [PATCH 19/30] xfs: open code ATTR_ENTSIZE
` [PATCH 20/30] xfs: move the legacy xfs_attr_list to xfs_ioctl.c
` [PATCH 21/30] xfs: rename xfs_attr_list_int to xfs_attr_list
` [PATCH 22/30] xfs: lift common checks into xfs_ioc_attr_list
` [PATCH 23/30] xfs: lift buffer allocation "
` [PATCH 24/30] xfs: lift cursor copy in/out "
` [PATCH 25/30] xfs: improve xfs_forget_acl
` [PATCH 26/30] xfs: clean up the ATTR_REPLACE checks
` [PATCH 27/30] xfs: clean up the attr flag confusion
` [PATCH 28/30] xfs: remove XFS_DA_OP_INCOMPLETE
` [PATCH 29/30] xfs: embedded the attrlist cursor into struct xfs_attr_list_context
` [PATCH 30/30] xfs: clean up bufsize alignment in xfs_ioc_attr_list

[PATCH 0/1] selinux: Add xfs quota command types
 2020-02-26 15:21 UTC  (10+ messages)

[PATCH, RFC] libxfs: use FALLOC_FL_ZERO_RANGE in libxfs_device_zero
 2020-02-25 23:33 UTC  (4+ messages)
` [PATCH V4] "

[PATCH v2] xfs: fix an undefined behaviour in _da3_path_shift
 2020-02-25 22:05 UTC  (3+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).