linuxppc-dev.lists.ozlabs.org archive mirror
 help / color / mirror / Atom feed
From: Helge Deller <deller@gmx.de>
To: Kees Cook <keescook@chromium.org>,
	Christophe Leroy <christophe.leroy@csgroup.eu>
Cc: linux-arch@vger.kernel.org, linux-ia64@vger.kernel.org,
	linux-parisc@vger.kernel.org, Arnd Bergmann <arnd@arndb.de>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	linux-kernel@vger.kernel.org,
	"James E.J. Bottomley" <James.Bottomley@hansenpartnership.com>,
	linux-mm@kvack.org, Paul Mackerras <paulus@samba.org>,
	Andrew Morton <akpm@linux-foundation.org>,
	linuxppc-dev@lists.ozlabs.org
Subject: Re: [PATCH v4 00/13] Fix LKDTM for PPC64/IA64/PARISC v4
Date: Wed, 16 Feb 2022 14:26:54 +0100	[thread overview]
Message-ID: <7c557d0c-6718-4e16-29c6-8b75c704b773@gmx.de> (raw)
In-Reply-To: <202202150807.D584917D34@keescook>

On 2/15/22 17:07, Kees Cook wrote:
> On Tue, Feb 15, 2022 at 01:40:55PM +0100, Christophe Leroy wrote:
>> PPC64/IA64/PARISC have function descriptors. LKDTM doesn't work
>> on those three architectures because LKDTM messes up function
>> descriptors with functions.
>>
>> This series does some cleanup in the three architectures and
>> refactors function descriptors so that it can then easily use it
>> in a generic way in LKDTM.
>
> Thanks for doing this! It looks good to me. :)

I endorse that.
Thank you, Christophe!

Acked-by: Helge Deller <deller@gmx.de>

Helge

> -Kees
>
>>
>> Changes in v4:
>> - Added patch 1 which Fixes 'sparse' for powerpc64le after wrong report on previous series, refer https://github.com/ruscur/linux-ci/actions/runs/1351427671
>> - Exported dereference_function_descriptor() to modules
>> - Addressed other received comments
>> - Rebased on latest powerpc/next (5a72345e6a78120368fcc841b570331b6c5a50da)
>>
>> Changes in v3:
>> - Addressed received comments
>> - Swapped some of the powerpc patches to keep func_descr_t renamed as struct func_desc and remove 'struct ppc64_opd_entry'
>> - Changed HAVE_FUNCTION_DESCRIPTORS macro to a config item CONFIG_HAVE_FUNCTION_DESCRIPTORS
>> - Dropped patch 11 ("Fix lkdtm_EXEC_RODATA()")
>>
>> Changes in v2:
>> - Addressed received comments
>> - Moved dereference_[kernel]_function_descriptor() out of line
>> - Added patches to remove func_descr_t and func_desc_t in powerpc
>> - Using func_desc_t instead of funct_descr_t
>> - Renamed HAVE_DEREFERENCE_FUNCTION_DESCRIPTOR to HAVE_FUNCTION_DESCRIPTORS
>> - Added a new lkdtm test to check protection of function descriptors
>>
>> Christophe Leroy (13):
>>   powerpc: Fix 'sparse' checking on PPC64le
>>   powerpc: Move and rename func_descr_t
>>   powerpc: Use 'struct func_desc' instead of 'struct ppc64_opd_entry'
>>   powerpc: Remove 'struct ppc64_opd_entry'
>>   powerpc: Prepare func_desc_t for refactorisation
>>   ia64: Rename 'ip' to 'addr' in 'struct fdesc'
>>   asm-generic: Define CONFIG_HAVE_FUNCTION_DESCRIPTORS
>>   asm-generic: Define 'func_desc_t' to commonly describe function
>>     descriptors
>>   asm-generic: Refactor dereference_[kernel]_function_descriptor()
>>   lkdtm: Force do_nothing() out of line
>>   lkdtm: Really write into kernel text in WRITE_KERN
>>   lkdtm: Fix execute_[user]_location()
>>   lkdtm: Add a test for function descriptors protection
>>
>>  arch/Kconfig                             |  3 +
>>  arch/ia64/Kconfig                        |  1 +
>>  arch/ia64/include/asm/elf.h              |  2 +-
>>  arch/ia64/include/asm/sections.h         | 24 +-------
>>  arch/ia64/kernel/module.c                |  6 +-
>>  arch/parisc/Kconfig                      |  1 +
>>  arch/parisc/include/asm/sections.h       | 16 ++----
>>  arch/parisc/kernel/process.c             | 21 -------
>>  arch/powerpc/Kconfig                     |  1 +
>>  arch/powerpc/Makefile                    |  2 +-
>>  arch/powerpc/include/asm/code-patching.h |  2 +-
>>  arch/powerpc/include/asm/elf.h           |  6 ++
>>  arch/powerpc/include/asm/sections.h      | 29 ++--------
>>  arch/powerpc/include/asm/types.h         |  6 --
>>  arch/powerpc/include/uapi/asm/elf.h      |  8 ---
>>  arch/powerpc/kernel/module_64.c          | 42 ++++++--------
>>  arch/powerpc/kernel/ptrace/ptrace.c      |  6 ++
>>  arch/powerpc/kernel/signal_64.c          |  8 +--
>>  drivers/misc/lkdtm/core.c                |  1 +
>>  drivers/misc/lkdtm/lkdtm.h               |  1 +
>>  drivers/misc/lkdtm/perms.c               | 71 +++++++++++++++++++-----
>>  include/asm-generic/sections.h           | 15 ++++-
>>  include/linux/kallsyms.h                 |  2 +-
>>  kernel/extable.c                         | 24 +++++++-
>>  tools/testing/selftests/lkdtm/tests.txt  |  1 +
>>  25 files changed, 155 insertions(+), 144 deletions(-)
>>
>> --
>> 2.34.1
>>
>


  parent reply	other threads:[~2022-02-16 13:29 UTC|newest]

Thread overview: 24+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-02-15 12:40 [PATCH v4 00/13] Fix LKDTM for PPC64/IA64/PARISC v4 Christophe Leroy
2022-02-15 12:40 ` [PATCH v4 01/13] powerpc: Fix 'sparse' checking on PPC64le Christophe Leroy
2022-02-15 16:06   ` Kees Cook
2022-02-15 12:40 ` [PATCH v4 02/13] powerpc: Move and rename func_descr_t Christophe Leroy
2022-02-15 12:40 ` [PATCH v4 03/13] powerpc: Use 'struct func_desc' instead of 'struct ppc64_opd_entry' Christophe Leroy
2022-02-15 12:40 ` [PATCH v4 04/13] powerpc: Remove " Christophe Leroy
2022-02-15 12:41 ` [PATCH v4 05/13] powerpc: Prepare func_desc_t for refactorisation Christophe Leroy
2022-02-15 12:41 ` [PATCH v4 06/13] ia64: Rename 'ip' to 'addr' in 'struct fdesc' Christophe Leroy
2022-02-15 12:41 ` [PATCH v4 07/13] asm-generic: Define CONFIG_HAVE_FUNCTION_DESCRIPTORS Christophe Leroy
2022-02-15 12:41 ` [PATCH v4 08/13] asm-generic: Define 'func_desc_t' to commonly describe function descriptors Christophe Leroy
2022-02-15 12:41 ` [PATCH v4 09/13] asm-generic: Refactor dereference_[kernel]_function_descriptor() Christophe Leroy
2022-02-15 12:41 ` [PATCH v4 10/13] lkdtm: Force do_nothing() out of line Christophe Leroy
2022-02-15 12:41 ` [PATCH v4 11/13] lkdtm: Really write into kernel text in WRITE_KERN Christophe Leroy
2022-02-15 12:41 ` [PATCH v4 12/13] lkdtm: Fix execute_[user]_location() Christophe Leroy
2022-02-15 12:41 ` [PATCH v4 13/13] lkdtm: Add a test for function descriptors protection Christophe Leroy
2022-02-15 16:07 ` [PATCH v4 00/13] Fix LKDTM for PPC64/IA64/PARISC v4 Kees Cook
2022-02-16 12:22   ` Michael Ellerman
2022-02-16 16:20     ` Kees Cook
2022-02-16 13:26   ` Helge Deller [this message]
2022-02-16 12:25 ` John Paul Adrian Glaubitz
2022-02-21 20:06   ` John Paul Adrian Glaubitz
2022-03-08 12:07 ` Michael Ellerman
2022-03-09  1:37   ` Michael Ellerman
2022-03-09 16:30     ` Kees Cook

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=7c557d0c-6718-4e16-29c6-8b75c704b773@gmx.de \
    --to=deller@gmx.de \
    --cc=James.Bottomley@hansenpartnership.com \
    --cc=akpm@linux-foundation.org \
    --cc=arnd@arndb.de \
    --cc=christophe.leroy@csgroup.eu \
    --cc=gregkh@linuxfoundation.org \
    --cc=keescook@chromium.org \
    --cc=linux-arch@vger.kernel.org \
    --cc=linux-ia64@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=linux-parisc@vger.kernel.org \
    --cc=linuxppc-dev@lists.ozlabs.org \
    --cc=paulus@samba.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).