linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: "Carl Vanderlip" <carlv@codeaurora.org>
To: "Sergei Shtylyov" <sshtylyov@mvista.com>
Cc: "Carl Vanderlip" <carlv@codeaurora.org>,
	"David Brown" <davidb@codeaurora.org>,
	"Daniel Walker" <dwalker@fifo99.com>,
	"Bryan Huntsman" <bryanh@codeaurora.org>,
	linux-fbdev@vger.kernel.org,
	"Brian Swetland" <swetland@google.com>,
	linux-arm-msm@vger.kernel.org, linux-kernel@vger.kernel.org,
	"Colin Cross" <ccross@android.com>,
	"Rebecca Schultz Zavin" <rebecca@android.com>,
	"Dima Zavin" <dima@android.com>,
	linux-arm-kernel@lists.infradead.org
Subject: Re: [PATCH 17/20] video: msm: Prevent framebuffer glitch  during	initialization
Date: Mon, 21 Mar 2011 16:49:46 -0700 (PDT)	[thread overview]
Message-ID: <1f9ceab007818b26e65019950985fe88.squirrel@www.codeaurora.org> (raw)
In-Reply-To: <4D87552D.4070205@ru.mvista.com>


> Carl Vanderlip wrote:
>
>> Holds a reference to the mdp_clk until lateinit, and moves the
>> frambuffer
>> initialization to device_init.
>
>     Maybe I'm just blind but I don't see where the patch does the
> latter...
>
>> The framebuffer lcdc driver will grab a
>> reference to mdp_clk, which prevents the clock from being disabled by
>> clock_late_init.
>
>> Authors:
>> Dima Zavin <dima@android.com>
>> Rebecca Schultz Zavin <rebecca@android.com>
>> Colin Cross <ccross@android.com>
>

Fear not. You are not going blind :P, I got a bit overzealous when trying
to re-use the commit text that was available from the squashed patch that
this patch set is spawned from (hence why [18/20] also has this same
issue.
I will be re-writing this commit text for v2 (unless this c-text is
desired to be kept for "historical" purposes).

>> ---
>>  drivers/video/msm/mdp.c |   10 ++++++++++
>>  1 files changed, 10 insertions(+), 0 deletions(-)
>
>> diff --git a/drivers/video/msm/mdp.c b/drivers/video/msm/mdp.c
>> index 0bb19fa..b3f334ad 100644
>> --- a/drivers/video/msm/mdp.c
>> +++ b/drivers/video/msm/mdp.c
>> @@ -38,6 +38,7 @@ struct class *mdp_class;
>>
>>  static DECLARE_WAIT_QUEUE_HEAD(mdp_ppp_waitqueue);
>>  static unsigned int mdp_irq_mask;
>> +struct clk *mdp_clk_to_disable_later;
>
>     Why not just 'mdp_clk'? :-)
>

I was not the original author for these variable names, though I do see
some reason behind the naming of this variable. I'd be more willing to
change this name, to "mdp_clk" if it weren't so visually similar to
mdp->clk (tired programmer eyes/brain could read (or write) the wrong
one).

As it is, the name is a little long, but it makes it extraordinarily clear
what its purpose is (i.e. you know exactly what it is being used for
without having to go searching for other places it is used).

So while I don't like the name as it is, I don't really like 'mdp_clk'
either (though would be willing to change it if anyone feels like being
stubborn :-)).

    -Carl V.

-- 
Sent by an employee of the Qualcomm Innovation Center, Inc.
The Qualcomm Innovation Center, Inc. is a member of the Code Aurora Forum.


  reply	other threads:[~2011-03-21 23:50 UTC|newest]

Thread overview: 44+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2011-03-18 21:47 [PATCH 00/20] video: msm: Adding Support for MDP3.1 Carl Vanderlip
2011-03-18 21:51 ` [PATCH 01/20] video: msm: Fix typo 'mpd'->'mdp' Carl Vanderlip
2011-03-21  4:24   ` Janorkar, Mayuresh
2011-03-22  0:08     ` Carl Vanderlip
2011-03-18 21:53 ` [PATCH 02/20] video: msm: add spinlock to mdp_info struct Carl Vanderlip
2011-03-18 21:53 ` [PATCH 03/20] video: msm: add locked_enable_mdp_irq function Carl Vanderlip
2011-03-18 21:54 ` [PATCH 04/20] video: msm: Move clk to mdp_info struct Carl Vanderlip
2011-03-18 21:54 ` [PATCH 05/20] video: msm: Setup framework for multiple output interfaces Carl Vanderlip
2011-03-18 21:55 ` [PATCH 06/20] video: msm: Simplify mdp_blit function Carl Vanderlip
2011-03-18 21:56 ` [PATCH 07/20] video: msm: Allow users to request a larger x and y virtual fb Carl Vanderlip
2011-03-21  4:40   ` Janorkar, Mayuresh
2011-03-21 16:41     ` Russell King - ARM Linux
2011-03-22  0:21     ` Carl Vanderlip
2011-03-18 21:56 ` [PATCH 08/20] video: msm: Refactor mdp_regs Carl Vanderlip
2011-03-21  5:17   ` Janorkar, Mayuresh
2011-03-21 17:23     ` Bryan Huntsman
2011-03-21 17:28       ` Brian Swetland
2011-03-18 21:57 ` [PATCH 09/20] video: msm: Split out MDP2.2 HW specific code Carl Vanderlip
2011-03-20  9:22   ` Russell King - ARM Linux
2011-03-22  0:26     ` Carl Vanderlip
2011-03-21  5:15   ` Janorkar, Mayuresh
2011-03-23 13:11   ` Daniel Walker
2011-03-23 19:18     ` Dima Zavin
2011-03-23 20:42     ` Carl Vanderlip
2011-03-23 22:47       ` David Brown
2011-03-18 21:57 ` [PATCH 10/20] video: msm: Separate more MDP " Carl Vanderlip
2011-03-18 21:57 ` [PATCH 11/20] video: msm: Add MDP FB DMA configuration Carl Vanderlip
2011-03-21  5:18   ` Janorkar, Mayuresh
2011-03-18 21:58 ` [PATCH 12/20] video: msm: Add IRQ callback for MDP interface Carl Vanderlip
2011-03-18 21:58 ` [PATCH 13/20] video: msm: Debugging for send_blit Carl Vanderlip
2011-03-21  5:20   ` Janorkar, Mayuresh
2011-03-18 21:58 ` [PATCH 14/20] video: msm: Write IRQ mask to MDP registers Carl Vanderlip
2011-03-18 21:59 ` [PATCH 15/20] video: msm: convert printk to pr_* Carl Vanderlip
2011-03-21  5:22   ` Janorkar, Mayuresh
2011-03-21 13:33   ` Sergei Shtylyov
2011-03-18 21:59 ` [PATCH 16/20] video: msm: Set the EBI1 clock to 128MHz when performing blits Carl Vanderlip
2011-03-21 20:31   ` Stephen Boyd
2011-03-18 21:59 ` [PATCH 17/20] video: msm: Prevent framebuffer glitch during initialization Carl Vanderlip
2011-03-21 13:39   ` Sergei Shtylyov
2011-03-21 23:49     ` Carl Vanderlip [this message]
2011-03-18 21:59 ` [PATCH 18/20] video: msm: Prevent DMA lockups when switching bit depths Carl Vanderlip
2011-03-21 13:42   ` Sergei Shtylyov
2011-03-18 21:59 ` [PATCH 19/20] video: msm: Separate calculation of base and offset Carl Vanderlip
2011-03-18 22:00 ` [PATCH 20/20] video: msm: Add support for MDP 3.1 (qsd8k) Carl Vanderlip

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1f9ceab007818b26e65019950985fe88.squirrel@www.codeaurora.org \
    --to=carlv@codeaurora.org \
    --cc=bryanh@codeaurora.org \
    --cc=ccross@android.com \
    --cc=davidb@codeaurora.org \
    --cc=dima@android.com \
    --cc=dwalker@fifo99.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-arm-msm@vger.kernel.org \
    --cc=linux-fbdev@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=rebecca@android.com \
    --cc=sshtylyov@mvista.com \
    --cc=swetland@google.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).