linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Bjorn Helgaas <helgaas@kernel.org>
To: linux-pci@vger.kernel.org
Cc: linux-kernel@vger.kernel.org,
	"Rafael J. Wysocki" <rjw@rjwysocki.net>,
	linux-pm@vger.kernel.org, Keith Busch <keith.busch@intel.com>,
	Sinan Kaya <okaya@codeaurora.org>, Lukas Wunner <lukas@wunner.de>,
	Frederick Lawler <fred@fredlawl.com>
Subject: Re: [PATCH v2 00/13] PCI: Simplify PCIe port driver
Date: Mon, 19 Mar 2018 13:43:22 -0500	[thread overview]
Message-ID: <20180319184322.GB77194@bhelgaas-glaptop.roam.corp.google.com> (raw)
In-Reply-To: <152062141493.77693.9630397416694091342.stgit@bhelgaas-glaptop.roam.corp.google.com>

On Fri, Mar 09, 2018 at 12:59:49PM -0600, Bjorn Helgaas wrote:
> This is an attempt to move a few things out of the port driver.
> 
> I added these new patches since v1:
> 
>   Merge pcieport_if.h into portdrv.h
>     Merge pcieport_if.h and portdrv.h to reduce clutter
> 
>   Remove unnecessary "pcie_ports=auto" parameter
>     This is the default setting anyway, so specifying the parameter doesn't
>     do anything.
> 
>   Encapsulate pcie_ports_auto inside the port driver
>     "pcie_ports_auto" was declared in linux/pci.h even though nobody
>     outside the port driver used it.
> 
>   Rename and reverse sense of pcie_ports_auto
>     "pcie_ports_auto" is connected with the "pcie_ports=native" parameter,
>     so rename it to match.
> 
> Other changes since v1:
>   - Rebase onto my pci/portdrv branch.
>   - Rename pcie_resume_early() to pcie_pme_root_status_cleanup() as
>     suggested by Rafael.
>   - Add Rafael's Reviewed-by tags.
> 
> v1: https://lkml.kernel.org/r/152040297576.240786.1532465558381209070.stgit@bhelgaas-glaptop.roam.corp.google.com
> 
> ---
> 
> Bjorn Helgaas (13):
>       PCI/portdrv: Merge pcieport_if.h into portdrv.h
>       PCI/PM: Move pcie_clear_root_pme_status() to core
>       PCI/PM: Clear PCIe PME Status bit in core, not PCIe port driver
>       PCI/PM: Clear PCIe PME Status bit for Root Complex Event Collectors
>       PCI/portdrv: Disable port driver in compat mode
>       PCI/portdrv: Remove pcie_port_bus_type link order dependency
>       PCI/portdrv: Remove unused PCIE_PORT_SERVICE_VC
>       PCI/portdrv: Simplify PCIe feature permission checking
>       PCI/portdrv: Remove unnecessary include of <linux/pci-aspm.h>
>       PCI/portdrv: Remove "pcie_hp=nomsi" kernel parameter
>       PCI/portdrv: Remove unnecessary "pcie_ports=auto" parameter
>       PCI/portdrv: Encapsulate pcie_ports_auto inside the port driver
>       PCI/portdrv: Rename and reverse sense of pcie_ports_auto

I applied these with Christoph's acks and Lukas' renaming suggestion to
pci/portdrv for v4.17.

      parent reply	other threads:[~2018-03-19 18:43 UTC|newest]

Thread overview: 29+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-03-09 18:59 [PATCH v2 00/13] PCI: Simplify PCIe port driver Bjorn Helgaas
2018-03-09 18:59 ` [PATCH v2 01/13] PCI/portdrv: Merge pcieport_if.h into portdrv.h Bjorn Helgaas
2018-03-12  7:59   ` Christoph Hellwig
2018-03-09 19:00 ` [PATCH v2 02/13] PCI/PM: Move pcie_clear_root_pme_status() to core Bjorn Helgaas
2018-03-12  8:00   ` Christoph Hellwig
2018-03-09 19:00 ` [PATCH v2 03/13] PCI/PM: Clear PCIe PME Status bit in core, not PCIe port driver Bjorn Helgaas
2018-03-09 19:00 ` [PATCH v2 04/13] PCI/PM: Clear PCIe PME Status bit for Root Complex Event Collectors Bjorn Helgaas
2018-03-09 19:00 ` [PATCH v2 05/13] PCI/portdrv: Disable port driver in compat mode Bjorn Helgaas
2018-03-09 19:00 ` [PATCH v2 06/13] PCI/portdrv: Remove pcie_port_bus_type link order dependency Bjorn Helgaas
2018-03-12  8:01   ` Christoph Hellwig
2018-03-12 14:17     ` Bjorn Helgaas
2018-03-09 19:00 ` [PATCH v2 07/13] PCI/portdrv: Remove unused PCIE_PORT_SERVICE_VC Bjorn Helgaas
2018-03-12  8:02   ` Christoph Hellwig
2018-03-09 19:00 ` [PATCH v2 08/13] PCI/portdrv: Simplify PCIe feature permission checking Bjorn Helgaas
2018-03-12  8:04   ` Christoph Hellwig
2018-03-12 14:03     ` Bjorn Helgaas
2018-03-12 14:20       ` Lukas Wunner
2018-03-19 18:37         ` Bjorn Helgaas
2019-05-07 12:00   ` David Woodhouse
2019-05-07 12:49     ` Bjorn Helgaas
2019-05-07 13:02       ` David Woodhouse
2019-05-07 14:07         ` Bjorn Helgaas
2019-05-08  6:45           ` David Woodhouse
2018-03-09 19:00 ` [PATCH v2 09/13] PCI/portdrv: Remove unnecessary include of <linux/pci-aspm.h> Bjorn Helgaas
2018-03-09 19:00 ` [PATCH v2 10/13] PCI/portdrv: Remove "pcie_hp=nomsi" kernel parameter Bjorn Helgaas
2018-03-09 19:00 ` [PATCH v2 11/13] PCI/portdrv: Remove unnecessary "pcie_ports=auto" parameter Bjorn Helgaas
2018-03-09 19:00 ` [PATCH v2 12/13] PCI/portdrv: Encapsulate pcie_ports_auto inside the port driver Bjorn Helgaas
2018-03-09 19:01 ` [PATCH v2 13/13] PCI/portdrv: Rename and reverse sense of pcie_ports_auto Bjorn Helgaas
2018-03-19 18:43 ` Bjorn Helgaas [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20180319184322.GB77194@bhelgaas-glaptop.roam.corp.google.com \
    --to=helgaas@kernel.org \
    --cc=fred@fredlawl.com \
    --cc=keith.busch@intel.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pci@vger.kernel.org \
    --cc=linux-pm@vger.kernel.org \
    --cc=lukas@wunner.de \
    --cc=okaya@codeaurora.org \
    --cc=rjw@rjwysocki.net \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).