Hi all, Today's linux-next merge of the drm tree got a conflict in: drivers/gpu/vga/vga_switcheroo.c between commit: 99efde6c9bb7 ("PCI/PM: Rename pci_wakeup_bus() to pci_resume_bus()") from the pci tree and commit: 9572e6693cd7 ("vga_switcheroo: simplify the return expression of vga_switcheroo_runtime_resume") from the drm tree. I fixed it up (see below) and can carry the fix as necessary. This is now fixed as far as linux-next is concerned, but any non trivial conflicts should be mentioned to your upstream maintainer when your tree is submitted for merging. You may also want to consider cooperating with the maintainer of the conflicting tree to minimise any particularly complex conflicts. -- Cheers, Stephen Rothwell diff --cc drivers/gpu/vga/vga_switcheroo.c index 8843b078ad4e,1401fd52f37a..000000000000 --- a/drivers/gpu/vga/vga_switcheroo.c +++ b/drivers/gpu/vga/vga_switcheroo.c @@@ -1039,12 -1038,8 +1038,8 @@@ static int vga_switcheroo_runtime_resum mutex_lock(&vgasr_mutex); vga_switcheroo_power_switch(pdev, VGA_SWITCHEROO_ON); mutex_unlock(&vgasr_mutex); - pci_wakeup_bus(pdev->bus); + pci_resume_bus(pdev->bus); - ret = dev->bus->pm->runtime_resume(dev); - if (ret) - return ret; - - return 0; + return dev->bus->pm->runtime_resume(dev); } /**