linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Leonardo Bras <leobras.c@gmail.com>
To: Alexey Kardashevskiy <aik@ozlabs.ru>,
	Michael Ellerman <mpe@ellerman.id.au>,
	Benjamin Herrenschmidt <benh@kernel.crashing.org>,
	Paul Mackerras <paulus@samba.org>,
	Thiago Jung Bauermann <bauerman@linux.ibm.com>,
	Ram Pai <linuxram@us.ibm.com>
Cc: linuxppc-dev@lists.ozlabs.org, linux-kernel@vger.kernel.org,
	Oliver <oohall@gmail.com>
Subject: Re: [PATCH 3/4] powerpc/pseries/iommu: Move window-removing part of remove_ddw into remove_dma_window
Date: Mon, 22 Jun 2020 23:22:50 -0300	[thread overview]
Message-ID: <75e1ece8d8e59322fdc70a32cc3888ce45ffbd56.camel@gmail.com> (raw)
In-Reply-To: <887bf30e-ae9e-b0cb-0388-dc555692ff0a@ozlabs.ru>

On Tue, 2020-06-23 at 11:12 +1000, Alexey Kardashevskiy wrote:
> 
> On 23/06/2020 04:59, Leonardo Bras wrote:
> > Hello Alexey, thanks for the feedback!
> > 
> > On Mon, 2020-06-22 at 20:02 +1000, Alexey Kardashevskiy wrote:
> > > On 19/06/2020 15:06, Leonardo Bras wrote:
> > > > Move the window-removing part of remove_ddw into a new function
> > > > (remove_dma_window), so it can be used to remove other DMA windows.
> > > > 
> > > > It's useful for removing DMA windows that don't create DIRECT64_PROPNAME
> > > > property, like the default DMA window from the device, which uses
> > > > "ibm,dma-window".
> > > > 
> > > > Signed-off-by: Leonardo Bras <leobras.c@gmail.com>
> > > > ---
> > > >  arch/powerpc/platforms/pseries/iommu.c | 53 +++++++++++++++-----------
> > > >  1 file changed, 31 insertions(+), 22 deletions(-)
> > > > 
> > > > diff --git a/arch/powerpc/platforms/pseries/iommu.c b/arch/powerpc/platforms/pseries/iommu.c
> > > > index 5e1fbc176a37..de633f6ae093 100644
> > > > --- a/arch/powerpc/platforms/pseries/iommu.c
> > > > +++ b/arch/powerpc/platforms/pseries/iommu.c
> > > > @@ -767,25 +767,14 @@ static int __init disable_ddw_setup(char *str)
> > > >  
> > > >  early_param("disable_ddw", disable_ddw_setup);
> > > >  
> > > > -static void remove_ddw(struct device_node *np, bool remove_prop)
> > > > +static void remove_dma_window(struct device_node *pdn, u32 *ddw_avail,
> > > 
> > > You do not need the entire ddw_avail here, pass just the token you need.
> > 
> > Well, I just emulated the behavior of create_ddw() and query_ddw() as
> > both just pass the array instead of the token, even though they only
> > use a single token. 
> 
> True, there is a pattern.
> 
> > I think it's to make the rest of the code independent of the design of
> > the "ibm,ddw-applicable" array, and if it changes, only local changes
> > on the functions will be needed.
> 
> The helper removes a window, if you are going to call other operations
> in remove_dma_window(), then you'll have to change its name ;)

Not only doing new stuff, it can change the order for some reason (as
the order of the output of query), and it would need not change the
caller.

> 
> 
> > > Also, despite this particular file, the "pdn" name is usually used for
> > > struct pci_dn (not device_node), let's keep it that way.
> > 
> > Sure, I got confused for some time about this, as we have:
> > static u64 enable_ddw(struct pci_dev *dev, struct device_node *pdn).
> > but on *_ddw() we have "struct pci_dn *pdn".
> 
> True again, not the cleanest style here.
> 
> 
> > I will also add a patch that renames those 'struct device_node *pdn' to
> > something like 'struct device_node *parent_dn'.
> 
> I would not go that far, we (well, Oliver) are getting rid of many
> occurrences of pci_dn and Oliver may have a stronger opinion here.
> 
> 
> > > > +			      struct property *win)
> > > >  {
> > > >  	struct dynamic_dma_window_prop *dwp;
> > > > -	struct property *win64;
> > > > -	u32 ddw_avail[3];
> > > >  	u64 liobn;
> > > > -	int ret = 0;
> > > > -
> > > > -	ret = of_property_read_u32_array(np, "ibm,ddw-applicable",
> > > > -					 &ddw_avail[0], 3);
> > > > -
> > > > -	win64 = of_find_property(np, DIRECT64_PROPNAME, NULL);
> > > > -	if (!win64)
> > > > -		return;
> > > > -
> > > > -	if (ret || win64->length < sizeof(*dwp))
> > > > -		goto delprop;
> > > > +	int ret;
> > > >  
> > > > -	dwp = win64->value;
> > > > +	dwp = win->value;
> > > >  	liobn = (u64)be32_to_cpu(dwp->liobn);
> > > >  
> > > >  	/* clear the whole window, note the arg is in kernel pages */
> > > > @@ -793,24 +782,44 @@ static void remove_ddw(struct device_node *np, bool remove_prop)
> > > >  		1ULL << (be32_to_cpu(dwp->window_shift) - PAGE_SHIFT), dwp);
> > > >  	if (ret)
> > > >  		pr_warn("%pOF failed to clear tces in window.\n",
> > > > -			np);
> > > > +			pdn);
> > > >  	else
> > > >  		pr_debug("%pOF successfully cleared tces in window.\n",
> > > > -			 np);
> > > > +			 pdn);
> > > >  
> > > >  	ret = rtas_call(ddw_avail[2], 1, 1, NULL, liobn);
> > > >  	if (ret)
> > > >  		pr_warn("%pOF: failed to remove direct window: rtas returned "
> > > >  			"%d to ibm,remove-pe-dma-window(%x) %llx\n",
> > > > -			np, ret, ddw_avail[2], liobn);
> > > > +			pdn, ret, ddw_avail[2], liobn);
> > > >  	else
> > > >  		pr_debug("%pOF: successfully removed direct window: rtas returned "
> > > >  			"%d to ibm,remove-pe-dma-window(%x) %llx\n",
> > > > -			np, ret, ddw_avail[2], liobn);
> > > > +			pdn, ret, ddw_avail[2], liobn);
> > > > +}
> > > > +
> > > > +static void remove_ddw(struct device_node *np, bool remove_prop)
> > > > +{
> > > > +	struct property *win;
> > > > +	u32 ddw_avail[3];
> > > > +	int ret = 0;
> > > > +
> > > > +	ret = of_property_read_u32_array(np, "ibm,ddw-applicable",
> > > > +					 &ddw_avail[0], 3);
> > > > +	if (ret)
> > > > +		return;
> > > > +
> > > > +	win = of_find_property(np, DIRECT64_PROPNAME, NULL);
> > > > +	if (!win)
> > > > +		return;
> > > > +
> > > > +	if (win->length >= sizeof(struct dynamic_dma_window_prop))
> > > 
> > > Any good reason not to make it "=="? Is there something optional or we
> > > expect extension (which may not grow from the end but may add cells in
> > > between). Thanks,
> > 
> > Well, it comes from the old behavior of remove_ddw():
> > -	if (ret || win64->length < sizeof(*dwp))
> > -		goto delprop;
> > As I reversed the logic from 'if (test) go out' to 'if (!test) do
> > stuff', I also reversed (a < b) to !(a < b) => (a >= b).
> > 
> > I have no problem changing that to '==', but it will produce a
> > different behavior than before. 
> 
> I missed than, never mind then.
> 
> 
> > > 
> > > > +		remove_dma_window(np, ddw_avail, win);
> > > > +
> > > > +	if (!remove_prop)
> > > > +		return;
> > > >  
> > > > -delprop:
> > > > -	if (remove_prop)
> > > > -		ret = of_remove_property(np, win64);
> > > > +	ret = of_remove_property(np, win);
> > > >  	if (ret)
> > > >  		pr_warn("%pOF: failed to remove direct window property: %d\n",
> > > >  			np, ret);
> > > > 
> > 
> > Best regards,
> > Leonardo
> > 


  parent reply	other threads:[~2020-06-23  2:23 UTC|newest]

Thread overview: 28+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-06-19  5:06 [PATCH 0/4] Remove default DMA window before creating DDW Leonardo Bras
2020-06-19  5:06 ` [PATCH 1/4] powerpc/pseries/iommu: Update call to ibm,query-pe-dma-windows Leonardo Bras
2020-06-22 10:02   ` Alexey Kardashevskiy
2020-06-22 18:58     ` Leonardo Bras
2020-06-23  1:12       ` Alexey Kardashevskiy
2020-06-23  2:14         ` Leonardo Bras
2020-06-23  2:29           ` Alexey Kardashevskiy
2020-06-19  5:06 ` [PATCH 2/4] powerpc/pseries/iommu: Implement ibm,reset-pe-dma-windows rtas call Leonardo Bras
2020-06-22 10:02   ` Alexey Kardashevskiy
2020-06-22 18:58     ` Leonardo Bras
2020-06-23  1:11       ` Alexey Kardashevskiy
2020-06-23  2:20         ` Leonardo Bras
2020-06-19  5:06 ` [PATCH 3/4] powerpc/pseries/iommu: Move window-removing part of remove_ddw into remove_dma_window Leonardo Bras
2020-06-22 10:02   ` Alexey Kardashevskiy
2020-06-22 18:59     ` Leonardo Bras
2020-06-23  1:12       ` Alexey Kardashevskiy
2020-06-23  1:33         ` Oliver O'Halloran
2020-06-23  2:26           ` Leonardo Bras
2020-06-23  2:22         ` Leonardo Bras [this message]
2020-06-19  5:06 ` [PATCH 4/4] powerpc/pseries/iommu: Remove default DMA window before creating DDW Leonardo Bras
2020-06-20  6:13   ` kernel test robot
2020-06-22 10:02   ` Alexey Kardashevskiy
2020-06-22 18:59     ` Leonardo Bras
2020-06-23  1:11       ` Alexey Kardashevskiy
2020-06-23  2:31         ` Leonardo Bras
2020-06-23  2:35           ` Alexey Kardashevskiy
2020-06-23  2:43             ` Leonardo Bras
2020-06-23  3:52               ` Alexey Kardashevskiy

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=75e1ece8d8e59322fdc70a32cc3888ce45ffbd56.camel@gmail.com \
    --to=leobras.c@gmail.com \
    --cc=aik@ozlabs.ru \
    --cc=bauerman@linux.ibm.com \
    --cc=benh@kernel.crashing.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linuxppc-dev@lists.ozlabs.org \
    --cc=linuxram@us.ibm.com \
    --cc=mpe@ellerman.id.au \
    --cc=oohall@gmail.com \
    --cc=paulus@samba.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).