linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: luoj@codeaurora.org
To: undisclosed-recipients:;
Subject: Re: [PATCH 2/3] net: mdio-ipq4019: rename mdio_ipq4019 to mdio_ipq
Date: Mon, 02 Aug 2021 13:56:40 +0800	[thread overview]
Message-ID: <7931e7a44e9af6be9b145b264b1596cf@codeaurora.org> (raw)
In-Reply-To: <YQKp9gsnjBNmXYIc@lunn.ch>

On 2021-07-29 21:15, Andrew Lunn wrote:
> On Thu, Jul 29, 2021 at 08:53:57PM +0800, Luo Jie wrote:
>> mdio_ipq driver supports more SOCs such as ipq40xx, ipq807x,
>> ipq60xx and ipq50xx.
>> 
>> Signed-off-by: Luo Jie <luoj@codeaurora.org>
>> ---
>>  drivers/net/mdio/Kconfig                      |  6 +-
>>  drivers/net/mdio/Makefile                     |  2 +-
>>  .../net/mdio/{mdio-ipq4019.c => mdio-ipq.c}   | 66 
>> +++++++++----------
>>  3 files changed, 37 insertions(+), 37 deletions(-)
>>  rename drivers/net/mdio/{mdio-ipq4019.c => mdio-ipq.c} (81%)
> 
> Hi Luo
> 
> We don't rename files unless there is a very good reason. It makes
> back porting of fixes harder in stable. There are plenty of examples
> of files with device specific names, but supporting a broad range of
> devices. Take for example lm75, at24.
> 
> Hi Andrew
> Thanks for the comments, will update the patch set to keep the name 
> unchanged.
> 
>> -config MDIO_IPQ4019
>> -	tristate "Qualcomm IPQ4019 MDIO interface support"
>> +config MDIO_IPQ
>> +	tristate "Qualcomm IPQ MDIO interface support"
>>  	depends on HAS_IOMEM && OF_MDIO
>>  	depends on GPIOLIB && COMMON_CLK && RESET_CONTROLLER
>>  	help
>>  	  This driver supports the MDIO interface found in Qualcomm
>> -	  IPQ40xx series Soc-s.
>> +	  IPQ40xx, IPQ60XX, IPQ807X and IPQ50XX series Soc-s.
> 
> Please leave the MDIO_IPQ4019 unchanged, so we don't break backwards
> compatibility, but the changes to the text are O.K.
> 
> will correct it in the next patch set.
> 
>> @@ -31,38 +31,38 @@
>>  /* 0 = Clause 22, 1 = Clause 45 */
>>  #define MDIO_MODE_C45				BIT(8)
>> 
>> -#define IPQ4019_MDIO_TIMEOUT	10000
>> -#define IPQ4019_MDIO_SLEEP		10
>> +#define IPQ_MDIO_TIMEOUT	10000
>> +#define IPQ_MDIO_SLEEP		10
> 
> This sort of mass rename will also make back porting fixes
> harder. Please don't do it.
> 
> will keep it unchanged in the next patch set.
> 
>> -static const struct of_device_id ipq4019_mdio_dt_ids[] = {
>> +static const struct of_device_id ipq_mdio_dt_ids[] = {
>>  	{ .compatible = "qcom,ipq4019-mdio" },
>> +	{ .compatible = "qcom,ipq-mdio" },
>>  	{ }
>>  };
> 
> Such a generic name is not a good idea. It appears this driver is not
> compatible with the IPQ8064? It is O.K. to add more specific
> compatibles. So you could add
> 
> qcom,ipq40xx, qcom,ipq60xx, qcom,ipq807x and qcom,ipq50xx.
> 
> But really, there is no need. Take for example snps,dwmac-mdio, which
> is used in all sorts of devices.
> 
>    Andrew

> Hi Andrew, yes, this driver is not compatible with IPQ8064, but it is 
> compatible with
> the new chipset such as ipq807x, ipq60xx and ipq50xx, will take your 
> suggestion in
> the next patch set, thanks for the comments.
> 

  reply	other threads:[~2021-08-02  5:56 UTC|newest]

Thread overview: 14+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-07-29 12:53 [PATCH 1/3] net: mdio-ipq4019: Add mdio reset function Luo Jie
2021-07-29 12:53 ` [PATCH 2/3] net: mdio-ipq4019: rename mdio_ipq4019 to mdio_ipq Luo Jie
2021-07-29 13:15   ` Andrew Lunn
2021-08-02  5:56     ` luoj [this message]
2021-07-29 12:53 ` [PATCH 3/3] dt-bindings: net: rename Qualcomm IPQ MDIO bindings Luo Jie
2021-07-29 13:17   ` Andrew Lunn
2021-08-02  6:02     ` luoj
2021-07-29 13:57   ` Rob Herring
2021-07-29 17:29   ` Rob Herring
2021-08-02  7:19     ` luoj
2021-08-02 13:39       ` Andrew Lunn
2021-08-04  2:37         ` Jie Luo
2021-07-29 13:26 ` [PATCH 1/3] net: mdio-ipq4019: Add mdio reset function Andrew Lunn
2021-08-02  6:46   ` luoj

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=7931e7a44e9af6be9b145b264b1596cf@codeaurora.org \
    --to=luoj@codeaurora.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).