linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-01-25 04:13:15 to 2020-01-25 16:52:59 UTC [more...]

[PATCH 4.19 000/639] 4.19.99-stable review
 2020-01-25 16:52 UTC  (18+ messages)
` [PATCH 4.19 143/639] rtc: cmos: ignore bogus century byte
` [PATCH 4.19 151/639] arm64: dts: allwinner: h6: Move GIC device node fix base address ordering
` [PATCH 4.19 177/639] rtc: ds1307: rx8130: Fix alarm handling
` [PATCH 4.19 255/639] scsi: megaraid_sas: reduce module load time

[PATCH 1/1] io_uring: fix refcounting with OOM
 2020-01-25 16:46 UTC  (2+ messages)

[PATCH] sched/rt: optimize checking group rt scheduler constraints
 2020-01-25 16:40 UTC  (4+ messages)

[RFC net-next v3 00/10] net: bridge: mrp: Add support for Media Redundancy Protocol (MRP)
 2020-01-25 16:35 UTC  (19+ messages)
` [RFC net-next v3 02/10] net: bridge: mrp: Expose function br_mrp_port_open
` [RFC net-next v3 03/10] net: bridge: mrp: Add MRP interface used by netlink
` [RFC net-next v3 04/10] net: bridge: mrp: Add generic netlink interface to configure MRP
` [RFC net-next v3 06/10] net: bridge: mrp: switchdev: Extend switchdev API to offload MRP
` [RFC net-next v3 09/10] net: bridge: mrp: Integrate MRP into the bridge

[PATCH] fs/adfs: bigdir: Fix an error code in adfs_fplus_read()
 2020-01-25 16:32 UTC  (3+ messages)

[PATCH v2] ASoC: cros_ec_codec: Support setting bclk ratio
 2020-01-25 16:29 UTC 

[PATCH 0/3] mm/gup: track FOLL_PIN pages (follow on from v12)
 2020-01-25 16:23 UTC  (2+ messages)

[PATCH 1/2] perf report: apply --cpu filter before --switch-on/--switch-off
 2020-01-25 16:18 UTC  (3+ messages)
` [PATCH 2/2] perf evswitch: Add --switch-on-delay/--switch-off-delay

[tip: core/rcu] rcu: Enable tick for nohz_full CPUs slow to provide expedited QS
 2020-01-25 16:10 UTC  (3+ messages)

[PATCH 0/2] drm/i915/gem: conversion to new drm logging macros
 2020-01-25 16:08 UTC  (2+ messages)

[PATCH v4 bpf-next 0/3] Add bpf_perf_prog_read_branches() helper
 2020-01-25 15:47 UTC  (5+ messages)
` [PATCH v4 bpf-next 1/3] bpf: "
` [PATCH v4 bpf-next 2/3] tools/bpf: Sync uapi header bpf.h

arm64: dts: qcom: sc7180: Add cpuidle low power states
 2020-01-25 15:39 UTC  (4+ messages)
` [PATCH] "

[PATCH v2 0/6] Add RSC power domain support
 2020-01-25 15:36 UTC  (3+ messages)

[tip:x86/asm] BUILD SUCCESS 183ef7adf4ed638ac0fb0c3c9a71fc00e8512b61
 2020-01-25 15:30 UTC 

[PATCH V1] mmc: sdhci-msm: Add system suspend/resume callbacks
 2020-01-25 15:28 UTC  (2+ messages)

[PATCH v1 0/7] uml: add unspecified HAS_IOMEM dependencies
 2020-01-25 15:28 UTC  (5+ messages)
` [PATCH v1 2/7] mtd: rawnand: add unspecified HAS_IOMEM dependency

[PATCH] perf: Support Python 3.8+ in Makefile
 2020-01-25 14:56 UTC 

[PATCH v3 1/7] fs/readdir: Fix filldir() and filldir64() use of user_access_begin()
 2020-01-25 14:40 UTC  (5+ messages)
` [PATCH v3 2/7] uaccess: Tell user_access_begin() if it's for a write or not

[PATCH] powerpc/32: Add missing context synchronisation with CONFIG_VMAP_STACK
 2020-01-25 14:35 UTC  (6+ messages)

[PATCH] firestream: fix memory leaks
 2020-01-25 14:12 UTC  (3+ messages)

[PATCH v2 0/6] conversion to struct drm_device logging macros
 2020-01-25 14:31 UTC  (3+ messages)
` [PATCH v2 2/6] drm/i915/ddi: convert to struct drm_device log macros

[PATCH v2] firestream: fix memory leaks
 2020-01-25 14:33 UTC 

[PATCH] amdgpu: use dma-resv API instead of manual kmalloc
 2020-01-25 11:52 UTC  (2+ messages)

[PATCH] ASoC: cros_ec_codec: Support setting bclk ratio
 2020-01-25 14:19 UTC  (2+ messages)

[PATCH v2] drm/i915/display: conversion to new struct drm_device logging macros
 2020-01-25 14:18 UTC  (2+ messages)

[4.19] clk.c cpufreq-drv odd behavior, lima/mali450 poweron suggest, ARM mt7623
 2020-01-25 13:47 UTC 

[PATCH] staging: rtl8723bs: hal: fix condition with no effect
 2020-01-25 13:46 UTC 

[PATCH v11] x86/split_lock: Enable split lock detection by kernel
 2020-01-25 13:41 UTC  (13+ messages)
  ` [PATCH v12] "
          ` [PATCH v13] "
              ` [PATCH v14] "
                  ` [PATCH v15] "

[PATCH] staging: rtl8723bs: core: fix condition with no effect
 2020-01-25 13:34 UTC 

[PATCH 00/16] Add MHI bus support
 2020-01-25 13:26 UTC  (7+ messages)
` [PATCH 02/16] bus: mhi: core: Add support for registering MHI controllers

[PATCH] staging: comedi: drivers: fix condition with no effect
 2020-01-25 13:15 UTC 

[PATCH v7 00/11] proc: modernize proc to support multiple private instances
 2020-01-25 13:05 UTC  (12+ messages)
` [PATCH v7 01/11] proc: Rename struct proc_fs_info to proc_fs_opts
` [PATCH v7 02/11] proc: add proc_fs_info struct to store proc information
` [PATCH v7 03/11] proc: move /proc/{self|thread-self} dentries to proc_fs_info
` [PATCH v7 04/11] proc: move hide_pid, pid_gid from pid_namespace "
` [PATCH v7 05/11] proc: add helpers to set and get proc hidepid and gid mount options
` [PATCH v7 06/11] proc: support mounting procfs instances inside same pid namespace
` [PATCH v7 07/11] proc: flush task dcache entries from all procfs instances
` [PATCH v7 08/11] proc: instantiate only pids that we can ptrace on 'hidepid=4' mount option
` [PATCH v7 09/11] proc: add option to mount only a pids subset
` [PATCH v7 10/11] docs: proc: add documentation for "hidepid=4" and "subset=pidfs" options and new mount behavior
` [PATCH v7 11/11] proc: Move hidepid values to uapi as they are user interface to mount

[RESEND PATCH] staging: exfat: Fix alignment warnings
 2020-01-25 12:19 UTC 

[PATCH] staging: greybus: bootrom: fix uninitialized variables
 2020-01-25 12:14 UTC  (3+ messages)

[GIT PULL] Btrfs fix for 5.5-rc8
 2020-01-25 12:14 UTC 

irqchip: Figuring out utility of hierarchy irqdomain
 2020-01-25 12:02 UTC  (2+ messages)

[PATCH] x86/CPU/AMD: Remove amd_get_topology_early()
 2020-01-25 12:01 UTC  (2+ messages)
` [tip: x86/cleanups] "

[PATCH] pinctrl actions: Fix functions groups names
 2020-01-25 11:33 UTC  (3+ messages)
` [PATCH v2] pinctrl: "

[PATCH 0/8] media: sunxi: Add DE2 rotate driver
 2020-01-25 11:24 UTC  (5+ messages)
` [PATCH 1/8] clk: sunxi-ng: sun8i-de2: Swap A64 and H6 definitions
  ` [linux-sunxi] "

[PATCH v7 0/5] Add NUMA-awareness to qspinlock
 2020-01-25 11:23 UTC  (4+ messages)
` [PATCH v7 1/5] locking/qspinlock: Rename mcs lock/unlock macros and make them more generic

[PATCH v8 0/5] Add NUMA-awareness to qspinlock
 2020-01-25 11:20 UTC  (11+ messages)
` [PATCH v8 4/5] locking/qspinlock: Introduce starvation avoidance into CNA

[PATCH 0/5] arm64: dts: allwinner: a64: Enable deinterlace core
 2020-01-25 11:03 UTC  (6+ messages)
` [PATCH 1/5] dt-bindings: interconnect: sunxi: Add A64 MBUS compatible
` [PATCH 2/5] clk: sunxi-ng: a64: Export MBUS clock
` [PATCH 3/5] arm64: dts: allwinner: a64: Add MBUS controller node
` [PATCH 4/5] media: dt-bindings: media: Add Allwinner A64 deinterlace compatible
` [PATCH 5/5] arm64: dts: allwinner: a64: Add deinterlace core node

[RFC][PATCH 0/2] Avoiding DWC3 transfer stalls/hangs when using adb over f_fs
 2020-01-25 11:02 UTC  (7+ messages)
` [RFC][PATCH 1/2] usb: dwc3: gadget: Check for IOC/LST bit in both event->status and TRB->ctrl fields

[GIT PULL] pin control fix for v5.5
 2020-01-25 10:55 UTC 

[tip: core/rcu] powerpc: Remove comment about read_barrier_depends()
 2020-01-25 10:42 UTC 

[tip: core/rcu] srcu: Apply *_ONCE() to ->srcu_last_gp_end
 2020-01-25 10:42 UTC 

[tip: core/rcu] rcu: Provide wrappers for uses of ->rcu_read_lock_nesting
 2020-01-25 10:42 UTC 

[tip: core/rcu] rcu: Move gp_state_names[] and gp_state_getname() to tree_stall.h
 2020-01-25 10:42 UTC 

[tip: core/rcu] rcu: Clear .exp_hint only when deferred quiescent state has been reported
 2020-01-25 10:42 UTC 

[tip: core/rcu] rcu: Rename some instance of CONFIG_PREEMPTION to CONFIG_PREEMPT_RCU
 2020-01-25 10:42 UTC 

[tip: core/rcu] rcu: Fix harmless omission of "CONFIG_" from #if condition
 2020-01-25 10:42 UTC 

[PATCH 1/2] ARM: qcom_defconfig: Regenerate
 2020-01-25 10:46 UTC  (4+ messages)
` [PATCH 2/2] ARM: qcom_defconfig: Enable QRTR

[tip: core/rcu] rcu: Add multiple in-flight batches of kfree_rcu() work
 2020-01-25 10:42 UTC 

[tip: core/rcu] rcu: Remove kfree_call_rcu_nobatch()
 2020-01-25 10:42 UTC 

[tip: core/rcu] rcu: Use READ_ONCE() for ->expmask in rcu_read_unlock_special()
 2020-01-25 10:42 UTC 

[tip: core/rcu] rcu: Clear ->rcu_read_unlock_special only once
 2020-01-25 10:42 UTC 

[tip: core/rcu] rculist_nulls: Change docbook comment headers
 2020-01-25 10:42 UTC 

[tip: core/rcu] rcu: Add support for debug_objects debugging for kfree_rcu()
 2020-01-25 10:42 UTC 

[tip: core/rcu] rcuperf: Add kfree_rcu() performance Tests
 2020-01-25 10:42 UTC 

[tip: core/rcu] rcu: Make kfree_rcu() use a non-atomic ->monitor_todo
 2020-01-25 10:42 UTC 

[tip: core/rcu] rcu: Remove kfree_rcu() special casing and lazy-callback handling
 2020-01-25 10:42 UTC 

[tip: core/rcu] doc: Convert to rcubarrier.txt to ReST
 2020-01-25 10:42 UTC 

[tip: core/rcu] doc: Converted NMI-RCU.txt to NMI-RCU.rst
 2020-01-25 10:42 UTC 

[tip: core/rcu] rcutorture: Dynamically allocate rcu_fwds structure
 2020-01-25 10:42 UTC 

[tip: core/rcu] doc: Convert arrayRCU.txt to arrayRCU.rst
 2020-01-25 10:42 UTC 

[tip: core/rcu] doc: Fix typo "deference" to "dereference"
 2020-01-25 10:42 UTC 

[tip: core/rcu] torture: Hoist calls to lscpu to higher-level kvm.sh script
 2020-01-25 10:42 UTC 

[tip: core/rcu] rcu: Mark non-global functions and variables as static
 2020-01-25 10:42 UTC 

[tip: core/rcu] torture: Allow "CFLIST" to specify default list of scenarios
 2020-01-25 10:42 UTC 

[tip: core/rcu] rcutorture: Move to dynamic initialization of rcu_fwds
 2020-01-25 10:42 UTC 

[tip: core/rcu] rcu: Add and update docbook header comments in list.h
 2020-01-25 10:42 UTC 

[tip: core/rcu] doc: Updated full list of RCU API in whatisRCU.rst
 2020-01-25 10:42 UTC 

[tip: core/rcu] torture: Handle systems lacking the mpstat command
 2020-01-25 10:42 UTC 

[tip: core/rcu] rcu: Use lockdep rather than comment to enforce lock held
 2020-01-25 10:42 UTC 

[tip: core/rcu] rcu: Make PREEMPT_RCU be a modifier to TREE_RCU
 2020-01-25 10:42 UTC 

[tip: core/rcu] rcutorture: Dispense with Dracut for initrd creation
 2020-01-25 10:42 UTC 

[tip: core/rcu] rculist: Describe variadic macro argument in a Sphinx-compatible way
 2020-01-25 10:42 UTC 

[tip: core/rcu] rcu: Rename sync_rcu_preempt_exp_done() to sync_rcu_exp_done()
 2020-01-25 10:42 UTC 

[tip: core/rcu] rcu: Remove rcu_swap_protected()
 2020-01-25 10:42 UTC 

[tip: core/rcu] rcu: Avoid data-race in rcu_gp_fqs_check_wake()
 2020-01-25 10:42 UTC 

[tip: core/rcu] rcu: Substitute lookup for bit-twiddling in sync_rcu_exp_select_node_cpus()
 2020-01-25 10:42 UTC 

[tip: core/rcu] rcu: Use WRITE_ONCE() for assignments to ->pprev for hlist_nulls
 2020-01-25 10:42 UTC 

[tip: core/rcu] rcu: Avoid modifying mask_ofl_ipi in sync_rcu_exp_select_node_cpus()
 2020-01-25 10:42 UTC 

[tip: core/rcu] wireless/mediatek: Replace rcu_swap_protected() with rcu_replace_pointer()
 2020-01-25 10:42 UTC 

[tip: core/rcu] rcu: Update tree_exp.h function-header comments
 2020-01-25 10:42 UTC 

[tip: core/rcu] list: Add hlist_unhashed_lockless()
 2020-01-25 10:42 UTC 

[tip: core/rcu] doc: Convert whatisRCU.txt to .rst
 2020-01-25 10:42 UTC 

[tip: core/rcu] rcu: Fix data-race due to atomic_t copy-by-value
 2020-01-25 10:42 UTC 

[tip: core/rcu] torture: Use gawk instead of awk for systime() function
 2020-01-25 10:42 UTC 

[tip: core/rcu] rcutorture: Thread rcu_fwd pointer through forward-progress functions
 2020-01-25 10:42 UTC 

[tip: core/rcu] rcu: Replace synchronize_sched_expedited_wait() "_sched" with "_rcu"
 2020-01-25 10:42 UTC 

[tip: core/rcu] rcu: Fix missed wakeup of exp_wq waiters
 2020-01-25 10:42 UTC 

[tip: core/rcu] rcu: Use CONFIG_PREEMPTION where appropriate
 2020-01-25 10:42 UTC 

KCSAN: data-race in find_next_bit / rcu_report_exp_cpu_mult
 2020-01-25 10:42 UTC  (2+ messages)
` [tip: core/rcu] rcu: Use *_ONCE() to protect lockless ->expmask accesses

[tip: core/rcu] rcu: Allow only one expedited GP to run concurrently with wakeups
 2020-01-25 10:42 UTC 

[tip: core/rcu] rcu/nocb: Fix dump_tree hierarchy print always active
 2020-01-25 10:42 UTC 

[tip: core/rcu] net/tipc: Replace rcu_swap_protected() with rcu_replace_pointer()
 2020-01-25 10:42 UTC 

[tip: core/rcu] torture: Handle jitter for CPUs that cannot be offlined
 2020-01-25 10:42 UTC 

[tip: core/rcu] rcutorture: Pull callback forward-progress data into rcu_fwd struct
 2020-01-25 10:42 UTC 

[tip: core/rcu] rcutorture: Add worst-case call_rcu() forward-progress results
 2020-01-25 10:42 UTC 

[tip: core/rcu] rcutorture: Complete threading rcu_fwd pointers through functions
 2020-01-25 10:42 UTC 

[tip: core/rcu] doc: Convert to rcu_dereference.txt to rcu_dereference.rst
 2020-01-25 10:42 UTC 

[tip: core/rcu] rculist_nulls: Add docbook comments
 2020-01-25 10:42 UTC 

[tip: core/rcu] rcu: Add basic support for kfree_rcu() batching
 2020-01-25 10:42 UTC 

[tip: core/rcu] rcu: Add a hlist_nulls_unhashed_lockless() function
 2020-01-25 10:42 UTC 

[tip: core/rcu] rculist.h: Add list_tail_rcu()
 2020-01-25 10:42 UTC 

[tip: core/rcu] rcu: Fix tracepoint tracking RCU CPU kthread utilization
 2020-01-25 10:42 UTC 

[tip: core/rcu] .mailmap: Add entries for old paulmck@kernel.org addresses
 2020-01-25 10:42 UTC 

[tip: core/rcu] rcu: Remove the declaration of call_rcu() in tree.h
 2020-01-25 10:42 UTC 

[tip: core/rcu] rcu: Remove unused stop-machine #include
 2020-01-25 10:42 UTC 

[tip: core/rcu] rcu: Move rcu_{expedited,normal} definitions into rcupdate.h
 2020-01-25 10:42 UTC 

[tip: core/rcu] rcu: Avoid tick_dep_set_cpu() misordering
 2020-01-25 10:42 UTC 

[tip: core/rcu] rcu: Switch force_qs_rnp() to for_each_leaf_node_cpu_mask()
 2020-01-25 10:42 UTC 

[PATCH v2 00/10] Rework READ_ONCE() to improve codegen
 2020-01-25 10:34 UTC  (8+ messages)
` [PATCH v2 05/10] READ_ONCE: Enforce atomicity for {READ,WRITE}_ONCE() memory accesses
` [PATCH v2 09/10] compiler/gcc: Raise minimum GCC version for kernel builds to 4.8

[PATCH 5.4 000/102] 5.4.15-stable review
 2020-01-25 10:22 UTC  (2+ messages)

[PATCH] net: cxgb3_main: Add CAP_NET_ADMIN check to CHELSIO_GET_MEM
 2020-01-25  9:53 UTC  (3+ messages)

[PATCH V4,net-next, 0/2] hv_netvsc: Add XDP support
 2020-01-25  9:43 UTC  (2+ messages)

[PATCH 0/2] KVM: x86: do not mix raw and monotonic clocks in kvmclock
 2020-01-25  9:42 UTC  (3+ messages)

[PATCH v4 00/10] Create a userfaultfd demand paging test
 2020-01-25  9:39 UTC  (10+ messages)
` [PATCH v4 06/10] KVM: selftests: Add support for vcpu_args_set to aarch64 and s390x
` [PATCH v4 07/10] KVM: selftests: Support multiple vCPUs in demand paging test
` [PATCH v4 09/10] KVM: selftests: Stop memslot creation in KVM internal memslot region

[PATCH net-next v2] devlink: Add health recover notifications on devlink flows
 2020-01-25  9:35 UTC  (2+ messages)

[PATCH net] net: bcmgenet: Use netif_tx_napi_add() for TX NAPI
 2020-01-25  9:32 UTC  (2+ messages)

[PATCH] KVM: x86: Take a u64 when checking for a valid dr7 value
 2020-01-25  9:32 UTC  (2+ messages)

[PATCH -next] efi/libstub/x86: fix an EFI server boot failure
 2020-01-25  9:12 UTC  (4+ messages)

[PATCH 0/7] seq_file .next functions should increase position index
 2020-01-25  8:27 UTC  (3+ messages)

[PATCH] jbd2: delete the duplicated words in the comments
 2020-01-25  7:23 UTC  (2+ messages)

mmotm 2020-01-23-21-12 uploaded
 2020-01-25  7:06 UTC  (3+ messages)
` mmotm 2020-01-23-21-12 uploaded (efi)

[PATCH v4, 1/1] arm64: dts: rockchip: add ROCK Pi S DTS support
 2020-01-25  6:31 UTC 

[PATCH] drm/panel: Fix boe,tv101wum-n53 htotal timing
 2020-01-25  6:12 UTC  (2+ messages)

[PATCH v6 0/5] usb: xhci: Add support for Renesas USB controllers
 2020-01-25  5:32 UTC  (5+ messages)

INFO: rcu detected stall in ip_set_udel
 2020-01-25  5:17 UTC  (2+ messages)

[PATCH v9 0/5] Add NUMA-awareness to qspinlock
 2020-01-25  4:58 UTC  (5+ messages)

[PATCH] riscv: Introduce CONFIG_RELOCATABLE
 2020-01-25  4:57 UTC  (2+ messages)

[PATCH v3 1/7] builddeb: remove unneeded files in hdrobjfiles for headers package
 2020-01-25  4:12 UTC  (6+ messages)
` [PATCH v3 2/7] builddeb: match temporary directory name to the package name
` [PATCH v3 4/7] builddeb: avoid invoking sub-shells where possible
` [PATCH v3 5/7] builddeb: remove redundant make for ARCH=um
` [PATCH v3 6/7] builddeb: split kernel headers deployment out into a function
` [PATCH v3 7/7] builddeb: split libc "


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).