linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Li Yang <leoyang.li@nxp.com>
To: Roy Pledge <Roy.Pledge@nxp.com>
Cc: "moderated list:ARM/FREESCALE IMX / MXC ARM ARCHITECTURE" 
	<linux-arm-kernel@lists.infradead.org>,
	lkml <linux-kernel@vger.kernel.org>,
	YueHaibing <yuehaibing@huawei.com>,
	linuxppc-dev <linuxppc-dev@lists.ozlabs.org>,
	Lee Jones <lee.jones@linaro.org>
Subject: Re: [PATCH 25/25] soc: fsl: qbman: qman: Remove unused variable 'dequeue_wq'
Date: Mon, 23 Nov 2020 18:49:53 -0600	[thread overview]
Message-ID: <CADRPPNTguTHuRVhB_4QmN4N3Jorqi8y0gzm4Ew9D=qOuXqu=4g@mail.gmail.com> (raw)
In-Reply-To: <20201103152838.1290217-26-lee.jones@linaro.org>

Hi Roy,

On Tue, Nov 3, 2020 at 9:31 AM Lee Jones <lee.jones@linaro.org> wrote:
>
> Fixes the following W=1 kernel build warning(s):
>
>  drivers/soc/fsl/qbman/qman.c: In function ‘qman_shutdown_fq’:
>  drivers/soc/fsl/qbman/qman.c:2700:8: warning: variable ‘dequeue_wq’ set but not used [-Wunused-but-set-variable]
>
> Cc: Li Yang <leoyang.li@nxp.com>
> Cc: YueHaibing <yuehaibing@huawei.com>
> Cc: linuxppc-dev@lists.ozlabs.org
> Signed-off-by: Lee Jones <lee.jones@linaro.org>
> ---
>  drivers/soc/fsl/qbman/qman.c | 8 ++------
>  1 file changed, 2 insertions(+), 6 deletions(-)
>
> diff --git a/drivers/soc/fsl/qbman/qman.c b/drivers/soc/fsl/qbman/qman.c
> index 9888a70618730..62b182c3a8b04 100644
> --- a/drivers/soc/fsl/qbman/qman.c
> +++ b/drivers/soc/fsl/qbman/qman.c
> @@ -2622,7 +2622,7 @@ int qman_shutdown_fq(u32 fqid)
>         union qm_mc_command *mcc;
>         union qm_mc_result *mcr;
>         int orl_empty, drain = 0, ret = 0;
> -       u32 channel, wq, res;
> +       u32 channel, res;
>         u8 state;
>
>         p = get_affine_portal();
> @@ -2655,7 +2655,7 @@ int qman_shutdown_fq(u32 fqid)
>         DPAA_ASSERT((mcr->verb & QM_MCR_VERB_MASK) == QM_MCR_VERB_QUERYFQ);
>         /* Need to store these since the MCR gets reused */
>         channel = qm_fqd_get_chan(&mcr->queryfq.fqd);
> -       wq = qm_fqd_get_wq(&mcr->queryfq.fqd);
> +       qm_fqd_get_wq(&mcr->queryfq.fqd);

This probably is not needed also.

>
>         if (channel < qm_channel_pool1) {
>                 channel_portal = get_portal_for_channel(channel);
> @@ -2697,7 +2697,6 @@ int qman_shutdown_fq(u32 fqid)
>                          * to dequeue from the channel the FQ is scheduled on
>                          */
>                         int found_fqrn = 0;
> -                       u16 dequeue_wq = 0;
>
>                         /* Flag that we need to drain FQ */
>                         drain = 1;
> @@ -2705,11 +2704,8 @@ int qman_shutdown_fq(u32 fqid)
>                         if (channel >= qm_channel_pool1 &&
>                             channel < qm_channel_pool1 + 15) {
>                                 /* Pool channel, enable the bit in the portal */
> -                               dequeue_wq = (channel -
> -                                             qm_channel_pool1 + 1)<<4 | wq;
>                         } else if (channel < qm_channel_pool1) {
>                                 /* Dedicated channel */
> -                               dequeue_wq = wq;

With these gone, these if statements seem to be redundant.  Can you
propose an additional patch to further cleanup the code here?  Thanks.

>                         } else {
>                                 dev_err(dev, "Can't recover FQ 0x%x, ch: 0x%x",
>                                         fqid, channel);
> --
> 2.25.1
>

  reply	other threads:[~2020-11-24  0:50 UTC|newest]

Thread overview: 58+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-11-03 15:28 [PATCH 00/25] Rid W=1 warnings in SoC Lee Jones
2020-11-03 15:28 ` [PATCH 01/25] soc: bcm: brcmstb: pm: pm-arm: Provide prototype for brcmstb_pm_s3_finish() Lee Jones
2020-11-04  3:25   ` Florian Fainelli
2020-11-26  9:20     ` Lee Jones
2020-11-27 17:05       ` Florian Fainelli
2020-11-27 17:20         ` Lee Jones
2020-11-03 15:28 ` [PATCH 02/25] soc: qcom: qcom_aoss: Remove set but unused variable 'tlen' Lee Jones
2020-11-03 15:28 ` [PATCH 03/25] soc: qcom: qcom_aoss: Add missing description for 'cooling_devs' Lee Jones
2020-11-03 15:28 ` [PATCH 04/25] soc: fsl: dpio: qbman-portal: Fix a bunch of kernel-doc misdemeanours Lee Jones
2020-11-03 15:28 ` [PATCH 05/25] soc: rockchip: io-domain: Remove incorrect and incomplete comment header Lee Jones
2020-11-12 10:33   ` Lee Jones
2020-11-12 11:13     ` Heiko Stübner
2020-11-12 13:22       ` Lee Jones
2020-11-12 13:23         ` Heiko Stübner
2020-11-12 13:28           ` Lee Jones
2020-11-12 13:30             ` Heiko Stübner
2020-11-12 13:47               ` Lee Jones
2020-11-03 15:28 ` [PATCH 06/25] soc: ti: knav_qmss_queue: Remove set but unchecked variable 'ret' Lee Jones
2020-11-12 10:31   ` Lee Jones
2020-11-12 12:25     ` Tero Kristo
2020-11-12 13:21       ` Lee Jones
2020-11-12 13:33         ` Tero Kristo
2020-11-12 17:50         ` santosh.shilimkar
2020-11-12 19:02           ` Lee Jones
2020-11-12 19:47             ` santosh.shilimkar
2020-11-12 20:07               ` Lee Jones
2020-11-03 15:28 ` [PATCH 07/25] soc: ti: knav_qmss_queue: Fix a whole host of function documentation issues Lee Jones
2020-11-03 15:28 ` [PATCH 08/25] soc: ti: knav_dma: Fix a kernel function doc formatting issue Lee Jones
2020-11-03 15:28 ` [PATCH 09/25] soc: ti: pm33xx: Remove set but unused variable 'ret' Lee Jones
2020-11-03 15:28 ` [PATCH 10/25] soc: ti: wkup_m3_ipc: Document 'm3_ipc' parameter throughout Lee Jones
2020-11-03 15:28 ` [PATCH 11/25] soc: fsl: qe: qe_common: Fix misnamed function attribute 'addr' Lee Jones
2020-11-12 10:33   ` Lee Jones
2020-11-12 23:12     ` Leo Li
2020-11-13  7:15       ` Lee Jones
2020-11-03 15:28 ` [PATCH 12/25] soc: qcom: qcom-geni-se: Fix misnamed function parameter 'rx_rfr' Lee Jones
2020-11-03 15:28 ` [PATCH 13/25] soc: tegra: fuse: speedo-tegra124: Remove some set but unused variables Lee Jones
2020-11-10 19:39   ` Thierry Reding
2020-11-03 15:28 ` [PATCH 14/25] soc: samsung: s3c-pm-check: Fix incorrectly named variable 'val' Lee Jones
2020-11-03 20:38   ` Krzysztof Kozlowski
2020-11-03 15:28 ` [PATCH 15/25] soc: qcom: rpmh: Fix possible doc-rot in rpmh_write()'s header Lee Jones
2020-11-03 15:28 ` [PATCH 16/25] soc: qcom: smem: Fix formatting and missing documentation issues Lee Jones
2020-11-03 15:28 ` [PATCH 17/25] soc: qcom: smsm: Fix some kernel-doc formatting and naming problems Lee Jones
2020-11-03 15:28 ` [PATCH 18/25] soc: qcom: wcnss_ctrl: Demote non-conformant struct header and fix function headers Lee Jones
2020-11-03 15:28 ` [PATCH 19/25] soc: qcom: smp2p: Remove unused struct attribute provide another Lee Jones
2020-11-11  5:20   ` Bjorn Andersson
2020-11-11  7:11     ` Lee Jones
2020-11-03 15:28 ` [PATCH 20/25] soc: qcom: llcc-qcom: Fix expected kernel-doc formatting Lee Jones
2020-11-03 15:28 ` [PATCH 21/25] soc: qcom: rpmhpd: Provide some missing struct member descriptions Lee Jones
2020-11-03 15:28 ` [PATCH 22/25] soc: qcom: kryo-l2-accessors: Fix misnaming of 'val' Lee Jones
2020-11-03 15:28 ` [PATCH 23/25] soc: ti: k3-ringacc: Provide documentation for 'k3_ring's 'state' Lee Jones
2020-11-03 15:28 ` [PATCH 24/25] soc: tegra: fuse: speedo-tegra210: Remove a group of set but unused variables Lee Jones
2020-11-10 19:41   ` Thierry Reding
2020-11-10 21:02     ` Lee Jones
2020-11-03 15:28 ` [PATCH 25/25] soc: fsl: qbman: qman: Remove unused variable 'dequeue_wq' Lee Jones
2020-11-24  0:49   ` Li Yang [this message]
2020-11-11  5:25 ` [PATCH 00/25] Rid W=1 warnings in SoC Bjorn Andersson
2020-11-12 11:16 ` Heiko Stuebner
2020-11-24  0:44 ` Li Yang

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='CADRPPNTguTHuRVhB_4QmN4N3Jorqi8y0gzm4Ew9D=qOuXqu=4g@mail.gmail.com' \
    --to=leoyang.li@nxp.com \
    --cc=Roy.Pledge@nxp.com \
    --cc=lee.jones@linaro.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linuxppc-dev@lists.ozlabs.org \
    --cc=yuehaibing@huawei.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).