linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Arnd Bergmann <arnd@arndb.de>
To: Lee Jones <lee.jones@linaro.org>
Cc: Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	David Woodhouse <dwmw2@infradead.org>
Subject: Re: [PATCH 06/16] char: applicom: Remove 3 unused variables 'ret' and 2 instances of 'byte_reset_it'
Date: Thu, 20 May 2021 14:27:57 +0200	[thread overview]
Message-ID: <CAK8P3a0Sej06iAj_F==o3sGfNNT4d98=+0MFQCi539wO+WB9oQ@mail.gmail.com> (raw)
In-Reply-To: <20210520121347.3467794-7-lee.jones@linaro.org>

On Thu, May 20, 2021 at 2:13 PM Lee Jones <lee.jones@linaro.org> wrote:

> @@ -568,7 +565,7 @@ static ssize_t ac_read (struct file *filp, char __user *buf, size_t count, loff_
>
>                                 /* Got a packet for us */
>                                 memset(&st_loc, 0, sizeof(st_loc));
> -                               ret = do_ac_read(i, buf, &st_loc, &mailbox);
> +                               do_ac_read(i, buf, &st_loc, &mailbox);
>                                 spin_unlock_irqrestore(&apbs[i].mutex, flags);
>                                 set_current_state(TASK_RUNNING);
>                                 remove_wait_queue(&FlagSleepRec, &wait);

This change doesn't look right to me. It's clear that the code we have is bogus,
but I think what the authors intended was:

--- a/drivers/char/applicom.c
+++ b/drivers/char/applicom.c
@@ -577,7 +577,7 @@ static ssize_t ac_read (struct file *filp, char
__user *buf, size_t count, loff_
                                        return -EFAULT;
                                if (copy_to_user(buf + sizeof(st_loc),
&mailbox, sizeof(mailbox)))
                                        return -EFAULT;
-                               return tmp;
+                               return ret;
                        }

                        if (tmp > 2) {

From the git history, I can see that this got changed in linux-2.3.99,
but the previous
version just returned zero on success instead of the number of bytes,
so presumably
nobody ever cared about the returned value.

> @@ -700,7 +697,6 @@ static long ac_ioctl(struct file *file, unsigned int cmd, unsigned long arg)
>         void __iomem *pmem;
>         int ret = 0;
>         static int warncount = 10;
> -       volatile unsigned char byte_reset_it;
>         struct st_ram_io *adgl;
>         void __user *argp = (void __user *)arg;
>
> @@ -762,7 +758,7 @@ static long ac_ioctl(struct file *file, unsigned int cmd, unsigned long arg)
>
>                 for (i = 0; i < MAX_BOARD; i++) {
>                         if (apbs[i].RamIO) {
> -                               byte_reset_it = readb(apbs[i].RamIO + RAM_IT_TO_PC);
> +                               readb(apbs[i].RamIO + RAM_IT_TO_PC);
>                         }

This is a little subtle but should be fine on all architectures now. I suspect
this used to be required a long time ago before the readb() function worked
correctly everywhere.

I'm also reminded that I had meant to send a patch to move this file
to drivers/staging,
as all evidence suggests it has not been used for decades.

       Arnd

  reply	other threads:[~2021-05-20 12:29 UTC|newest]

Thread overview: 29+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-05-20 12:13 [PATCH 00/16] Rid W=1 warnings from Char Lee Jones
2021-05-20 12:13 ` [PATCH 01/16] char: pcmcia: cm4000_cs: Remove unused variable 'tmp' Lee Jones
2021-05-20 12:13 ` [PATCH 02/16] char: pcmcia: cm4040_cs: Remove unused variable 'uc' Lee Jones
2021-05-20 12:13 ` [PATCH 03/16] char: random: Include header containing our prototypes Lee Jones
2021-05-20 12:13 ` [PATCH 04/16] char: pcmcia: synclink_cs: Fix a bunch of kernel-doc issues Lee Jones
2021-05-20 12:13 ` [PATCH 05/16] " Lee Jones
2021-05-21  8:09   ` Greg Kroah-Hartman
2021-05-21  8:17     ` Lee Jones
2021-05-20 12:13 ` [PATCH 06/16] char: applicom: Remove 3 unused variables 'ret' and 2 instances of 'byte_reset_it' Lee Jones
2021-05-20 12:27   ` Arnd Bergmann [this message]
2021-05-20 12:13 ` [PATCH 07/16] char: tpm: tpm1-cmd: Fix a couple of misnamed functions Lee Jones
2021-05-20 16:41   ` Jarkko Sakkinen
2021-05-20 12:13 ` [PATCH 08/16] char: tpm: tpm_ftpm_tee: Fix a couple of kernel-doc misdemeanours Lee Jones
2021-05-20 16:43   ` Jarkko Sakkinen
2021-05-20 12:13 ` [PATCH 09/16] char: agp: backend: Demote some non-conformant kernel-doc headers Lee Jones
2021-06-17  9:52   ` Lee Jones
2021-05-20 12:13 ` [PATCH 10/16] char: agp: frontend: Include header file containing our prototypes Lee Jones
2021-05-20 12:13 ` [PATCH 11/16] char: agp: via-agp: Remove unused variable 'current_size' Lee Jones
2021-05-20 12:13 ` [PATCH 12/16] char: hpet: Remove unused variable 'm' Lee Jones
2021-05-20 12:13 ` [PATCH 13/16] char: agp: generic: Place braces around optimised out function in if() Lee Jones
2021-05-20 12:13 ` [PATCH 14/16] char: agp: uninorth-agp: Remove unused variable 'size' Lee Jones
2021-05-20 12:13 ` [PATCH 15/16] char: hw_random: pseries-rng: Demote non-conformant kernel-doc header Lee Jones
2021-05-20 12:13 ` [PATCH 16/16] char: mem: Provide local prototype for non-static function Lee Jones
2021-05-20 12:32   ` Arnd Bergmann
2021-05-20 12:56 ` [PATCH 00/16] Rid W=1 warnings from Char Arnd Bergmann
2021-05-21  7:22   ` Lee Jones
2021-05-21  7:42     ` Greg Kroah-Hartman
2021-05-21  7:44       ` Greg Kroah-Hartman
2021-05-21  7:56         ` Lee Jones

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='CAK8P3a0Sej06iAj_F==o3sGfNNT4d98=+0MFQCi539wO+WB9oQ@mail.gmail.com' \
    --to=arnd@arndb.de \
    --cc=dwmw2@infradead.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=lee.jones@linaro.org \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).