linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: SF Markus Elfring <elfring@users.sourceforge.net>
To: linux-mmc@vger.kernel.org,
	Adrian Hunter <adrian.hunter@intel.com>,
	Harjani Ritesh <riteshh@codeaurora.org>,
	Jens Axboe <axboe@fb.com>,
	Linus Walleij <linus.walleij@linaro.org>,
	Mike Christie <mchristi@redhat.com>,
	Shawn Lin <shawn.lin@rock-chips.com>,
	Ulf Hansson <ulf.hansson@linaro.org>,
	Wolfram Sang <wsa+renesas@sang-engineering.com>
Cc: LKML <linux-kernel@vger.kernel.org>, kernel-janitors@vger.kernel.org
Subject: [PATCH 6/8] mmc/core/mmc_test: Improve a size determination in five functions
Date: Sun, 8 Jan 2017 22:49:10 +0100	[thread overview]
Message-ID: <b8461289-1930-08ed-55ef-e2d7dd09a312@users.sourceforge.net> (raw)
In-Reply-To: <8e2accf5-90b3-6bd0-2abd-699927bc459b@users.sourceforge.net>

From: Markus Elfring <elfring@users.sourceforge.net>
Date: Sun, 8 Jan 2017 21:25:44 +0100

Replace the specification of a data structure by a pointer dereference
as the parameter for the operator "sizeof" to make the corresponding size
determination a bit safer according to the Linux coding style convention.

Signed-off-by: Markus Elfring <elfring@users.sourceforge.net>
---
 drivers/mmc/core/mmc_test.c | 11 +++++------
 1 file changed, 5 insertions(+), 6 deletions(-)

diff --git a/drivers/mmc/core/mmc_test.c b/drivers/mmc/core/mmc_test.c
index bb9f569a5dd5..294d3c675734 100644
--- a/drivers/mmc/core/mmc_test.c
+++ b/drivers/mmc/core/mmc_test.c
@@ -356,7 +356,7 @@ static struct mmc_test_mem *mmc_test_alloc_mem(unsigned long min_sz,
 	if (max_segs > max_page_cnt)
 		max_segs = max_page_cnt;
 
-	mem = kzalloc(sizeof(struct mmc_test_mem), GFP_KERNEL);
+	mem = kzalloc(sizeof(*mem), GFP_KERNEL);
 	if (!mem)
 		return NULL;
 
@@ -545,7 +545,7 @@ static void mmc_test_save_transfer_result(struct mmc_test_card *test,
 	if (!test->gr)
 		return;
 
-	tr = kmalloc(sizeof(struct mmc_test_transfer_result), GFP_KERNEL);
+	tr = kmalloc(sizeof(*tr), GFP_KERNEL);
 	if (!tr)
 		return;
 
@@ -2973,8 +2973,7 @@ static void mmc_test_run(struct mmc_test_card *test, int testcase)
 			}
 		}
 
-		gr = kzalloc(sizeof(struct mmc_test_general_result),
-			GFP_KERNEL);
+		gr = kzalloc(sizeof(*gr), GFP_KERNEL);
 		if (gr) {
 			INIT_LIST_HEAD(&gr->tr_lst);
 
@@ -3108,7 +3107,7 @@ static ssize_t mtf_test_write(struct file *file, const char __user *buf,
 	if (ret)
 		return ret;
 
-	test = kzalloc(sizeof(struct mmc_test_card), GFP_KERNEL);
+	test = kzalloc(sizeof(*test), GFP_KERNEL);
 	if (!test)
 		return -ENOMEM;
 
@@ -3213,7 +3212,7 @@ static int __mmc_test_register_dbgfs_file(struct mmc_card *card,
 		return -ENODEV;
 	}
 
-	df = kmalloc(sizeof(struct mmc_test_dbgfs_file), GFP_KERNEL);
+	df = kmalloc(sizeof(*df), GFP_KERNEL);
 	if (!df) {
 		debugfs_remove(file);
 		dev_err(&card->dev,
-- 
2.11.0

  parent reply	other threads:[~2017-01-08 21:50 UTC|newest]

Thread overview: 28+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-01-08 21:38 [PATCH 0/8] MMC-core: Fine-tuning for some function implementations SF Markus Elfring
2017-01-08 21:42 ` [PATCH 1/8] mmc-core: Use kmalloc_array() in mmc_test_area_init() SF Markus Elfring
2017-01-09 18:31   ` Linus Walleij
2017-01-10  7:37     ` Chunyan Zhang
2017-01-10  8:44   ` Shawn Lin
2017-01-11  1:59   ` Andy Shevchenko
2017-01-08 21:43 ` [PATCH 2/8] mmc-core: Fix a typo in a comment line SF Markus Elfring
2017-01-09 18:32   ` Linus Walleij
2017-01-10  8:43   ` Shawn Lin
2017-01-08 21:45 ` [PATCH 3/8] mmc-core: Use seq_puts() in mtf_testlist_show() SF Markus Elfring
2017-01-09 18:33   ` Linus Walleij
2017-01-10  8:41   ` Shawn Lin
2017-01-08 21:46 ` [PATCH 4/8] mmc/core/mmc_test: Add some spaces for better code readability SF Markus Elfring
2017-01-09 18:34   ` Linus Walleij
2017-01-10  8:35   ` Shawn Lin
2017-01-08 21:47 ` [PATCH 5/8] mmc/core/mmc_test: Combine substrings for 5 messages SF Markus Elfring
2017-01-09 18:35   ` Linus Walleij
2017-01-10  8:34   ` Shawn Lin
2017-01-08 21:49 ` SF Markus Elfring [this message]
2017-01-09 18:35   ` [PATCH 6/8] mmc/core/mmc_test: Improve a size determination in five functions Linus Walleij
2017-01-10  8:31   ` Shawn Lin
2017-01-08 21:50 ` [PATCH 7/8] mmc-core: Use kcalloc() in mmc_test_alloc_mem() SF Markus Elfring
2017-01-09 18:36   ` Linus Walleij
2017-01-10  8:28   ` Shawn Lin
2017-01-08 21:55 ` [PATCH 8/8] mmc-core: Use kmalloc_array() in mmc_alloc_sg() SF Markus Elfring
2017-01-09 18:37   ` Linus Walleij
2017-01-10  8:27   ` Shawn Lin
2017-01-12 12:01 ` [PATCH 0/8] MMC-core: Fine-tuning for some function implementations Ulf Hansson

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=b8461289-1930-08ed-55ef-e2d7dd09a312@users.sourceforge.net \
    --to=elfring@users.sourceforge.net \
    --cc=adrian.hunter@intel.com \
    --cc=axboe@fb.com \
    --cc=kernel-janitors@vger.kernel.org \
    --cc=linus.walleij@linaro.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mmc@vger.kernel.org \
    --cc=mchristi@redhat.com \
    --cc=riteshh@codeaurora.org \
    --cc=shawn.lin@rock-chips.com \
    --cc=ulf.hansson@linaro.org \
    --cc=wsa+renesas@sang-engineering.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).