linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Palmer Dabbelt <palmer@sifive.com>
To: mark.rutland@arm.com
Cc: linux-kernel@vger.kernel.org, mark.rutland@arm.com,
	boqun.feng@gmail.com, Will Deacon <will.deacon@arm.com>,
	vgupta@synopsys.com
Subject: Re: [PATCHv2 04/16] atomics/treewide: make atomic_fetch_add_unless() optional
Date: Mon, 04 Jun 2018 16:24:47 -0700 (PDT)	[thread overview]
Message-ID: <mhng-20f0f4d8-bc31-410d-950b-d3ae00d7a2ee@palmer-si-x1c4> (raw)
In-Reply-To: <20180529154346.3168-5-mark.rutland@arm.com>

On Tue, 29 May 2018 08:43:34 PDT (-0700), mark.rutland@arm.com wrote:
> Several architectures these have a near-identical implementation based
> on atomic_read() and atomic_cmpxchg() that we can instead define in
> <linux/atomic.h>, so let's do so, using something close to the existing
> x86 implementation with try_cmpxchg().
>
> Where an architecture provides its own atomic_fetch_add_unless(), it
> must define a preprocessor symbol for it. The instrumented atomics are
> updated accordingly.
>
> Note that arch/arc's existing atomic_fetch_add_unless() had redundant
> barriers, as these are already present in its atomic_cmpxchg()
> implementation.
>
> There should be no functional change as a result of this patch.
>
> Signed-off-by: Mark Rutland <mark.rutland@arm.com>
> Reviewed-by: Geert Uytterhoeven <geert@linux-m68k.org>
> Acked-by: Geert Uytterhoeven <geert@linux-m68k.org>
> Acked-by: Peter Zijlstra (Intel) <peterz@infradead.org>
> Cc: Boqun Feng <boqun.feng@gmail.com>
> Cc: Will Deacon <will.deacon@arm.com>
> Cc: Vineet Gupta <vgupta@synopsys.com>
> ---
>  arch/alpha/include/asm/atomic.h           |  2 +-
>  arch/arc/include/asm/atomic.h             | 28 ----------------------------
>  arch/arm/include/asm/atomic.h             | 11 +----------
>  arch/arm64/include/asm/atomic.h           |  1 -
>  arch/h8300/include/asm/atomic.h           |  1 +
>  arch/hexagon/include/asm/atomic.h         |  1 +
>  arch/ia64/include/asm/atomic.h            | 16 ----------------
>  arch/m68k/include/asm/atomic.h            | 15 ---------------
>  arch/mips/include/asm/atomic.h            | 24 ------------------------
>  arch/parisc/include/asm/atomic.h          | 24 ------------------------
>  arch/powerpc/include/asm/atomic.h         |  1 +
>  arch/riscv/include/asm/atomic.h           |  1 +
>  arch/s390/include/asm/atomic.h            | 15 ---------------
>  arch/sh/include/asm/atomic.h              | 25 -------------------------
>  arch/sparc/include/asm/atomic_32.h        |  2 ++
>  arch/sparc/include/asm/atomic_64.h        | 15 ---------------
>  arch/x86/include/asm/atomic.h             | 21 ---------------------
>  arch/xtensa/include/asm/atomic.h          | 24 ------------------------
>  include/asm-generic/atomic-instrumented.h |  4 +++-
>  include/asm-generic/atomic.h              | 11 -----------
>  include/linux/atomic.h                    | 23 +++++++++++++++++++++++
>  21 files changed, 34 insertions(+), 231 deletions(-)
> [...]
> diff --git a/arch/riscv/include/asm/atomic.h b/arch/riscv/include/asm/atomic.h
> index 18259e90f57e..5f161daefcd2 100644
> --- a/arch/riscv/include/asm/atomic.h
> +++ b/arch/riscv/include/asm/atomic.h
> @@ -349,6 +349,7 @@ static __always_inline int atomic_fetch_add_unless(atomic_t *v, int a, int u)
>  		: "memory");
>  	return prev;
>  }
> +#define atomic_fetch_add_unless atomic_fetch_add_unless
>
>  #ifndef CONFIG_GENERIC_ATOMIC64
>  static __always_inline long __atomic64_add_unless(atomic64_t *v, long a, long u)

Acked-by: Palmer Dabbelt <palmer@sifive.com>

Thanks!

  reply	other threads:[~2018-06-04 23:24 UTC|newest]

Thread overview: 33+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-05-29 15:43 [PATCHv2 00/16] atomics: API cleanups Mark Rutland
2018-05-29 15:43 ` [PATCHv2 01/16] atomics/treewide: s/__atomic_add_unless/atomic_fetch_add_unless/ Mark Rutland
2018-06-04 23:24   ` Palmer Dabbelt
2018-05-29 15:43 ` [PATCHv2 02/16] atomics/treewide: remove redundant atomic_inc_not_zero() definitions Mark Rutland
2018-06-04 23:24   ` Palmer Dabbelt
2018-05-29 15:43 ` [PATCHv2 03/16] atomics/treewide: make atomic64_inc_not_zero() optional Mark Rutland
2018-06-04 23:17   ` Palmer Dabbelt
2018-06-05  5:34     ` Mark Rutland
2018-05-29 15:43 ` [PATCHv2 04/16] atomics/treewide: make atomic_fetch_add_unless() optional Mark Rutland
2018-06-04 23:24   ` Palmer Dabbelt [this message]
2018-05-29 15:43 ` [PATCHv2 05/16] atomics: prepare for atomic64_fetch_add_unless() Mark Rutland
2018-06-05  9:26   ` Peter Zijlstra
2018-06-05  9:53     ` Mark Rutland
2018-06-05 10:54       ` Michael Ellerman
2018-06-05 11:08         ` Mark Rutland
2018-06-06  8:57           ` Michael Ellerman
2018-05-29 15:43 ` [PATCHv2 06/16] atomics/generic: define atomic64_fetch_add_unless() Mark Rutland
2018-05-29 15:43 ` [PATCHv2 07/16] atomics/alpha: " Mark Rutland
2018-05-29 15:43 ` [PATCHv2 08/16] atomics/arc: " Mark Rutland
2018-05-29 15:43 ` [PATCHv2 09/16] atomics/arm: " Mark Rutland
2018-05-29 15:43 ` [PATCHv2 10/16] atomics/powerpc: " Mark Rutland
2018-05-29 15:43 ` [PATCHv2 11/16] atomics/riscv: " Mark Rutland
2018-06-04 23:17   ` Palmer Dabbelt
2018-05-29 15:43 ` [PATCHv2 12/16] atomics/treewide: make atomic64_fetch_add_unless() optional Mark Rutland
2018-05-29 15:43 ` [PATCHv2 13/16] atomics/treewide: make test ops optional Mark Rutland
2018-06-04 23:17   ` Palmer Dabbelt
2018-05-29 15:43 ` [PATCHv2 14/16] atomics/treewide: remove atomic_inc_not_zero_hint() Mark Rutland
2018-05-29 15:43 ` [PATCHv2 15/16] atomics/treewide: make unconditional inc/dec ops optional Mark Rutland
2018-06-04 23:17   ` Palmer Dabbelt
2018-05-29 15:43 ` [PATCHv2 16/16] atomics/treewide: make conditional " Mark Rutland
2018-05-30 11:23 ` [PATCHv2 00/16] atomics: API cleanups Mark Rutland
2018-05-30 13:34   ` Mark Rutland
2018-06-05  9:43 ` Peter Zijlstra

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=mhng-20f0f4d8-bc31-410d-950b-d3ae00d7a2ee@palmer-si-x1c4 \
    --to=palmer@sifive.com \
    --cc=boqun.feng@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mark.rutland@arm.com \
    --cc=vgupta@synopsys.com \
    --cc=will.deacon@arm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).