netdev.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Andrii Nakryiko <andrii.nakryiko@gmail.com>
To: Quentin Monnet <quentin@isovalent.com>
Cc: Alexei Starovoitov <ast@kernel.org>,
	Daniel Borkmann <daniel@iogearbox.net>,
	Andrii Nakryiko <andrii@kernel.org>,
	Networking <netdev@vger.kernel.org>, bpf <bpf@vger.kernel.org>
Subject: Re: [PATCH bpf-next 1/6] libbpf: rename btf__load() as btf__load_into_kernel()
Date: Thu, 15 Jul 2021 21:32:32 -0700	[thread overview]
Message-ID: <CAEf4Bza=5GjYyDCZNMbUFyQskXunT8S3R1jCfvZmy3f1joRVFQ@mail.gmail.com> (raw)
In-Reply-To: <20210714141532.28526-2-quentin@isovalent.com>

On Wed, Jul 14, 2021 at 7:15 AM Quentin Monnet <quentin@isovalent.com> wrote:
>
> As part of the effort to move towards a v1.0 for libbpf, rename
> btf__load() function, used to "upload" BTF information into the kernel,
> and rename it instead as btf__load_into_kernel().
>
> This new name better reflects what the function does, and should be less
> confusing.
>
> References:
>
> - https://github.com/libbpf/libbpf/issues/278
> - https://github.com/libbpf/libbpf/wiki/Libbpf:-the-road-to-v1.0#btfh-apis
>
> Signed-off-by: Quentin Monnet <quentin@isovalent.com>
> ---
>  tools/lib/bpf/btf.c      | 3 ++-
>  tools/lib/bpf/btf.h      | 1 +
>  tools/lib/bpf/libbpf.c   | 2 +-
>  tools/lib/bpf/libbpf.map | 5 +++++
>  4 files changed, 9 insertions(+), 2 deletions(-)
>

[...]

> diff --git a/tools/lib/bpf/libbpf.map b/tools/lib/bpf/libbpf.map
> index 944c99d1ded3..d42f20b0e9e4 100644
> --- a/tools/lib/bpf/libbpf.map
> +++ b/tools/lib/bpf/libbpf.map
> @@ -375,3 +375,8 @@ LIBBPF_0.5.0 {
>                 bpf_object__gen_loader;
>                 libbpf_set_strict_mode;
>  } LIBBPF_0.4.0;
> +
> +LIBBPF_0.6.0 {

we haven't released v0.5 yet, so this will go into 0.5, probably

> +       global:
> +               btf__load_into_kernel;
> +} LIBBPF_0.5.0;
> --
> 2.30.2
>

  reply	other threads:[~2021-07-16  4:32 UTC|newest]

Thread overview: 13+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-07-14 14:15 [PATCH bpf-next 0/6] libbpf: rename btf__get_from_id() and btf__load() APIs, support split BTF Quentin Monnet
2021-07-14 14:15 ` [PATCH bpf-next 1/6] libbpf: rename btf__load() as btf__load_into_kernel() Quentin Monnet
2021-07-16  4:32   ` Andrii Nakryiko [this message]
2021-07-21 15:36     ` Quentin Monnet
2021-07-14 14:15 ` [PATCH bpf-next 2/6] libbpf: rename btf__get_from_id() as btf__load_from_kernel_by_id() Quentin Monnet
2021-07-16  4:35   ` Andrii Nakryiko
2021-07-14 14:15 ` [PATCH bpf-next 3/6] tools: replace btf__get_from_id() with btf__load_from_kernel_by_id() Quentin Monnet
2021-07-14 14:15 ` [PATCH bpf-next 4/6] libbpf: explicitly mark btf__load() and btf__get_from_id() as deprecated Quentin Monnet
2021-07-16  4:42   ` Andrii Nakryiko
2021-07-14 14:15 ` [PATCH bpf-next 5/6] libbpf: add split BTF support for btf__load_from_kernel_by_id() Quentin Monnet
2021-07-16  4:44   ` Andrii Nakryiko
2021-07-14 14:15 ` [PATCH bpf-next 6/6] tools: bpftool: support dumping split BTF by id Quentin Monnet
2021-07-16  3:28 ` [PATCH bpf-next 0/6] libbpf: rename btf__get_from_id() and btf__load() APIs, support split BTF John Fastabend

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='CAEf4Bza=5GjYyDCZNMbUFyQskXunT8S3R1jCfvZmy3f1joRVFQ@mail.gmail.com' \
    --to=andrii.nakryiko@gmail.com \
    --cc=andrii@kernel.org \
    --cc=ast@kernel.org \
    --cc=bpf@vger.kernel.org \
    --cc=daniel@iogearbox.net \
    --cc=netdev@vger.kernel.org \
    --cc=quentin@isovalent.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).