qemu-devel.nongnu.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-12-08 20:28:03 to 2020-12-09 09:28:59 UTC [more...]

[RFC PATCH 00/27] vDPA software assisted live migration
 2020-12-09  9:26 UTC  (3+ messages)

[PATCH 1/1] Avoid migration if guest is in postmigrated status
 2020-12-09  9:23 UTC  (2+ messages)

[RFC v9 00/22] i386 cleanup
 2020-12-09  9:22 UTC  (45+ messages)
` [RFC v9 01/32] accel/tcg: split CpusAccel into three TCG variants
` [RFC v9 02/32] accel/tcg: split tcg_start_vcpu_thread
` [RFC v9 03/32] accel/tcg: rename tcg-cpus functions to match module name
` [RFC v9 04/32] i386: move kvm accel files into kvm/
` [RFC v9 05/32] i386: move whpx accel files into whpx/
` [RFC v9 06/32] i386: move hax accel files into hax/
` [RFC v9 07/32] i386: hvf: remove stale MAINTAINERS entry for old hvf stubs
` [RFC v9 08/32] i386: move TCG accel files into tcg/
` [RFC v9 09/32] i386: move cpu dump out of helper.c into cpu-dump.c
` [RFC v9 10/32] i386: move TCG cpu class initialization out of helper.c
` [RFC v9 11/32] tcg: cpu_exec_{enter,exit} helpers
` [RFC v9 12/32] tcg: make CPUClass.cpu_exec_* optional
` [RFC v9 13/32] tcg: Make CPUClass.debug_excp_handler optional
` [RFC v9 14/32] cpu: Remove unnecessary noop methods
` [RFC v9 15/32] cpu: Introduce TCGCpuOperations struct
` [RFC v9 16/32] target/riscv: remove CONFIG_TCG, as it is always TCG
` [RFC v9 17/32] accel/tcg: split TCG-only code from cpu_exec_realizefn
` [RFC v9 18/32] cpu: Move synchronize_from_tb() to tcg_ops
` [RFC v9 19/32] cpu: Move cpu_exec_* "
` [RFC v9 20/32] cpu: Move tlb_fill "
` [RFC v9 21/32] cpu: Move debug_excp_handler "
` [RFC v9 22/32] target/arm: do not use cc->do_interrupt for KVM directly
` [RFC v9 23/32] cpu: move cc->do_interrupt to tcg_ops
` [RFC v9 24/32] cpu: move cc->transaction_failed "
` [RFC v9 25/32] cpu: move do_unaligned_access "
` [RFC v9 26/32] accel: extend AccelState and AccelClass to user-mode
` [RFC v9 27/32] accel: replace struct CpusAccel with AccelOpsClass
` [RFC v9 28/32] accel: introduce AccelCPUClass extending CPUClass
` [RFC v9 29/32] i386: split cpu accelerators from cpu.c, using AccelCPUClass
` [RFC v9 30/32] cpu: call AccelCPUClass::cpu_realizefn in cpu_exec_realizefn
` [RFC v9 31/32] hw/core/cpu: call qemu_init_vcpu in cpu_common_realizefn
` [RFC v9 32/32] cpu: introduce cpu_accel_instance_init

[Bug 1907427] [NEW] Build on sparc64 fails with "undefined reference to `fdt_check_full'"
 2020-12-09  9:13 UTC 

[PATCH 00/17] target/mips: Convert MSA ASE to decodetree
 2020-12-09  9:17 UTC  (14+ messages)
` [PATCH 11/17] target/mips: Move msa_reset() to mod-msa_helper.c
` [PATCH 14/17] target/mips: Declare gen_msa/_branch() in 'translate.h'
` [PATCH 16/17] target/mips: Introduce decode tree bindings for MSA opcodes
` [PATCH 17/17] target/mips: Use decode_msa32() generated from decodetree

[PATCH] s390x: pv: Fence additional unavailable SCLP facilities for PV guests
 2020-12-09  8:54 UTC  (6+ messages)

[PATCH 0/4] clock: Get rid of clock_get_ns()
 2020-12-09  8:50 UTC  (13+ messages)
` [PATCH 1/4] clock: Introduce clock_ticks_to_ns()
` [PATCH 2/4] target/mips: Don't use clock_get_ns() in clock period calculation
` [PATCH 3/4] clock: Remove clock_get_ns()
` [PATCH 4/4] clock: Define and use new clock_display_freq()

[PATCH 1/3] net: checksum: Skip fragmented IP packets
 2020-12-09  8:33 UTC  (3+ messages)
` [PATCH 3/3] net: checksum: Introduce fine control over checksum type

[RFC PATCH v2 0/3] vfio: Some fixes and optimizations for VFIO migration
 2020-12-09  8:09 UTC  (4+ messages)
` [RFC PATCH v2 1/3] vfio: Move the saving of the config space to the right place in "
` [RFC PATCH v2 2/3] vfio: Set the priority of the VFIO VM state change handler explicitly
` [RFC PATCH v2 3/3] vfio: Avoid disabling and enabling vectors repeatedly in VFIO migration

[PATCH 0/7] Fix some memleaks caused by ptimer_init
 2020-12-09  8:07 UTC  (2+ messages)

[PATCH 0/8] Add RISC-V semihosting 0.2. Finish ARM semihosting 2.0
 2020-12-09  7:58 UTC  (3+ messages)
` [PATCH 5/8] riscv: Add semihosting support [v13]

[PATCH] fsdev: open brace '{' following struct go on the same line
 2020-12-09  7:52 UTC  (2+ messages)

[PATCH v5 0/4] migration: UFFD write-tracking migration/snapshots
 2020-12-09  7:17 UTC  (6+ messages)
` [PATCH v5 1/4] migration: introduce 'background-snapshot' migration capability

[PATCH] bugfix: hostmem: Free host_nodes list right after visited
 2020-12-09  6:58 UTC  (2+ messages)

[PATCH v11 00/13] hw/block/nvme: Support Namespace Types and Zoned Namespace Command Set
 2020-12-09  6:37 UTC  (15+ messages)
` [PATCH v11 01/13] hw/block/nvme: Process controller reset and shutdown differently
` [PATCH v11 02/13] hw/block/nvme: Generate namespace UUIDs
` [PATCH v11 03/13] hw/block/nvme: Separate read and write handlers
` [PATCH v11 04/13] hw/block/nvme: Combine nvme_write_zeroes() and nvme_write()
` [PATCH v11 05/13] hw/block/nvme: Add Commands Supported and Effects log
` [PATCH v11 06/13] hw/block/nvme: Add support for Namespace Types
` [PATCH v11 07/13] hw/block/nvme: Support allocated CNS command variants
` [PATCH v11 08/13] block/nvme: Make ZNS-related definitions
` [PATCH v11 09/13] hw/block/nvme: Support Zoned Namespace Command Set
` [PATCH v11 10/13] hw/block/nvme: Introduce max active and open zone limits
` [PATCH v11 11/13] hw/block/nvme: Support Zone Descriptor Extensions
` [PATCH v11 12/13] hw/block/nvme: Add injection of Offline/Read-Only zones
` [PATCH v11 13/13] hw/block/nvme: Document zoned parameters in usage text

[PATCH] file-posix: detect the lock using the real file
 2020-12-09  4:54 UTC  (6+ messages)
` [PATCH v2] "

Implementing Custom USB HID Device
 2020-12-09  4:49 UTC 

[PATCH v3] qom: code hardening - have bound checking while looping with integer value
 2020-12-09  4:33 UTC  (5+ messages)

[PATCH v2 0/5] Fix some style problems in contrib
 2020-12-09  3:04 UTC  (6+ messages)
` [PATCH v2 1/5] contrib: Don't use '#' flag of printf format
` [PATCH v2 2/5] contrib: Fix some code style problems, ERROR: "foo * bar" should be "foo *bar"
` [PATCH v2 3/5] contrib: Add spaces around operator
` [PATCH v2 4/5] contrib: space required after that ','
` [PATCH v2 5/5] contrib: Open brace '{' following struct go on the same line

[PATCH RESEND v2 0/7] some memleak trivial patchs
 2020-12-09  2:48 UTC  (2+ messages)

[PATCH] kvm: Take into account the unaligned section size when preparing bitmap
 2020-12-09  2:33 UTC  (3+ messages)

[PATCH 00/13] target/mips: Convert LSA/DLSA and part of the Rel6 removed opcodes
 2020-12-09  0:22 UTC  (17+ messages)
` [PATCH 01/13] !fixup "target/mips/translate: Add declarations for generic code"
` [PATCH 02/13] target/mips: Extract LSA/DLSA translation generators
` [PATCH 03/13] target/mips: Introduce decodetree helpers for MSA LSA/DLSA opcodes
` [PATCH 04/13] target/mips: Introduce decodetree helpers for Release6 "
` [PATCH 05/13] target/mips: Remove now unreachable LSA/DLSA opcodes code
` [PATCH 06/13] target/mips: Convert Rel6 Special2 opcode to decodetree
` [PATCH 07/13] target/mips: Convert Rel6 COP1X "
` [PATCH 08/13] target/mips: Convert Rel6 CACHE/PREF opcodes "
` [PATCH 09/13] target/mips: Convert Rel6 LWL/LWR/SWL/SWR "
` [PATCH 10/13] target/mips: Convert Rel6 LWLE/LWRE/SWLE/SWRE "
` [PATCH 11/13] target/mips: Convert Rel6 LDL/LDR/SDL/SDR "
` [PATCH 12/13] target/mips: Convert Rel6 LLD/SCD "
` [PATCH 13/13] target/mips: Convert Rel6 LL/SC "

[PATCH v2 00/15] RISC-V: Start to remove xlen preprocess
 2020-12-08 22:56 UTC  (16+ messages)
` [PATCH v2 01/15] hw/riscv: Expand the is 32-bit check to support more CPUs
` [PATCH v2 02/15] target/riscv: Add a TYPE_RISCV_CPU_BASE CPU
` [PATCH v2 03/15] riscv: spike: Remove target macro conditionals
` [PATCH v2 04/15] riscv: virt: "
` [PATCH v2 05/15] hw/riscv: boot: Remove compile time XLEN checks
` [PATCH v2 06/15] hw/riscv: virt: "
` [PATCH v2 07/15] hw/riscv: spike: "
` [PATCH v2 08/15] hw/riscv: sifive_u: "
` [PATCH v2 09/15] target/riscv: fpu_helper: Match function defs in HELPER macros
` [PATCH v2 10/15] target/riscv: Add a riscv_cpu_is_32bit() helper function
` [PATCH v2 11/15] target/riscv: Specify the XLEN for CPUs
` [PATCH v2 12/15] target/riscv: cpu: Remove compile time XLEN checks
` [PATCH v2 13/15] target/riscv: cpu_helper: "
` [PATCH v2 14/15] target/riscv: csr: "
` [PATCH v2 15/15] target/riscv: cpu: Set XLEN independently from target

[PATCH 0/7] target/mips: Add translate.h and fpu_translate.h headers
 2020-12-08 22:54 UTC  (9+ messages)
` [PATCH 1/7] target/mips/translate: Extract DisasContext structure
` [PATCH 2/7] target/mips/translate: Add declarations for generic code
` [PATCH 5/7] target/mips/fpu_helper: Remove unused headers
` [PATCH 6/7] target/mips: Declare generic FPU functions in 'fpu_translate.h'

[PATCH 00/19] target/mips: Boring code reordering
 2020-12-08 22:30 UTC  (37+ messages)
` [PATCH 01/19] hw/mips: Move address translation helpers to target/mips/
` [PATCH 02/19] target/mips: Remove unused headers from translate.c
` [PATCH 03/19] target/mips: Remove unused headers from fpu_helper.c
` [PATCH 04/19] target/mips: Remove unused headers from cp0_helper.c
` [PATCH 05/19] target/mips: Remove unused headers from op_helper.c
` [PATCH 06/19] target/mips: Remove unused headers from kvm.c
` [PATCH 07/19] target/mips: Include "exec/memattrs.h" in 'internal.h'
` [PATCH 08/19] target/mips: Extract cpu_supports*/cpu_set* translate.c
` [PATCH 09/19] target/mips: Move mips_cpu_add_definition() from helper.c to cpu.c
` [PATCH 10/19] target/mips: Add !CONFIG_USER_ONLY comment after #endif
` [PATCH 11/19] target/mips: Extract common helpers from helper.c to common_helper.c
` [PATCH 12/19] target/mips: Rename helper.c as tlb_helper.c
` [PATCH 13/19] target/mips: Fix code style for checkpatch.pl
` [PATCH 14/19] target/mips: Move mmu_init() functions to tlb_helper.c
` [PATCH 15/19] target/mips: Move cpu definitions, reset() and realize() to cpu.c
` [PATCH 16/19] target/mips: Inline cpu_mips_realize_env() in mips_cpu_realizefn()
` [PATCH 17/19] target/mips: Rename translate_init.c as cpu-defs.c
` [RFC PATCH 19/19] target/mips: Only build TCG code when CONFIG_TCG is set

[PATCH RFC v4 00/15] Add riscv kvm accel support
 2020-12-08 22:29 UTC  (11+ messages)
` [PATCH RFC v4 03/15] target/riscv: Implement function kvm_arch_init_vcpu
` [PATCH RFC v4 06/15] target/riscv: Support start kernel directly by KVM
` [PATCH RFC v4 07/15] hw/riscv: PLIC update external interrupt by KVM when kvm enabled
` [PATCH RFC v4 09/15] target/riscv: Add host cpu type
` [PATCH RFC v4 13/15] target/riscv: Introduce dynamic time frequency for virt machine

[PATCH 0/2] target/mips: Let cpu_supports_isa() take CPUMIPSState argument
 2020-12-08 22:43 UTC  (2+ messages)

[PATCH v2] hw/block/nvme: add compare command
 2020-12-08 22:14 UTC  (2+ messages)

x86 TCG helpers clobbered registers
 2020-12-08 22:39 UTC  (7+ messages)

Plugin Register Accesses
 2020-12-08 22:34 UTC  (7+ messages)

[PATCH] hw/block/nvme: fix bad clearing of CAP
 2020-12-08 22:08 UTC  (2+ messages)

[PATCH v3 0/2] hw/block/nvme: add simple copy command
 2020-12-08 22:13 UTC  (3+ messages)
` [PATCH v3 2/2] "

[PATCH 0/4] Add a new -action parameter
 2020-12-08 20:59 UTC  (5+ messages)
` [PATCH 3/4] qmp: Allow setting -action parameters on the fly

[PATCH] smbios: entry-point-type option
 2020-12-08 21:20 UTC 

[PATCH 0/4] target/arm bug fix
 2020-12-08 21:04 UTC  (9+ messages)
` [PATCH 1/4] target/arm: Fixup special cross page case for sve continuous load/store
` [PATCH 2/4] target/arm: Fixup contiguous first-fault and no-fault loads
` [PATCH 3/4] target/arm: Fixup SIMD fcmla(by element) in 4H arrangement
` [PATCH 4/4] target/arm: adjust CPTR_EL2 according to HCR_EL2.E2H

[ANNOUNCE] QEMU 5.2.0 is now available
 2020-12-08 21:24 UTC 

[PATCH v9 00/12] hw/block/nvme: Support Namespace Types and Zoned Namespace Command Set
 2020-12-08 20:20 UTC  (5+ messages)
` [PATCH v9 08/12] hw/block/nvme: Support "

[PULL 00/66] pc,pci,virtio: fixes, cleanups
 2020-12-08 20:26 UTC  (13+ messages)
` [PULL 40/66] failover: Caller of this two functions already have primary_dev
` [PULL 41/66] failover: simplify failover_unplug_primary
` [PULL 46/66] libvhost-user: remove qemu/compiler.h usage
` [PULL 57/66] acpi: cpuhp: introduce 'firmware performs eject' status/control bits
` [PULL 59/66] tests/acpi: allow expected files change
` [PULL 60/66] x86: acpi: let the firmware handle pending "CPU remove" events in SMM
` [PULL 61/66] tests/acpi: update expected files
` [PULL 62/66] x86: ich9: factor out "guest_cpu_hotplug_features"
` [PULL 63/66] x86: ich9: let firmware negotiate 'CPU hot-unplug with SMI' feature
` [PULL 66/66] hw/virtio-pci Added AER capability


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).