On Tue, 2016-03-15 at 23:40 -0400, Meng Xu wrote: > > > > @@ -115,6 +118,18 @@ > > > >   #define RTDS_delayed_runq_add (1<<__RTDS_delayed_runq_add) > > > > > > > >   /* > > > > + * The replenishment timer handler needs to check this bit > > > > + * to know where a replenished vcpu was, when deciding which > > > > + * vcpu should tickle. > > > > + * A replenished vcpu should tickle if it was moved from the > > > > + * depleted queue to the run queue. > > > > + * + Set in burn_budget() if a vcpu has zero budget left. > > > > + * + Cleared and checked in the repenishment handler. > > > > > > It seems you have an extra + here... > > > Need to be removed. > > > > > > My bad, I didn't spot it out in last patch... :-( > > > > > You mean before "Cleared"? For __RTDS_scheduled there are '+' > > before > > 'Cleared', 'Checked', 'Set'. > Yes, those two +, are unnecessary. Isn't it? > I *think* the idea here was to sort of put down a bullet-ed list, but maybe we should ask the author. According to `git blame', is a certain Meng Xu, guy (commit 8726c055), anyone has his email address? :-D :-D However, I don't particularly like either the style or the final result (in terms of wording), so, let's avoid doing more of that in new code (see my other email). Regards, Dario -- <> (Raistlin Majere) ----------------------------------------------------------------- Dario Faggioli, Ph.D, http://about.me/dario.faggioli Senior Software Engineer, Citrix Systems R&D Ltd., Cambridge (UK)