xen-devel.lists.xenproject.org archive mirror
 help / color / mirror / Atom feed
From: Wei Liu <wei.liu2@citrix.com>
To: Wen Congyang <wency@cn.fujitsu.com>
Cc: Ian Jackson <ian.jackson@eu.citrix.com>,
	Andrew Cooper <andrew.cooper3@citrix.com>,
	Wei Liu <wei.liu2@citrix.com>,
	Ian Campbell <ian.campbell@citrix.com>,
	xen devel <xen-devel@lists.xen.org>
Subject: Re: [PATCH v3 3/3] libxl: rename checkpointed_stream to stream_type
Date: Fri, 11 Mar 2016 16:14:52 +0000	[thread overview]
Message-ID: <20160311161452.GY31271@citrix.com> (raw)
In-Reply-To: <1457674744-12495-3-git-send-email-wency@cn.fujitsu.com>

On Fri, Mar 11, 2016 at 01:39:04PM +0800, Wen Congyang wrote:
> Signed-off-by: Wen Congyang <wency@cn.fujitsu.com>
> ---
>  tools/libxl/libxl.c              |  4 ++--
>  tools/libxl/libxl.h              |  8 ++++++++
>  tools/libxl/libxl_create.c       |  4 ++--
>  tools/libxl/libxl_dom_save.c     |  6 +++---
>  tools/libxl/libxl_internal.h     |  2 +-
>  tools/libxl/libxl_save_callout.c |  4 ++--
>  tools/libxl/libxl_stream_read.c  |  4 ++--
>  tools/libxl/libxl_stream_write.c |  2 +-
>  tools/libxl/libxl_types.idl      |  2 +-
>  tools/libxl/xl_cmdimpl.c         | 16 ++++++++--------
>  10 files changed, 30 insertions(+), 22 deletions(-)
> 
> diff --git a/tools/libxl/libxl.c b/tools/libxl/libxl.c
> index 4cdc169..7c2c9fc 100644
> --- a/tools/libxl/libxl.c
> +++ b/tools/libxl/libxl.c
> @@ -876,7 +876,7 @@ int libxl_domain_remus_start(libxl_ctx *ctx, libxl_domain_remus_info *info,
>      dss->live = 1;
>      dss->debug = 0;
>      dss->remus = info;
> -    dss->checkpointed_stream = LIBXL_CHECKPOINTED_STREAM_REMUS;
> +    dss->stream_type = LIBXL_CHECKPOINTED_STREAM_REMUS;
>  
>      assert(info);
>  
> @@ -937,7 +937,7 @@ int libxl_domain_suspend(libxl_ctx *ctx, uint32_t domid, int fd, int flags,
>      dss->type = type;
>      dss->live = flags & LIBXL_SUSPEND_LIVE;
>      dss->debug = flags & LIBXL_SUSPEND_DEBUG;
> -    dss->checkpointed_stream = LIBXL_CHECKPOINTED_STREAM_NONE;
> +    dss->stream_type = LIBXL_CHECKPOINTED_STREAM_NONE;
>  
>      rc = libxl__fd_flags_modify_save(gc, dss->fd,
>                                       ~(O_NONBLOCK|O_NDELAY), 0,
> diff --git a/tools/libxl/libxl.h b/tools/libxl/libxl.h
> index f9e3ef5..86b1d06 100644
> --- a/tools/libxl/libxl.h
> +++ b/tools/libxl/libxl.h
> @@ -863,6 +863,14 @@ void libxl_mac_copy(libxl_ctx *ctx, libxl_mac *dst, libxl_mac *src);
>  #define LIBXL_HAVE_SRM_V1 1
>  
>  /*
> + * LIBXL_HAVE_STREAM_TYPE
> + *
> + * If this is define, then the libxl_domain_create_restore() interfaces;s
> + * parameter checkpointed_stream is renamed to stream_type
> + */
> +#define LIBXL_HAVE_STREAM_TYPE 1
> +
> +/*

I retract my ack on this patch because Andrew mentioned on IRC that you
introduced a new macro.

You should update your old one LIBXL_HAVE_CHECKPOINTED_STREAM instead.
The reason is your old code before this patch is not yet released, you
can change it at will.

Wei.

_______________________________________________
Xen-devel mailing list
Xen-devel@lists.xen.org
http://lists.xen.org/xen-devel

  parent reply	other threads:[~2016-03-11 16:14 UTC|newest]

Thread overview: 7+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-03-11  5:39 [PATCH v3 1/3] libxc: move migration_stream's definition to xenguest.h Wen Congyang
2016-03-11  5:39 ` [PATCH v3 2/3] tools: change checkpointed_stream's type from int to xc_migration_stream_t Wen Congyang
2016-03-11 14:44   ` Wei Liu
2016-03-11  5:39 ` [PATCH v3 3/3] libxl: rename checkpointed_stream to stream_type Wen Congyang
2016-03-11 14:45   ` Wei Liu
2016-03-11 16:14   ` Wei Liu [this message]
2016-03-11 14:44 ` [PATCH v3 1/3] libxc: move migration_stream's definition to xenguest.h Wei Liu

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20160311161452.GY31271@citrix.com \
    --to=wei.liu2@citrix.com \
    --cc=andrew.cooper3@citrix.com \
    --cc=ian.campbell@citrix.com \
    --cc=ian.jackson@eu.citrix.com \
    --cc=wency@cn.fujitsu.com \
    --cc=xen-devel@lists.xen.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).